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C H A P T E R  1
Overview

This section contains the following topics:

• Cisco Prime Network Services Controller Overview, page 1

• Topology Examples, page 4

• Features and Benefits, page 5

Cisco Prime Network Services Controller Overview
The dynamic nature of cloud environments requires organizations to apply and enforce frequent changes to
networks. These networks can consist of thousands of virtual services elements, such as firewalls, load
balancers, routers, and switches. Cisco PrimeNetwork Services Controller simplifies operationswith centralized,
automated multi-device and policy management for Cisco network virtual services. For the latest Prime
Network Services Controller release updates and overview, see the corresponding Prime Network Services
Controller data sheet.

Cisco Prime Network Services Controller (Prime Network Services Controller) is the primary management
element for Cisco Nexus 1000V (Nexus 1000V) Switches and Services that can enable a transparent, scalable,
and automation-centric networkmanagement solution for virtualized data center and hybrid cloud environments.
Nexus 1000V switches and services deliver a highly secure multitenant environment by adding virtualization
intelligence to the data center network. These virtual switches are built to scale for cloud networks. Support
for Virtual Extensible LAN (VXLAN) helps enable a highly scalable LAN segmentation and broader virtual
machine (VM) mobility.

Prime Network Services Controller enables the centralized management of Cisco virtual services to be
performed by an administrator, through its GUI, or programmatically through its XML API. Prime Network
Services Controller is built on an information-model architecture in which each managed device is represented
by its subcomponents (or objects), which are parametrically defined. This model-centric approach enables a
flexible and simple mechanism for provisioning and securing virtualized infrastructure using Cisco VSG and
Cisco Adaptive Security Appliance 1000V (ASA 1000V) Cloud Firewall virtual security services.

InterCloud

With Cisco Nexus 1000V InterCloud, the enterprise network can be securely extended to the cloud, with its
enterprise network and security configurations such as VLANs and policies extended to the cloud. Using
Prime Network Services Controller, workloads can be migrated from the enterprise data center to the public
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cloud while retaining the same IP addresses and other networking parameters, thus avoiding the need to
redesign the application.

Using Prime Network Services Controller, workloads in the public cloud can use the same security policies
as their counterparts in the enterprise data center. System administrators get the policy consistency and network
visibility that they require while retaining control of the cloud environment as a transparent extension of the
enterprise data center.

With Prime Network Services Controller, customers have a unified view of the workloads across the enterprise
data center (private cloud) and public cloud. They can select and migrate workloads from the enterprise data
center to the public cloud.

Hypervisor Support

The Prime Network Services Controller platform supports multiple VM Managers through their APIs and
through tight integration with Nexus 1000VVirtual SupervisorModules (VSMs) and Virtual EthernetModules
(VEMs).

Cisco Dynamic Fabric Automation Integration Support

CiscoDynamic Fabric Automation (DFA) delivers fabric optimization,management, and automation capabilities
under Cisco Unified Fabric. Prime Network Services Controller plays a critical role in the Cisco DFA solution
with L4-7 services integration. Prime Network Services Controller integrates with Cisco Data Center Network
Manager (DCNM) to support the managed resources and services in a VMware vSphere environment.

Consistent and Efficient Security Policies

Prime Network Services Controller uses security profiles for template-based configuration of security policies.
A security profile is a collection of security policy sets and integrated policies and rules that can be predefined
and applied on demand at the time of virtual machine instantiation. This profile-based approach significantly
simplifies authoring, deployment, and management of security policies, including dense multi-tenant
environments, while enhancing deployment agility and scaling. Security profiles also help reduce administrative
errors and simplify audits.

The XML API for Prime Network Services Controller facilitates integration with northbound network
provisioning tools for programmatic network and security provisioning andmanagement of Cisco VSG (VSG)
andASA 1000V. The option of programmatic control of those virtual appliances can greatly simplify operational
processes and reduce infrastructure management costs.

Nondisruptive Administration Model

By providing visual and programmatic controls, Prime Network Services Controller can enable the security
operations team to author and manage security policies for virtualized infrastructure and enhance collaboration
with the server and network operations teams. This nondisruptive administration model helps ensure
administrative segregation of duties to reduce errors and simplify regulatory compliance and auditing:

• Security administrators can author and manage security profiles and manage VSG and ASA 1000V
instances. Security profiles are referenced in Nexus 1000V port profiles.

• Network administrators can author and manage port profiles, and manage Nexus 1000V switches. Port
profiles with referenced security profiles are available in VMware vCenter through the Nexus 1000V
VSM programmatic interface with VMware vCenter.

• Server administrators can select an appropriate port profile in VMware vCenter when instantiating a
virtual machine.

Efficient Management for Easier Scalability
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Prime Network Services Controller implements an information-model architecture in which each managed
device, such as VSG or Cisco ASA 1000V, is represented by the device's object-information model. This
model-based architecture helps enable the use of:

• Statelessmanaged devices—Security policies (security templates) and object configurations are abstracted
into a centralized repository and used as templates against any virtual device type.

• Dynamic device allocation—A centralized resource management function manages pools of devices
that are commissioned (deployed) in service and a pool of devices that are available for commissioning.
This approach simplifies large-scale deployments because managed devices can be preinstantiated and
then configured on demand, and devices can be allocated and deallocated dynamically across
commissioned and noncommissioned pools.

• Scalable management—A distributed management-plane function is implemented using an embedded
agent on each managed device that helps enable greater scalability.
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Topology Examples
The following figures show virtual data center and InterCloud topology examples.

Figure 1: Virtual Data Center Topology Example

Figure 2: InterCloud Topology Example

   Cisco Prime Network Services Controller 3.2 User Guide
4

Overview
Topology Examples



Features and Benefits
The following table lists the features and benefits of using Prime Network Services Controller. For the latest
Prime Network Services Controller release description and overview, see the latest Prime Network Services
Controller data sheet and Release Notes.
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BenefitsDescriptionFeatures

• Provides secure connections
to the cloud via InterCloud
links using VMware ESXi
hypervisors.

• Enables easy creation of
templates and VMs on the
cloud.

• Supports high availability
across the InterCloud link.

PrimeNetwork Services Controller
extends your enterprise data center
into a public cloud through the
configuration and management of
InterCloud resources.

InterCloud Management

Simplifies provisioning and
troubleshooting in a scaled-out data
center.

PrimeNetwork Services Controller
provides central management of
VSG, CSR 1000V, ASA
1000V,Citrix NetScaler VPX and
Nexus 1000V .

Multiple-Device Management

Simplifies provisioning, reduces
administrative errors during load
balancing policy changes, reduces
audit complexities, and helps
enable a highly scale-out data
center environment.

An application network profile
represents load balancer server
farms and related features and
attributes.

Load Balancing Profiles

Simplifies provisioning, reduces
administrative errors during routing
policy changes, reduces audit
complexities, and helps enable a
highly scale-out data center
environment.

A network profile represents edge
router routing policies and related
features and attributes.

Routing Profiles

Simplifies provisioning, reduces
administrative errors during
security policy changes, reduces
audit complexities, and helps
enable a highly scaled-out data
center environment.

A security profile represents the
VSG or ASA 1000V security
policy configuration in a profile
(template).

Security Profiles

• Enhances scalability.

• Provides robust endpoint
failure recovery without loss
of configuration state.

The management agents in VSG
and ASA 1000V are stateless,
receiving information from Prime
Network Services Controller.

Stateless Device Provisioning
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BenefitsDescriptionFeatures

• Simplifies operation and
management of security
policies.

• Helps ensure that security
intent is accurately
represented in the associated
security policies.

Security policies are authored,
edited, and provisioned centrally.

Security Policy Management

Allows a security administrator to
institute highly specific policy
controls across the entire virtual
infrastructure.

PrimeNetwork Services Controller
obtains virtual machine contexts
from VMware vCenter.

Context-Aware Security Policies

—Cisco Prime NSC obtains tenant
information and allows virtual
services to be added to DFA virtual
overlay networks.

Support virtual services for DFA
environments

Helps enable security profiles to
stay aligned with rapid changes in
the virtual data center.

PrimeNetwork Services Controller
interacts with the Nexus 1000V
VSM to bind the security profile to
the corresponding Nexus 1000V
port profile.When virtual machines
are dynamically instantiated by
server administrators and
appropriate port profiles applied,
their association with trust zones
is also established.

Dynamic Security Policy and Zone
Provisioning

Reduces administrative errors,
helps ensure segregation of duties
in administrative teams, and
simplifies audit procedures.

PrimeNetwork Services Controller
is designed to manage VSG and
ASA 1000V security policies in a
dense multi-tenant environment so
that administrators can rapidly add
and delete tenants and update
tenant-specific configurations and
security policies.

Multi-Tenant (Scale-Out)
Management

• Reduces administrative
errors.

• Enables detailed control of
user privileges.

• Simplifies auditing
requirements.

RBAC simplifies operational tasks
across different types of
administrators, while allowing
subject-matter experts to continue
with their normal procedures.

Role-Based Access Control
(RBAC)
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BenefitsDescriptionFeatures

• Allows the use of the
best-in-class management
software.

• Offers transparent and
scalable operation
management.

PrimeNetwork Services Controller
XML API allows external system
management and orchestration
tools to programmatically provision
VSG and ASA 1000V.

XML-Based API

   Cisco Prime Network Services Controller 3.2 User Guide
8

Overview
Features and Benefits



C H A P T E R  2
Getting Started

This section contains the following topics:

• Logging Into Prime Network Services Controller, page 9

• Prime Network Services Controller Configuration Workflow, page 9

• GUI Overview, page 10

Logging Into Prime Network Services Controller
The default HTTPS URL for logging into the Prime Network Services Controller user interface is
https://server-ip-address, where server-ip-address is the IP address assigned to the Prime Network Services
Controller server. The IP address is the address for the management port.

If you log in using HTTP, you are automatically redirected to the HTTPS link.Note

Prime Network Services Controller Configuration Workflow
The following table provides the most common initial and ongoing workflow tasks to configure PrimeNetwork
Services Controller.

DescriptionInitial Configuration Tasks (Administrative)

Configure roles for user access.1. User Roles

Configure LDAP providers and select a primary authentication
service.

2. Primary Authentication

Configure trusted points for LDAP over SSL.3. Creating a Trusted Point

Configure access with hypervisors.4. Configuring VM Managers
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DescriptionInitial Configuration Tasks (Administrative)

Configure the default Prime Network Services Controller
system profile.

5. Configuring Device Policies and Profiles

Ongoing Configuration Tasks

Add tenants for resource and service support.6. Creating a Tenant

Configure access and security-related policies for access to
resources.

7. Configuring Service Policies and Profiles

Configure device-specific policies and profiles.8. Configuring Device Policies and Profiles

Add and configure enterprise and cloud resources.

To instantiate a cloud VM, use Cisco Intercloud
Fabric to import the cloud template before
instantiation in Cisco Prime Network Services
Controller.

Note

9. ConfiguringManaged Resources, on page
177

GUI Overview
PrimeNetwork Services Controller provides a browser-based interface that enables you to configure managed
endpoints, perform administrative operational tasks, and define and apply policies and profiles. You also use
the GUI to manage and provision device resources.

User Interface Components
When you log into Prime Network Services Controller, the user interface is displayed.

The Prime Network Services Controller user interface contains the components described in the following
table:

Table 1: Prime Network Services Controller User Interface Components

DescriptionComponent

Displays "Cisco PrimeNetwork Services Controller."Title

Allows you to set inactivity timeout values, obtain
product version information, access online help,
provide product feedback, and log out.

Toolbar
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DescriptionComponent

Provide access to the primary PrimeNetwork Services
Controller components for managing your
environment:

• Tenant Management

• Resource Management

• Policy Management

• InterCloud Management

• Administration

Tabs

Provides navigation to all objects in the Prime
Network Services Controller instance.

The navigation pane is displayed on the left side of
the screen below the tabs. The objects that are
displayed in the navigation pane depend on the
selected tab.

Navigation pane

Displays information and provides options for the
object that is selected in the navigation pane. The
Content pane often includes tables.

Content pane

The following table provides information about the tabs in the Prime Network Services Controller GUI:

Table 2: Tabs in the Prime Network Services Controller GUI

DescriptionTab

Enables you to manage tenants in the current Prime
Network Services Controller instance.

A system or server administrator can use this tab to
create organizational hierarchies and enable
multi-tenantmanagement domains. The organizational
hierarchy levels are Tenant > Virtual Data Center >
Application > Tier.

Tenant Management
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DescriptionTab

Enables you to manage logical resources, such as
VSGs, ASA 1000Vs, VSGs, and vCenters.

Resource Management subtabs are:

• Managed Resources

• Resources

• VMManagers

• Capabilities

• Diagnostics

Resource Management

Enables you to configure service and device policies
and profiles, and to assign policies to profiles.

Policy Management subtabs are:

• Service Profiles

• Service Policies

• Device Configurations

• Capabilities

• Diagnostics

Policy Management

Enables you to configure and monitor InterCloud
resources.

InterCloud Management subtabs are:

• Enterprise

• Public Cloud

• InterCloud Link

• InterCloud Policies

• Diagnostics

InterCloud Management

This tab is not available in Hyper-V
Hypervisor deployments.

Note

Provides the tools needed for administering Prime
Network Services Controller.

Administration subtabs are:

• Access Control

• System Profile

• Diagnostics

• Operations

• Service Registry

Administration
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Toolbar
The Prime Network Services Controller toolbar displays in the upper-right portion of the user interface. The
following table describes the toolbar options:

Table 3: Toolbar Options

DescriptionOption

Username of the current Prime Network Services
Controller session.

(username)

Enables you to specify the amount of time that the
Prime Network Services Controller session can
remain inactive before the session times out. The
value that you specify applies to the system from
which you logged into Prime Network Services
Controller.

Preferences

Logs you out of the current session.Log Out

Provides Prime Network Services Controller version
information.

About

Launches online help for the currently displayed
screen.

Help

Allows you to provide feedback on Prime Network
Services Controller.

Feedback

Tables
The tables in the Prime Network Services Controller GUI contain the following features:

DescriptionFeature

For tables that provide many actions, a drop-down
list displays the options. The actions that are available
for the selected item appear in normal font, whereas
those actions that are not available for the selected
item are dimmed.

Actions drop-down list

You can filter the table contents by a value that you
enter.

Filter

The number of entries in the table.Record count
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DescriptionFeature

You can sort all table entries by clicking on a column
heading.

Sort by column

Toolbars are available for most tables, with options
that are appropriate for the specific table.

Table-specific toolbars

Field Aids
Prime Network Services Controller includes the following aids to assist you in your tasks, whether configuring
policies and profiles, troubleshooting faults, or looking for additional information for a particular window or
dialog box.

Table 4: Prime Network Services Controller Field Aids

ExampleDescriptionFeature

Pause your cursor over a field to view
additional information about the field.

Tooltips

Indicates that information is required. If
you have entered information and the
field remains red, the entry contains an
error (such as an incomplete IP address).
You can pause your mouse over the field
to obtain information about the error.

Red field or
box

Two field icons (i and c) provide
additional information for the field:

• The "i" icon provides additional
information for the field.

• The "c" icon identifies the feature
support for the field. For example,
a feature might be supported on
ASA 1000Vs but not on VSGs.

Pause your cursor over the icon to view
the information.

Field icons
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ExampleDescriptionFeature

Fault information and links to fault
information are available for each edge
and compute firewall in Resource
Management.

Navigate to a specific compute or edge
firewall to view the object state, number
of faults, and severity of faults. The same
pane provides links to the relevant fault
page.

Fault links

Context-sensitive online help is available
for each Prime Network Services
Controller pane and dialog box.

To access help, click Help in the active
pane or ? in the active dialog box.

Online help

Firewall Access
If the Prime Network Services Controller server is protected by a firewall, the following ports must be enabled:

• 22—TCP

• 80—HTTP

• 443—HTTPS

• 843—Adobe Flash

• 6644—TCP, UDP

Idle Timeout Period
The Preferences dialog box allows you to specify the length of time, from 5 to 60 minutes, that a Prime
Network Services Controller session on your current machine can remain idle before the session is closed.
The value that you enter applies to the system that you used to log into Prime Network Services Controller.

Search
The Search tab enables you to search for instances of organizations in Prime Network Services Controller.
From the search result, you can expand an organization's hierarchy and launch devices and polices in that
organization.

Searching for organization names does not work if the organization names contain special characters.Note
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Procedure

Step 1 Do any of the following to launch the Search tab:

• Choose Policy Management > Service Policies > root > Search.

• Choose Policy Management > Service Profiles > root > Search.

• Choose Policy Management > Device Configurations > root > Search.

• Choose Tenant Management > root > Search.

• Choose Resource Management > Managed Resources > root > Search.

You can perform the Search operation at any level in the organizational hierarchy.Note

Step 2 Enter organization names as a *pattern or a regular expression.
The Search feature is case-sensitive. When you enter a name as a regular expression, it can contain regex
wildcards such as * , + , ? and so on. For example, "*" will match the previous character zero or more times.
Searching myVdc* will return all names that contain "myVd" and "myVDC".

Use the following the guidelines when you enter a pattern:

• To fetch organization names starting with "ABC", enter "ABC*".

• To fetch organization names ending with "ABC", enter "*ABC".

• To fetch organizations names starting with "A" and ending with "BC" but with other characters in
between, enter "A*BC".

Step 3 Click Search.
The search results are displayed in the table.

Clone
You can create a clone for an organization, policy, policy set, or profile at a destination of your choice. The
hierarchy of an organization's clone or the names of the elements in it cannot be changed. After a clone is
created, it cannot be renamed or moved to another location.

Procedure

Step 1 Based on the element you want to clone, do one of the following:

• To clone an organization, choose Tenant Management > root > tenant > organization.
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• To clone a policy, policy set, or profile, choose Policy Management > Service Polices > root > tenant
> Policies > policy or Policy Management > Service Profiles > root > tenant > Profiles > profile.

Step 2 Right-click the element to be cloned and choose Clone.
Step 3 In the Clone dialog box that appears:

a) Enter the name and destination of the clone.
b) Click OK.
The clone appears in the destination you chose.
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C H A P T E R  3
Configuring RBAC

This section contains the following topics:

• RBAC, page 19

• User Accounts, page 19

• User Roles, page 21

• Privileges, page 23

• User Locales, page 24

• Configuring User Roles, page 25

• Configuring User Locales, page 26

• Configuring Locally Authenticated User Accounts, page 29

• Monitoring User Sessions, page 32

RBAC
Role-Based Access Control (RBAC) is a method of restricting or authorizing system access for users based
on user roles and locales. A role defines the privileges of a user in the system and the locale defines the
organizations (domains) that a user would be able to access. Because users are not directly assigned privileges,
management of individual user privileges is simply a matter of assigning the appropriate roles and locales.

A user is granted write access to desired system resources only if the assigned role grants the access privileges
and the assigned locale allows access. For example, a user with the Server Administrator role in the Engineering
organization would be able to update server configurations in the Engineering organization but could not
update server configurations in the Finance organization unless the locales assigned to the user include the
Finance organization.

User Accounts
User accounts are used to access the system. Up to 260 local user accounts can be configured in each Prime
Network Services Controller instance. Each user account must have a unique username.
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A local user can be authenticated using a password or an SSH public key. The public key can be set in either
of the two formats: OpenSSH or SECSH.

Default User Account

Each Prime Network Services Controller instance has a default user account, admin, which cannot be modified
or deleted. This account is the system administrator or superuser account and has full privileges. There is no
default password assigned to the admin account; you must choose the password during the initial system setup.

Expiration of User Accounts

User accounts can be configured to expire at a predefined time. When the expiration time is reached, the user
account is disabled.

By default, user accounts do not expire.

Username Guidelines
The username is used as the login ID for Prime Network Services Controller. When you assign usernames to
Prime Network Services Controller user accounts, consider the following guidelines and restrictions:

• The login ID can contain from 1 to 32 characters, including the following:

◦Any alphanumeric character

◦Period (.)

◦Underscore (_)

◦Dash (-)

◦At symbol (@)

• Neither the unique username nor a local user's username can consist solely of numbers.

• The unique username cannot start with a number.

• If an all-numeric username exists on a AAA server (LDAP) and is entered during login, Prime Network
Services Controller cannot log in the user.

After you create a user account, you cannot change the username. You must delete the user account and create
a new one.

You can create up to 260 user accounts in a Prime Network Services Controller instance.Note

Password Guidelines
For authentication purposes, a password is required for each user account. To prevent users from choosing
insecure passwords, each password must be strong. If the Password Strength Check option is enabled, Prime
Network Services Controller rejects any password that does not meet the following requirements:

• Must contain a minimum of 8 characters.
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• Must contain at least three of the following:

• Lowercase letters

• Uppercase letters

• Digits

• Special characters

• Must not contain a character that is repeated more than three times consecutively, such as aaabbb.

• Must not be identical to the username or the reverse of the username.

• Must pass a password dictionary check. For example, the password must not be based on a standard
dictionary word.

• Must not contain the following symbols: dollar sign ($), question mark (?), or equals sign (=).

• Should not be blank for local user and admin accounts.

The Password Strength Check option is enabled by default. You can disable it from the Locally
Authenticated Users pane (Administration > Access Control > Locally Authenticated Users).

Note

If Prime Network Services Controller is configured to use remote authentication with LDAP, passwords
for those remote accounts can be blank. With this configuration, the remote credentials store is used for
authentication only, not authorization. The definition of the local user role definition applies to the remotely
authenticated user.

Note

User Roles
A user role contains one or more privileges that define the operations allowed for the user who is assigned to
that role. A user can be assigned one or more roles. A user assigned multiple roles has the combined privileges
of all assigned roles. For example, if Role1 has policy-related privileges, and Role2 has tenant-related privileges,
users who are assigned to both Role1 and Role2 have policy- and tenant-related privileges.

All roles include read access to all configuration settings in the Prime Network Services Controller instance.
The difference between the read-only role and other roles is that a user who is assigned only the read-only
role cannot modify the system state. A user assigned another role can modify the system state in that user's
assigned area or areas.

The system contains the following default user roles:

aaa

Users have read and write access to users, roles, and AAA configuration, and read access to the rest of
the system.
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admin

Users have read and write access to the entire system and has most privileges. However, users cannot
create or delete files, or perform system upgrades. These functions can be done only through the default
admin account. The default admin account is assigned this role by default, and it cannot be changed.

intercloud-infra

Users have read and write access for InterCloud operations, including creating InterCloud links, creating
provider accounts, managing InterCloud Extender and Switch images, and importing InterCloud Agent
images. Users with this role are limited to InterCloud functionality.

intercloud-server

Users have read and write access for cloud VMs. User can create or move VMs from the enterprise to
the cloud. Users can monitor cloud VMs for multiple tenants. Users with this role are limited to
InterCloud functionality.

network

Users can create organizations, security policies, and device profiles.

operations

Users can acknowledge faults and perform some basic operations, such as logging configuration.

read-only

Users have read-only access to system configuration and operational status with no privileges to perform
any operations.

tenant-admin

Users can configure tenant-related policies and resources for their associated tenants. However, users
can view only those objects related to their associated tenants as defined by their assigned locales and
organizations. They cannot see information about tenants that do not belong to their assigned locales
and organizations.

Roles can be created, modified to add or remove existing privileges, or deleted. When a role is modified, the
new privileges are applied to all users assigned to that role. Privilege assignment is not restricted to the
privileges defined for the default roles. That is, you can use a custom set of privileges to create a unique role.
For example, the default Network and Operations roles have different sets of privileges, but a new Network
and Operations role can be created that combines the privileges of both roles.

If a role is deleted after it has been assigned to users, it is also deleted from those user accounts.

The role and locale assignments for a local user can be changed on Prime Network Services Controller. The
role and locale for a remote user can be changed on LDAP. If any of the following information assigned to a
user is modified, the administrator must delete all existing sessions of that user so that the new privileges take
effect:

• Role

• Privilege for a role

• Locale

• Organization in a locale
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Privileges
User Privileges

Privileges give users assigned to user roles access to specific system resources and permission to perform
specific tasks. The following table lists each privilege and its description.

DescriptionPrivilege Name

System security and AAA.AAA

System administration.Admin

InterCloud infrastructure management.InterCloud-Infrastructure

InterCloud VM management.InterCloud-Server

Read-only access.

Read-only cannot be selected as a privilege; it is
assigned to every user role.

read-only

Service device configuration.Resource Configuration

Service device policies.Policy Management

Alarms and alarm policies.Fault Management

Logs, core file management, and show tech-support
command.

Operations

Create, delete, and modify tenants and organization
containers.

Tenant Management

Privileges and Role Assignments

The following table lists the out-of-box roles and the associated privileges.

Associated PrivilegesRole

aaaaaa

adminadmin

InterCloud-Infrastructureintercloud-infra

InterCloud-Serverintercloud-server

policy, res-config, tenantnetwork
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Associated PrivilegesRole

fault, operationsoperations

read-onlyread-only

policy, res-config, tenanttenant-admin

User Locales
A user can be assigned one or more locales. Each locale specifies one or more organizations or domains to
which the user is allowed access. In addition, the user has read-only access privileges outside their assigned
locale and going up the organization tree. This enables the user to use these organizations when creating
policies. One exception to this rule is a locale with root as the associated organization, which gives unrestricted
access to system resources in all organizations. Only the objects under organizations are controlled by locales.
Access to other objects such as users, roles, and resources that are not present in the organization tree are not
affected by locales.

At least one locale is required when adding a user account with either the network or tenant-admin role. If all
the locales associated with a tenant-admin or network user are deleted, the tenant-admin or network user will
not have access to the system. A user with the admin role needs to manually delete the user.

Users not assigned to a locale have access to all resources in all organizations. For users assigned to a
locale, access is restricted to the objects that reside under the organizations that belong to that locale.

Note

Users with AAA privileges (AAA role) can assign organizations to the locale of other users. The assignment
of organizations is restricted to only those in the locale of the user assigning the organizations. For example,
if a locale contains only the Engineering organization, then a user assigned to that locale can assign only the
Engineering organization to other users.

AAA privileges must be carefully assigned because they allow a user to manage other users' privileges
and role assignments.

Note

You can hierarchicallymanage organizations. A user who is assigned to a top-level organization has automatic
access to all organizations under it. For example, an Engineering organization can contain a Software
Engineering organization and a Hardware Engineering organization. A locale containing only the Software
Engineering organization has access to resources only within that organization; however, a locale that contains
the Engineering organization has access to the resources for both the Software Engineering and Hardware
Engineering organizations.

The role and locale assignments for a local user can be changed on Prime Network Services Controller. The
role and locale for a remote user can be changed on LDAP. If any of the following information assigned to a
user is modified, the administrator must delete all existing sessions of that user so that the new privileges take
effect:

• Role
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• Privilege for a role

• Locale

• Organization in a locale

Configuring User Roles

Creating a User Role

Procedure

Step 1 Choose Administration > Access Control > Roles.
Step 2 Click Create Role.
Step 3 In the Create Role dialog box, complete the following fields, then click OK:

DescriptionField

User role name.Name

Available privileges. To assign a privilege to the
selected role, check one or more of the following
check boxes:

• Admin

• AAA

• Fault Management

• InterCloud-Infrastructure

• InterCloud-Server

• Operations

• Policy Management

• Resource Configuration

• Tenant Management

You can assign the admin privilege, which
includes all privileges, or you can assign
privileges individually.

Note

Privileges
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Editing a User Role

Procedure

Step 1 Choose Administration > Access Control > Roles.
Step 2 Select the role you want to edit, then click Edit.
Step 3 In the Edit dialog box, check or uncheck the boxes for the privileges you want to add to or remove from the

role, then click OK.

Deleting a User Role
Except for the admin and read-only roles, you can delete user roles that are not appropriate for your environment.

Procedure

Step 1 Choose Administration > Access Control > Roles.
Step 2 Select the user role you want to delete, then click Delete.

You cannot delete the admin or read-only
role.

Note

Step 3 In the Confirm dialog box, click Yes.

Configuring User Locales

Creating a Locale

Before You Begin

Verify that one or more tenants exist; if none exist, create one. For information on creating tenants, see Creating
a Tenant, on page 69.

Procedure

Step 1 Choose Administration > Access Control > Locales.
Step 2 Click Create Locale.
Step 3 In the Create Locale dialog box, complete the following fields, then click OK:
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DescriptionField

Locale name, containing 2 to 255 characters. The
name can contain alphanumeric characters, hyphen
(-), underscore (_), period (.), and colon (:). You
cannot change this name after it is saved.

Name

Brief locale description, containing 1 to 256
characters. The description can contain alphanumeric
characters, hyphen (-), underscore (_), period (.), and
colon (:).

Description

Assigned Organizations

Click to assign organizations to locales.Assign Organization

List of organizations assigned to the locale.Assigned Organization

What to Do Next

Add the locale to one or more user accounts. For more information, see Changing the Locales or Roles
Assigned to a Locally Authenticated User, on page 32.

Editing a Locale

Procedure

Step 1 Choose Administration > Access Control > Locales.
Step 2 In the list of locales, select the locale you want to edit, then click Edit.
Step 3 In the Description field, change the description as appropriate.
Step 4 Click Assign Organization.
Step 5 In the Assign Organization dialog box:

a) Expand the root node to view the available organizations.
b) Check the check boxes of the organizations to assign to the locale.

Step 6 Click OK in the open dialog boxes to save your changes.
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Deleting a Locale

Before You Begin

If the locale you want to delete is assigned to any users, remove the locale from the user list of locales.Caution

If all the locales associated with a tenant-admin or network user are deleted, the tenant-admin or network
user will not have access to the system. A user with the admin role needs to manually delete the user.

Note

Procedure

Step 1 Choose Administration > Access Control > Locales.
Step 2 In the pane, click the locale you want to delete, and then click Delete.

Assigning an Organization to a Locale

Procedure

Step 1 Choose Administration > Access Control > Locales > locale, then click Assign Organization.
Step 2 In the Assign Organization dialog box:

a) Expand root to view the available organizations.
b) Check the check boxes for the organizations you want to add to the locale.

Step 3 Click OK in the open dialog boxes, then click Save to save the locale.

Deleting an Organization from a Locale

Procedure

Step 1 Choose Administration > Access Control > Locales > locale.
Step 2 In the content pane, click the General tab.
Step 3 In the Assigned Organizations area, select the organization you want to delete, then clickDelete Organization.
Step 4 When prompted, confirm the deletion, then click Save.
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Configuring Locally Authenticated User Accounts

Creating a User Account
When you create a user account, you assign one or more roles to the account. If you assign either the network
or tenant-admin role to a user, you must also assign a locale. For information on creating locales, see Creating
a Locale, on page 26.

Before You Begin

Configure locales for accounts that will require either the network or tenant-admin role.

Procedure

Step 1 Choose Administration > Access Control > Locally Authenticated Users.
Step 2 Click Create Locally Authenticated Users.
Step 3 In the Properties area, complete the following fields:

DescriptionField

Login name.

This name must be unique and meet the following
guidelines and restrictions for Prime Network
Services Controller user accounts:

• The login ID can be between 1 and 32
characters, including the following:

◦Any alphanumeric character

◦Underscore (_)

◦Dash (-)

◦At symbol (@)

• The user name for each user account cannot be
all-numeric.

• The user name cannot start with a number.

After you save the user name, it cannot be changed.
You must delete the user account and create a new
one.

Login ID

User description.Description

User first name. This field can contain up to 32
characters.

First Name
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DescriptionField

User last name. This field can contain up to 32
characters.

Last Name

User email address.Email

User telephone number.Phone

Password associated with this account.

For maximum security, each passwordmust be strong.
If the Password Strength Check check box is checked,
the system rejects any password that does not meet
the following requirements:

• Contains a minimum of eight characters

• Contains at least three of the following:

◦Lowercase letters

◦Uppercase letters

◦Digits

◦Special characters

• Does not contain a character that is repeated
more than three times consecutively, such as
aaabbb.

• Is not the user name or the reverse of the user
name.

• Passes a password dictionary check. For
example, the password must not be based on a
standard dictionary word.

• Does not contain the following symbols: dollar
sign ($), question mark (?), equals sign (=).

• The password must not be blank for local user
and admin accounts.

The password strength check box on the
Locally Authenticated Users pane can be
unchecked, indicating that the password is
not required to be strong. It must, however,
contain a minimum of eight characters. The
password field is a required field, and a user
cannot be created without providing a
password.

Note

Password

Reenter the password for confirmation purposes.Confirm Password
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DescriptionField

Indicates whether or not password expiration is
enabled. Check the check box to enable password
expiration.

Password Expires

Available if password expiration is enabled.

Date that the password expires.

Expiration Date

Step 4 In the Roles/Locales tab area, complete the following fields:
DescriptionField

Check the applicable check boxes to assign one or
more roles to the user:

You must assign a locale to a user before
you can assign the network or tenant-admin
role.

Note

• aaa

• admin

• intercloud-infra

• intercloud-server

• network

• operations

• read-only

• tenant-admin

Assigned Roles

Check the applicable check boxes to assign one or
more locales to the user.

You must assign a locale to a user before
you can assign the network or tenant-admin
role.

Note

Assigned Locale

Step 5 In the SSH tab area, complete the following fields, and then click OK:
DescriptionField

SSH key.

If you choose the Key radio button, the SSH Data
field is displayed.

Key

SSH password.Password
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DescriptionField

Available if Key is selected.

Enter the SSH public key.

SSH Data

Changing the Locales or Roles Assigned to a Locally Authenticated User

Procedure

Step 1 Choose Administration > Access Control > Locally Authenticated Users > user.
Step 2 In the General tab, click the Roles/Locales tab.
Step 3 Check or uncheck the appropriate check boxes to assign or remove a locale or role then click Save.

Monitoring User Sessions
You can monitor sessions for both locally and remotely authenticated users.

Procedure

Step 1 Choose Administration > Access Control, then choose one of the following:

• Locally Authenticated Users > user.

• Remotely Authenticated Users > user.

Step 2 Click the Sessions tab to view the user session.
DescriptionField

IP address from which the user logged in.Host

Date and time that the user logged in.Login Time

User interface for this session:

• web—GUI login

• shell—CLI login

• ep—End point

UI
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DescriptionField

Kind of terminal through which the user is logged in.Terminal Type
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C H A P T E R  4
Configuring Primary Authentication

This section includes the following topics:

• Primary Authentication, page 35

• Remote Authentication Providers, page 36

• Creating an LDAP Provider, page 36

• Editing an LDAP Provider, page 38

• Deleting an LDAP Provider, page 39

• Selecting a Primary Authentication Service, page 39

Primary Authentication
Prime Network Services Controller supports two methods to authenticate user logins:

• Local to Prime Network Services Controller

• Remote through LDAP

The role and locale assignments for a local user can be changed on Prime Network Services Controller. The
role and locale for a remote user can be changed on LDAP. If any of the following information assigned to a
user is modified, the administrator must delete all existing sessions of that user so that the new privileges take
effect:

• Role

• Privilege for a role

• Locale

• Organization in a locale
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Remote Authentication Providers
If a system is configured for a supported remote authentication service, you must create a provider for that
service to ensure that Prime Network Services Controller and the system configured with the service can
communicate.

User Accounts in Remote Authentication Services

You can create user accounts in Prime Network Services Controller or in the remote authentication server.

The temporary sessions for users who log in through remote authentication services can be viewed through
the Prime Network Services Controller GUI.

User Roles and Locales in Remote Authentication Services

If you create user accounts in the remote authentication server, you must ensure that the accounts include the
roles and locales those users require for working in Prime Network Services Controller and that the names of
those roles and locales match the names used in Prime Network Services Controller. If an account does not
have the required roles and locales, the user is granted only read-only privileges.

LDAP Attribute for User

In Prime Network Services Controller, the LDAP attribute that holds the LDAP user roles and locales is preset.
This attribute is always a name-value pair. For example, by default CiscoAvPair specifies the role and locale
information for the user, and if the filter is specified, the LDAP search is restricted to those values that match
the defined filter. By default, the filter is sAMAccountName=$userid. The user can change these values to
match the setting on the LDAP server. When a user logs in, Prime Network Services Controller checks for
the value of the attribute when it queries the remote authentication service and validates the user. The value
should be identical to the username.

An example of LDAP property settings is as follows:

• Timeout—30

• Retries—1

• Attribute—CiscoAvPair

• Filter—sAMAccountName=$userid

• Base DN—DC=cisco, DC=com (The specific location in the LDAP hierarchy where Prime Network
Services Controller starts the query for the LDAP user.)

Creating an LDAP Provider
Before You Begin

Configure users with the attribute that holds the user role and locale information for Prime Network Services
Controller. You can use an existing LDAP attribute that is mapped to the Prime Network Services Controller
user roles and locales, or you can create a custom attribute, such as the CiscoAVPair attribute, which has an
attribute ID of 1.3.6.1.4.1.9.287247.1. When you add the LDAP user to the LDAP server, specify the role
and locale in the attribute (for example, shell:roles=network,aaa shell:locale=sanjose,dallas).
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Procedure

Step 1 Choose Administration > Access Control > LDAP.
Step 2 In the content pane, click Create LDAP Provider.
Step 3 In the Create LDAP Provider dialog box, provide the following information: then click OK and Save.

DescriptionField

Hostname or IP address of the LDAP provider.

If SSL is enabled, this field must match a Common
Name (CN) in the security certificate of the LDAP
database.

If you use a hostname instead of an IP
address, you must configure a DNS server
in the Prime Network Services Controller
server.

Note

Hostname/IP Address

Password for the LDAP database account specified
in the Root DN field.

The maximum is 32 characters.

Key

Distinguished Name (DN) for an LDAP database
account that has read and search permissions for all
objects under the base DN.

The maximum supported string length is 127
characters.

Root DN

Port through which Prime Network Services
Controller communicates with the LDAP database.

The default port number is 389.

Port

Check to enable SSL.Enable SSL

Following is an example of creating an LDAP provider:

• Hostname/IP Address—Provider-blr-sam-aaa-10.cisco.com

• Key—xxxxxx (The password of the LDAP database account specified in the Root DN field.)

• Root DN— CN=bob,DC=cisco,DC=com (The value of CN is the name of a user with query privileges.
DC refers to the location in the LDAP directory where a user is created.)

• Port—389

• Enable SSL—check box
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What to Do Next

Select LDAP as the primary authentication service. For more information, see Selecting a Primary
Authentication Service, on page 39.

Editing an LDAP Provider
Procedure

Step 1 Choose Administration > Access Control > LDAP > ldap-adapter, then click Edit.
Step 2 In the Edit dialog box, modify the settings as as described in the following table, then click OK and Save.

DescriptionField

Hostname or IP address of the LDAP provider
(read-only).

If SSL is enabled, this field must match a Common
Name (CN) in the security certificate of the LDAP
database.

If you use a hostname instead of an IP
address, you must configure a DNS server
in the Prime Network Services Controller
server.

Note

Name

Password for the LDAP database account specified
in the Root DN field.

The maximum is 32 characters.

Key

Whether or not the preshared key has been set and is
properly configured (read-only).

If the Set value is Yes, and the Key field is empty, it
indicates that a key was provided previously.

Set

Distinguished Name (DN) for an LDAP database
account that has read and search permissions for all
objects under the base DN.

The maximum supported string length is 127
characters.

Root DN

Port through which Prime Network Services
Controller communicates with the LDAP database.

The default port number is 389.

Port

Check to enable SSL.Enable SSL
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Deleting an LDAP Provider
Procedure

Step 1 Choose Administration > Access Control > LDAP >ldap-provider, then click Delete.
Step 2 Confirm the deletion, then click Save.

Selecting a Primary Authentication Service

If the default authentication is set to LDAP, and the LDAP servers are not operating or are unreachable,
the local admin user can log in at any time and make changes to the authentication, authorization, and
accounting (AAA) system.

Note

Procedure

Step 1 Choose Administration > Access Control > Authentication.
Step 2 In the Properties tab, specify the information as described in the following table, then click OK.

DescriptionField

Default method by which a user is authenticated during remote login:

• LDAP—The user must be defined on the LDAP server specified
for this Prime Network Services Controller instance.

• Local—The user must be defined locally in this Prime Network
Services Controller instance.

• None—A password is not required when the user logs in remotely.

Default Authentication

Action taken when a user attempts to log in and the LDAP server does
not supply a user role with the authentication information:

• assign-default-role—The user can log in with a read-only user
role.

• no-login—The user cannot log into the system, even if the user
name and password are correct.

Role Policy to Remote Users
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C H A P T E R  5
Configuring Trusted Points

This section includes the following topics:

• Trusted Points, page 41

• Configuring Trusted Points, page 41

Trusted Points
When setting up LDAP over Secure Sockets Layer (SSL) protocol for Prime Network Services Controller
user authentication, you need to create a trusted point for each LDAP server. The certificate in the trusted
point can be any one of the following:

• The certificate of the certificate authority (CA) that issued the LDAP server certificate.

• If the CAs are organized in a hierarchy, the certificate of any of the CAs in the hierarchy.

• The certificate of the LDAP server.

Configuring Trusted Points

Creating a Trusted Point

Procedure

Step 1 Choose Administration > Access Control > Trusted Point, then click Create Trusted Point.
Step 2 In the Create Trusted Point dialog box, complete the following fields, then click OK.

DescriptionField

Trusted point name.Name

Certificate information for this trusted point.Certificate Chain
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Editing a Trusted Point

Procedure

Step 1 Choose Administration > Access Control > Trusted Point, then click Edit.
Step 2 In the Edit dialog box, modify the certificate chain as appropriate, then click OK.

The Name and Fingerprint fields cannot be modified.

Deleting a Trusted Point

Procedure

Step 1 Choose Administration > Access Control > Trusted Point > trusted-point, then click Delete.
Step 2 When prompted, confirm the deletion.
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C H A P T E R  6
Configuring VM Managers

This section includes the following topics:

• VMManager Overview, page 43

• Hypervisor and VMM Support, page 44

• Configuring Connectivity with VMware vCenter, page 45

• Configuring Connectivity with Microsoft SCVMM, page 47

• Editing a VM Manager, page 48

• Deleting a VM Manager, page 50

VM Manager Overview
After you install Prime Network Services Controller on a hypervisor, you must configure Prime Network
Services Controller so that it can communicate with the Virtual Machine Manager (VMM) for that hypervisor
and the VMs that Prime Network Services Controller manages.

Prime Network Services Controller communicates with the VMM to perform the following actions on the
VMs that Prime Network Services Controller manages:

• Obtain the VM attributes that Prime Network Services Controller uses to define security or service
policies for Nexus 1000V switches, VSG compute firewalls, and CSR 1000V edge routers.

• Instantiate, start, stop, restart, or delete VMs.

• Map VM network interfaces.

• Instantiate and configure services on service VMs.

For information on configuring VMM connectivity, see the following topics:

• Configuring Connectivity with VMware vCenter, on page 45

• Configuring Connectivity with Microsoft SCVMM, on page 47
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You must reestablish connectivity with the VMM if you change the Prime Network Services Controller
server hostname or fully qualified domain name (FQDN).

Note

Hypervisor and VMM Support
Prime Network Services Controller supports hypervisors and their VMMs as follows:

• VMware ESX with vCenter—All functionality described in VM Manager Overview, on page 43.

• Microsoft Hyper-V with SCVMM—Only read attributes and configure VSG compute firewalls.

No other VMMs are supported for managing VMs hosted by VMware ESX or Hyper-V Hypervisor.
Although SCVMMcan communicate with VMs configured on a VMware ESX hypervisor, PrimeNetwork
Services Controller support is restricted to homogeneous environments. That is, you can use SCVMM
only with Hyper-V Hypervisor and vCenter only with VMware ESX.

Note

The following table identifies the differences between the supported hypervisors with regard to Prime Network
Services Controller features and devices. Other features and devices that Prime Network Services Controller
supports but that are not listed in the table are expected to perform consistently on both hypervisors with their
respective VMMs.

Table 5: Hypervisors and Prime Network Services Controller Feature Support

Microsoft Hyper-V Hypervisor with
SCVMM

VMware ESX with vCenterFeature

AllAllNetwork attributes

Supported:

• Guest OS full name

• Port profile name

• VM DNS name

• VM name

Supported:

• Cluster name

• Guest OS full name

• Hypervisor name

• Parent application name

• Port profile name

• Resource pool

• VM DNS name

• VM name

VM attribute support

SupportedNot supportedVM Refresh button

Device and Feature Support
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Microsoft Hyper-V Hypervisor with
SCVMM

VMware ESX with vCenterFeature

Not supportedSupportedASA 1000V

Not supportedSupported (ESXi)Citrix NetScaler load balancer

Not supportedSupportedCSR 1000V

Not supportedSupported (ESXi)Integration with DCNM

Not supportedSupportedInterCloud functionality

SupportedSupportedVSG

Configuring Connectivity with VMware vCenter
Establish connectivity between Prime Network Services Controller and VMware vCenter by performing the
following tasks:

1 Exporting the vCenter Extension File, on page 45

2 Registering the vCenter Extension Plug-in in vCenter, on page 46

3 Configuring Connectivity with vCenter, on page 46

Exporting the vCenter Extension File
The first step in configuring connectivity with VMware vCenter is to export the vCenter extension file.

Before You Begin

If you use Internet Explorer, do one of the following to ensure that you can download the extension file:

• Open Internet Explorer in Administrator mode.

• After starting Internet Explorer, choose Tools > Internet Options > Security, and uncheck the Enable
Protected Mode check box.
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Procedure

Step 1 In Prime Network Services Controller, choose Resource Management > VMManagers > VMManagers.
Step 2 In the VM Managers pane, click Export vCenter Extension.
Step 3 Save the vCenter extension file in a directory that the vSphere Client can access because you will need to

register the vCenter extension plug-in from within the vSphere Client (see Registering the vCenter Extension
Plug-in in vCenter, on page 46).

Step 4 Open the XML extension file to confirm that the content is available.

Registering the vCenter Extension Plug-in in vCenter
Registering the vCenter extension plug-in enables you to create a VM Manager in Prime Network Services
Controller and communicate with the vCenter VMM and the VMs that Prime Network Services Controller
manages.

Procedure

Step 1 From the VMware vSphere Client, log in to the vCenter server that you want to manage by using Prime
Network Services Controller.

Step 2 In the vSphere Client, choose Plug-ins > Manage Plug-ins.
Step 3 Right-click the window background and choose New Plug-in.

Scroll down and right-click near the bottom of the window to view the New Plug-in option.Tip

Step 4 Browse to the Prime Network Services Controller vCenter extension file that you previously exported and
click Register Plug-in.
The vCenter Register Plug-in window appears, displaying a security warning.

Step 5 In the security warning message box, click Ignore.
If desired, you can install this certificate for further integration with Public Key Infrastructure (PKI)
and Kerberos facilities.

Note

A progress indicator shows the task status.

Step 6 When the success message is displayed, click OK, and then click Close.

Configuring Connectivity with vCenter
After you register the vCenter extension plug-in in vCenter, you can configure connectivity with vCenter in
Prime Network Services Controller.
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Procedure

Step 1 Choose Resource Management > VMManagers > VMManagers, and then click Add VMManager.
Step 2 In the Add VM Manager dialog box, enter the following information and then click OK:

• Name—VMM name.

• Description—VMM description.

• Hostname / IP Address—Hostname or IP address of the VMM.

• Port Number—Port number to use for communications.

A successfully added VMM is displayed with the following information:

• Admin State of enable.

• Operational State of up.

• VMware vCenter version.

Configuring Connectivity with Microsoft SCVMM
Use this procedure to configure Prime Network Services Controller connectivity with Microsoft SCVMM
(SCVMM).

Before You Begin

• Confirm that you have the username and password for SCVMM access.

• Install Microsoft Service Provider Framework (SPF) so that Prime Network Services Controller can
communicate with SCVMM. For more information, see http://technet.microsoft.com/en-us/library/
jj642895.aspx.

• Confirm that SPF is installed correctly and functional in SCVMM by connecting to https://
spf_host_ip:8090/SC2012R2/VMM/Microsoft.Management.Odata.Svc.

Procedure

Step 1 Choose Resource Management > VMManagers, and then click Add VMManager.
Step 2 In the Add VMManager dialog box, provide the information described in the following table, and then click

OK:

DescriptionField

VMM name.Name

VMM description.Description
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DescriptionField

Hostname or IP address of the VMM.Hostname / IP Address

Domain or username for SCVMM access.Domain Name / Username

Password for SCVMM access.Password

Port to use for communications.Port Number

A successfully added VMM is displayed with the following information:

• Admin State of enable.

• Operational State of up.

• SCVMM version.

Editing a VM Manager
After a VM Manager is added, you can modify its properties as follows:

• Admin State—For vCenter and SCVMM.

• Description—For vCenter and SCVMM.

• Domain Name / Username—SCVMM only.

• Password—SCVMM only.

All other fields are read-only.

Changing the administrative state depends on the current operational state:

• To change the administrative state to enabled, the operational state must be down.

• To change the administrative state to disabled, the operational state must be up.

If your request to change the administrative state fails, resubmit the request when the system has the correct
operational state.

Procedure

Step 1 Choose one of the following:

• Resource Management > VMManagers
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• InterCloud Management > Enterprise > VMManagers

Step 2 In the VM Managers tab, select the VM Manager you want to edit, and then click Edit.
Step 3 In the Edit VM Manager dialog box, edit the information as required, and then click OK.

DescriptionField

VMManager name (read-only).Name

Description of the VM Manager.Description

Hostname or IP address of the VMM (read-only).Hostname / IP Address

(SCVMM only) Domain or username for SCVMM
access.

Domain Name / Username

(SCVMM only) Password for SCVMM access.Password

Port to use for communications (read-only).Port Number

One of the following administrative states for the VM
Manager:

• enable—When aVMManager is added to Prime
Network Services Controller with the
administrative state of enable, the system fetches
all VM inventory from the VM Manager. Any
changes that occur to the VM on the VM
Manager are also fetched.

• disable—When a VM Manager is added to
Prime Network Services Controller with the
administrative state of disable, the system
displays all discovered VMs from the VM
Manager. Any changes that occur to the VMs
on the VM Manager are not fetched. The
changes will be fetched by Prime Network
Services Controller when the admin state is
changed to enable.

Admin State

VMM vendor (read-only).Type

VMM version (read-only).Version
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DescriptionField

One of the following operational states (read-only):

• up

• unreachable

• bad-credentials

• comm-err

• admin-down

• unknown

Operational State

Reason for the operational state (read-only).Operational State Reason

Deleting a VM Manager
You cannot delete a VM Manager if a service VM is deployed on the associated VMM.

Procedure

Step 1 Choose one of the following:

• Resource Management > VMManagers

• InterCloud Management > Enterprise > VMManagers

Step 2 Choose the VM Manager that you want to delete, and then click Delete.
Step 3 When prompted, confirm the deletion.
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C H A P T E R  7
Configuring System Profiles

This section includes the following topics:

• System Profile Overview, page 51

• Policies in System Profiles, page 51

• Configuring Policies, page 52

• Modifying the Default System Profile, page 62

• Editing a DNS Domain, page 64

• Adding an NTP Server, page 65

System Profile Overview
Prime Network Services Controller provides one default System profile. The System profile includes time
zone, DNS domain, DNS Server and NTP Server IP address information that is automatically generated using
the data taken from initial Prime Network Services Controller installation. The System profile also contains
the following policies: log file, fault, syslog, and core file. You can add and modify DNS server, NTP server,
and policy information associated to the default system profile. However, you cannot create a new DNS
domain or delete the default System profile.

Note • Access to a DNS server and an NTP server is required for Prime Network Services Controller to
communicate with the Amazon Cloud Provider.

• If you change the fully qualified domain name (FQDN), you must reconfigure Prime Network
Services Controller connectivity with the hypervisor.

Policies in System Profiles
You can create multiple policies and assign them to the System profile. To manage policies for the default
System profile, choose Administration > System Profile.
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The system profile uses name resolution to resolve policy assignments. For details, see Name Resolution
in a Multi-Tenant Environment, on page 68.

Note

The following policies, which are created under root, are visible in the System profile.:

• Core file

• Fault

• Log file

• Syslog

Policies created under root are visible to both the System profile and the Device profile.

You cannot delete existing default policies.Note

Configuring Policies

Configuring a Core File Policy Profile
You can create and modify the core file policy attributes. For more information on core file policy attributes,
see the Core File Attributes Table.

To add, modify, or delete a core file policy:

Procedure

Step 1 Choose Administration > System Profile > root > Policies > Core File.
Step 2 In the General tab, do one of the following:

• To add a core file policy, click Add Core File Policy. Enter the appropriate information and click OK

• To edit a core file policy, select the policy, and then click Edit. Edit the appropriate fields and clickOK.

• To delete a core file policy, select the policy, and then click Delete.
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Core File Attributes Table

DescriptionField

Core file policy name, containing 1 to 32 characters.
You can use alphanumeric characters, hyphen (-),
underscore (_), and period (.). You cannot change the
name after the policy has been saved.

Name

Brief policy description, containing 1 to 256
characters. You can use alphanumeric characters,
hyphen (-), underscore (_), and period (.).

Description

Indicate whether the administrative state of the policy
is to be enabled or disabled.

Admin State

Hostname or IP address to use for this policy. If you
use a hostname rather than an IP address, you must
configure a DNS server in Prime Network Services
Controller.

Hostname/IP Address

Port number for sending the core dump file.

This field is read-only for InterCloud policies.

Port

Protocol for exporting the core dump file (tftp only).Protocol

Path to use when storing the core dump file on a
remote system. The default path is /tftpboot; for
example, /tftpboot/test, where test is the subfolder.

Path

Configuring a Fault Policy
When the system boots up, a default fault policy is created. You can add additional fault policies or modify
existing ones. However, you cannot delete the default fault policy. For more information on fault policy
attributes, see the Fault Policy Attributes Table.

To add, modify, or delete a fault policy:

Procedure

Step 1 Choose Administration > System Profile > root > Policies > Fault.
Step 2 In the General tab, do one of the following:

• To add a fault file policy, click Add Fault File Policy. Enter the appropriate information and click OK

• To edit a fault file policy, select the policy, and then click Edit. Edit the appropriate fields and click
OK.
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• To delete a fault file policy, select the policy, and then click Delete.

Fault Policy Attributes Table

DescriptionField

Fault policy name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name

Brief policy description.Description

Length of time (in hours, minutes, and seconds) that
must elapse before the system allows a fault to change
its state.

Flapping occurs when a fault is raised and cleared
several times in rapid succession. To prevent this, the
system does not allow a fault to change its state until
this amount of time has elapsed since the last state
change.

If the condition reoccurs during the flapping interval,
the fault returns to the active state. If the condition
does not reoccur during the flapping interval, the fault
is cleared. What happens at that point depends on the
setting in the Clear Faults Retention Action field.

The default flapping interval is ten seconds.

Flapping Interval

Action to be taken when faults are cleared:

• retain—Retain the cleared faults.

• delete—Delete fault messages as soon as they
are marked as cleared.

Clear Faults Retention Action
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DescriptionField

How long the system is to retain cleared fault
messages:

• Forever—The system retains all cleared fault
messages regardless of their age.

• Other—The system retains cleared fault
message for a specified the length of time.
In the spinbox that is displayed when you select
this option, enter the length of time (in days,
hours, minutes, and seconds) that the system is
to retain cleared fault messages.

Clear Faults Retention Interval

Configuring a Logging Policy
When the system boots up, a default logging policy is created. You can add additional log policies or modify
existing ones. However, you cannot delete the default log policy. For more information on logging policy
attributes, see the Logging Policy Attributes Tables.

Procedure

Step 1 Choose Administration > System Profile > root > Policies > Log File.
Step 2 In the General tab, do one of the following:

• To add a logging file policy, clickAdd Logging File Policy. Enter the appropriate information and click
OK

• To edit a logging file policy, select the policy, and then click Edit. Edit the appropriate fields and click
OK.

• To delete a logging file policy, select the policy, and then click Delete.

Logging Policy Attributes Tables

DescriptionField

Logging policy name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name
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DescriptionField

Brief policy description.Description

One of the following logging severity levels:

• debug0

• debug1

• debug2

• debug3

• debug4

• info

• warning

• minor

• major

• critical

The default log level is info.

Log Level

Number of backup files that are filled before they are
overwritten.

The range is 1 to 9 files, with a default of 2 files.

Backup Files Count

Backup file size.

The range is 1MB to 100MBwith a default of 5MB.

File Size (bytes)

Configuring a Syslog Policy
When the system boots up, a default syslog policy is created. You can add additional syslog policies or modify
existing ones. However, you cannot delete the default syslog policy. For more information on syslog policy
attributes, see the Syslog Policy Attributes Table.

The syslog message settings that you configure for the System profile apply to Prime Network Services
Controller syslog messages only. These settings do not affect other, non-Prime Network Services Controller
syslog messages.

To add, modify, or delete a syslog policy:

Procedure

Step 1 Choose Administration > System Profile > root > Policies > Syslog.
Step 2 In the General tab, do one of the following:
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• To add a syslog policy, click Add Syslog Policy. Enter the appropriate information and click OK

• To edit a syslog policy, select the policy, and then click Edit. Edit the appropriate fields and click OK.

• To delete a Syslog policy, select the policy, and then click Delete.

Syslog Policy Attributes Table

DescriptionField

General Tab

Policy name.Name

Brief policy description.Description

Check the check box to use the EMBLEM format for
syslog messages.

This option appears only on supported devices.

Use Emblem Format

Check the check box to continue logging if the syslog
server is down.

This option only appears on supported devices.

Continue if Host is Down

Servers Tab

Click to add a new syslog server.Add Syslog Server

List of configured syslog servers.Syslog Servers table

Local Destinations Tab

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: alert, critical, or
emergency.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

Console
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DescriptionField

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: emergency, alert,
critical, error, warning, notification, information,
or debugging.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

Monitor

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: emergency, alert,
critical, error, warning, notification, information,
or debugging.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

• File Name—Name of the file to whichmessages
are logged.

• Size (bytes)—Maximum size, in bytes, that the
file can reach before the system begins to
overwrite the messages.

File
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DescriptionField

Buffer options are not available for InterCloud
policies.

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: emergency, alert,
critical, error, warning, notification, information,
or debugging.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

• Buffer Size (Bytes)—In bytes, the size of the
buffer for syslog messages.

•Wrap to Flash—Indicates whether or not the
buffer contents are saved to flash memory when
the buffer wraps (becomes full). Check the
check box to save the contents to flash memory
if the buffer wraps.

• Max File Size in Flash (KB)—Maximum size,
in kilobytes, that can be used by the syslog
buffer. This option is enabled if the Wrap to
Flash option is enabled.

• Min Free Flash Size (KB)—Minimum size, in
kilobytes, that is allocated for the syslog buffer.
This option is enabled if the Wrap to Flash
option is enabled.

Buffer

Check the check box for each of the following options
that you want to enable for timestamp display:

• Enable Timestamp

• Include Year

• Include Milliseconds

• Show Time Zone

• Use Local Time Zone

Time Stamp
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Adding a Syslog Server to a Syslog Policy
This procedure assumes that you have already created a syslog policy for a Prime Network Services Controller
profile. For information on creating a syslog policy for a Prime Network Services Controller profile, see
Configuring a Syslog Policy, on page 56. For more information on syslog server attributes see the Syslog
Server Attributes Table.

Procedure

Step 1 Choose Administration > System Profile > root > Policies > Syslog > syslog-policy.
Step 2 In the Servers tab, click Add Syslog Server. Enter the appropriate information and click OK.
Step 3 In the Servers tab, do one of the following:

• To add a syslog server, click Add Syslog Server. Enter the appropriate information and click OK

• To edit a syslog server, select the server, and then click Edit. Edit the appropriate fields and click OK.

• To delete a syslog server, select the server, and then click Delete.

Syslog Server Attributes Table

DescriptionField

One of the following server types:

• primary

• secondary

• tertiary

Server Type

Hostname or IP address where the syslog file
resides.

If you use a hostname, you must
configure a DNS server.

Note

Hostname/IP Address
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DescriptionField

One of the following severity levels:

• emergencies (0)

• alerts (1)

• critical (2)

• errors (3)

• warnings (4)

• notifications (5)

• information (6)

• debugging (7)

Severity

One of the following forwarding facilities:

• auth

• authpriv

• cron

• daemon

• ftp

• kernel

• local0

• local1

• local2

• local3

• local4

• local5

• local6

• local7

• lpr

• mail

• news

• syslog

• user

• uucp

Forwarding Facility
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DescriptionField

Administrative state of the server: disabled or
enabled.

Admin State

Port to use to send data to the syslog server.

The default port selection is 514 for UDP.

This option is not available for InterCloud
policies.

Port

Protocol to use: TCP or UDP (default).

This option is not available for InterCloud
policies.

Protocol

Check the check box to use Transport Layer
Security.

This option is available only for TCP.

This option is not available for InterCloud
policies.

Use Transport Layer Security

Interface to use to access the syslog server.Server Interface

Modifying the Default System Profile
You can add and modify DNS server, NTP server, and policy information associated to the default system
profile. However, you cannot create a new DNS domain or delete the default System profile.

Procedure

Step 1 Choose Administration > System Profile > root > Profile > default.
Step 2 In the General tab, update the information as required:

DescriptionField

Default profile name (read-only).Name

Brief profile description.Description

Available time zones.

The default time zone is UTC.

Time Zone

Step 3 In the Policy tab, update the information as required:
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DescriptionField

DNS Servers

Click to add a new DNS server.Add DNS Server

Deletes the DNS server selected in the DNS Servers
table.

Delete

Changes the priority of the selected DNS server.

Prime Network Services Controller uses the DNS
servers in the order in which they appear in the table.

Up and down arrows

Identifies the DNS servers configured in the system.DNS Servers table

NTP Servers

Click to add a new NTP server.Add NTP Server

Deletes the NTP server selected in the NTP Servers
table.

Delete

Changes the priority of the selected NTP server.

Prime Network Services Controller uses the NTP
servers in the order in which they appear in the table.

Up and down arrows

Identifies the NTP servers configured in the system.NTP Servers table

DNS Domains

Edits the DNS domain selected in the DNS Domains
table. The default DNS domain cannot be deleted.

Changing the DNS domain will cause a
loss of connectivity that results in an error
message, your session closing, and then
the display of a new Prime Network
Services Controller certificate. This
situation occurs when the Prime Network
Services Controller hostname, Prime
Network Services Controller domain
name, or both have changed. If this occurs,
reconfigure connectivity with your
hypervisor. For more information, see
Configuring VM Managers, on page 43.

Caution

Edit

Identifies the default DNS domain name and domain
configured in the system.

DNS Domains

Other Options
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DescriptionField

The syslog policies associated with this profile can
be selected, added, or edited.

Click the Resolved Policy field to review or modify
the specified policy.

Syslog

The fault policies associated with this profile can be
selected, added, or edited.

Click the Resolved Policy field to review or modify
the specified policy.

Fault

The core file policies associated with this profile can
be selected, added, or edited.

Click the Resolved Policy field to review or modify
the specified policy.

Core File

The log file policies associated with this profile can
be selected, added, or edited.

Click the Resolved Policy field to review or modify
the specified policy.

Log File

Step 4 Click Save.

Editing a DNS Domain

Changing the DNS domain will cause a loss of connectivity that results in an error message, your session
closing, and then the display of a new Prime Network Services Controller certificate. This situation occurs
when the Prime Network Services Controller hostname, domain name, or both have changed. If this occurs,
reconfigure connectivity with the hypervisor. For more information, see Configuring VM Managers, on
page 43.

Caution

Procedure

Step 1 Choose Administration > System Profile > root > Profile > default.
Step 2 Click the Policy tab.
Step 3 In the DNS Domains table, select the domain that you want to edit, then click Edit.
Step 4 In the Edit DNS Domains dialog box, edit the Domain Name field as required, then click OK.
Step 5 Click Save.
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Adding an NTP Server
You can specify a maximum of four NTP servers for the System profile. Use the up and down arrows to
arrange the servers from highest to lowest priority, with the highest priority server at the top of the list.

Procedure

Step 1 Choose Administration > System Profile > root > Profile > default.
Step 2 In the Policy tab, do one of the following:

• To add an NTP server, click Add NTP Server. Enter the appropriate information, click OK, and then
click Save.

• To delete an NTP server, select the server, and then click Delete.
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C H A P T E R  8
Configuring Tenants

This section includes the following topics:

• Tenant Management, page 67

• Configuring Tenants, page 69

• Configuring Virtual Data Centers, page 70

• Configuring Applications, page 71

• Configuring Tiers, page 72

Tenant Management
The topics in this section describe how to manage tenants when Prime Network Services Controller is installed
in Standalonemode. For information onmanaging tenants when PrimeNetwork Services Controller is installed
in Orchestrator mode, see Integrating with DCNM, on page 209.

Tenant Management and Multi-Tenant Environments
Prime Network Services Controller provides the ability to support multi-tenant environments. A multi-tenant
environment enables the division of large physical infrastructures into logical entities called organizations.
As a result, you can achieve logical isolation between organizations without providing a dedicated physical
infrastructure for each organization.

The administrator can assign unique resources to each tenant through the related organization in themulti-tenant
environment. These resources can include policies, pools, device profiles, service devices, and so on. The
administrator can use locales to assign or restrict user privileges and roles by organization if access to certain
organizations needs to be restricted.

Users with the tenant-admin role can see only those objects and resources that are related to their associated
tenants as defined by the locales and organizations assigned to them. They cannot see the policies or resources
of other tenants. Tenant-admin users can view faults only for the resources (such as firewalls or load balancers)
that they manage. They cannot see diagnostic information or configure administrative options.
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Users with the admin role add a user with the tenant-admin role by associating the user with a locale and
organization. For more information about creating user accounts and assigning locales and organizations, see
the following topics:

• Creating a User Account, on page 29

• Creating a Locale, on page 26

The tenant-admin role has the following privileges:

• Policy management

• Resource configuration

• Tenant management

Prime Network Services Controller provides a strict organizational hierarchy as follows:

1 root

2 Tenant

3 Virtual Data Center

4 Application

5 Tier

The root can have multiple tenants. Each tenant can have multiple data centers. Each data center can have
multiple applications, and each application can have multiple tiers.

The policies and pools created at the root level are systemwide and are available to all organizations in the
system. However, any policies and pools created in an organization below the root level are available only to
those resources that are below that organization in the same hierarchy.

For example, if a system has tenants named Company A and Company B, Company A cannot use any policies
created in the Company B organization. Company B cannot access any policies created in the Company A
organization. However, both Company A and Company B can use policies and pools in the root organization.

Name Resolution in a Multi-Tenant Environment
In a multi-tenant environment, Prime Network Services Controller uses the hierarchy of an organization to
resolve the names of policies and resource pools. The steps that Prime Network Services Controller takes to
resolve the names of policies and resource pools are as follows:

1 Prime Network Services Controller checks the policies and pools for the specified name within an
organization assigned to the device profile or security policy.

2 If the policy or pool is found, Prime Network Services Controller uses that policy or pool.

3 If the policy or pool does not contain available resources at the local level, Prime Network Services
Controller moves up the hierarchy to the parent organization and checks for a policy with the specified
name. Prime Network Services Controller repeats this step until the search reaches the root organization.
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The object name reference resolution takes an object name and resolves an object from an organization
container to the object with the same name that is closest in the tree as it searches upward toward root. If
an object with the specified name is not found, Prime Network Services Controller uses a corresponding
default object. For example, assume that there is an SNMP policy under a data center named MySNMP
and an SNMP policy in the tenant in the same tree that is also named MySNMP. In this case, the user
cannot explicitly select the MySNMP policy under the tenant. If the user wants to select the SNMP policy
under the tenant, they must provide a unique name for the object in the given tree.

Note

4 If the search reaches the root organization and an assigned policy or pool is not found, Prime Network
Services Controller looks for a default policy or pool starting at the current level and going up the chain
to the root level. If a default policy or pool is found, Prime Network Services Controller uses it. If a policy
is not available, a fault is generated.

Configuring Tenants

Creating a Tenant

Procedure

Step 1 Choose Tenant Management > root > Create Tenant.
Step 2 In the Create Tenant dialog box, enter a name and description for the tenant, and then click OK.

Editing a Tenant

Procedure

Step 1 Choose Tenant Management > root > tenant where tenant is the tenant that you want to edit.
Step 2 In the General tab, modify the description as required, and then click Save.
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Deleting a Tenant

When you delete an organization (such as a tenant, virtual data center, application, or tier), all data contained
under the organization is deleted, including subordinate organizations, service devices, resource pools,
and policies.

Note

Procedure

Step 1 Choose Tenant Management > root.
Step 2 Right-click the tenant that you want to delete, and choose Delete Tenant.
Step 3 When prompted, confirm the deletion.

Configuring Virtual Data Centers

Creating a Virtual Data Center

Procedure

Step 1 Choose Tenant Management > root > tenant, where tenant is the location for the new virtual data center.
Step 2 Click Create Virtual Data Center.
Step 3 In the Create Virtual Data Center dialog box, enter a name and description for the virtual data center, and then

click OK.

Editing a Virtual Data Center

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc where vdc is the virtual data center that you want to edit.
Step 2 In the General tab, modify the description as required and click Save.

   Cisco Prime Network Services Controller 3.2 User Guide
70

Configuring Tenants
Deleting a Tenant



Deleting a Virtual Data Center

When you delete a virtual data center, all data contained under the virtual data center is deleted, including
subordinate organizations, service devices, resource pools, and policies.

Note

Procedure

Step 1 Choose Tenant Management > root > tenant where tenant is the tenant with the virtual data center that you
want to delete.

Step 2 Right-click the virtual data center that you want to delete and choose Delete Virtual Data Center.
Step 3 When prompted, confirm the deletion.

Configuring Applications

Creating an Application

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc where vdc is the location for the new application.
Step 2 Click Create Application.
Step 3 In the Create Application dialog box, enter a name and description for the application, and then click OK.

Editing an Application

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc > application, where application is the application that
you want to edit.

Step 2 In the General tab, modify the description as required, and then click Save.
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Deleting an Application

When you delete an application, all data contained under the application is deleted, including subordinate
organizations, service devices, resource pools, and policies.

Note

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc where vdc is the virtual data center with the application
that you want to delete.

Step 2 Right-click the application that you want to delete, and choose Delete Application.
Step 3 When prompted, confirm the deletion.

Configuring Tiers

Creating a Tier

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc > application, where application is the location for the
new tier.

Step 2 Click Create Tier.
Step 3 In the Create Tier dialog box, enter a name and description for the tier, and then click OK

Editing a Tier

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc > application > tier where tier is the tier you want to
edit.

Step 2 In the General tab, modify the description as required, and then click Save.
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Deleting a Tier

When you delete a tier, all data contained under it is also deleted, including service devices, resource
pools, and policies.

Note

Procedure

Step 1 Choose Tenant Management > root > tenant > vdc > application where application contains the tier that
you want to delete.

Step 2 Right-click the tier that you want to delete and choose Delete Tier.
Step 3 When prompted, confirm the deletion.
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C H A P T E R  9
Configuring Service Policies and Profiles

This section includes the following topics:

• Service Path Configuration Workflow, page 75

• Configuring Service Policies, page 81

• Working with Profiles, page 116

• Configuring Security Profiles, page 123

• Configuring Security Policy Attributes, page 128

Service Path Configuration Workflow
Service paths enable you to apply multiple services to VM traffic by binding a sequence of services to a
specific port profile.

The following table identifies the tasks required to configure a service path, related topics, and the minimum
role required for each task:

Role RequiredRelated TopicTask

adminSee Prerequisites for
Configuring Service Paths,
on page 76.

1. Confirm that the
prerequisites are met.

adminSee Creating a Tenant, on
page 69.

2. Create the tenant and, if
needed, the subordinate
organization in which the
service path will reside.

adminSee Adding a Port Profile to
a VSM, on page 77.

3. Add a port profile to a
Nexus 1000V VSM.

You can perform
this step at any time
before Step 6.

Note
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Role RequiredRelated TopicTask

tenant-adminSee Creating a Service Node,
on page 78.

4. Create service nodes for
inclusion in the service path.

tenant-adminSee Creating a Service Path,
on page 79.

5. Create a service path with
service entries.

tenant-adminSee Binding a Service Path to
a Port Profile, on page 80.

6. Bind the service path to the
VSM port profile.

Prerequisites for Configuring Service Paths
The following table describes the prerequisites for configuring service paths:

RequirementItem

Has at least one of the following assigned:

• Compute firewall

• Edge firewall

• vPath-enabled load balancer using Citrix
NetScaler 1000V

Tenant

• Has a security policy assigned.

• Has a policy set with policies and rules for the
compute firewall.

• The policy set is bound to the compute firewall
security policy.

• AVLAN is provided if the firewall is to be used
as a Layer 2 adjacent service node.

• The VLAN exists on the VSM.

Compute firewall
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RequirementItem

• Has an edge device profile defined.

• Has an edge security profile defined.

• Has a policy set with policies and rules for the
edge firewall.

• An inbound security profile is attached to the
outside interface of the edge firewall.

• A VLAN is provided on the data interface
because the edge firewall can be used only as a
Layer 2 adjacent service node.

• The VLAN exists on the VSM.

Edge firewall

Has vPath enabled.Load Balancer

• Is deployed.

• Is registered with Prime Network Services
Controller.

Nexus 1000V

The following services are deployed:

• VSG

• ASA 1000V

• Citrix NetScaler 1000V

Services

Adding a Port Profile to a VSM
Prime Network Services Controller enables you to add a port profile to an enterprise VSM. You cannot add
a port profile to a cloud VSM.

If an enterprise VSM has preconfigured port profiles or virtual service configurations that were created outside
of Prime Network Services Controller, these configurations will not be displayed in the Prime Network
Services Controller GUI.

If you create a port profile in Prime Network Services Controller and specify a VLAN, you must create the
VLAN itself on the VSM and then add it to the necessary system and uplink port profiles. The same steps
apply for VLANs that you specify while creating service devices, such as edge or compute firewalls: you
must create the VLANs on the devices, and then add them to the appropriate system and uplink port profiles.

Before You Begin

Confirm the following:
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• An enterprise VSM is registered and in the applied state in Prime Network Services Controller by
choosing Resource Management > Resources > VSMs.

• You have admin privileges.

Procedure

Step 1 Choose Resource Management > Resources > VSMs > vsm, then click Edit.
Step 2 Above the Port Profile table, click Add.
Step 3 In the Add Port Profile dialog box, enter the required information as follows, then click OK:

1 In the General tab, provide the following information:

• Name

• Description

• State: Enabled or Disabled.

• Type of Binding: Dynamic, Ephemeral, or Static.

• Binding Option: Auto, AutoExpand, or None.

• Maximum and minimum number of ports.

• Tenant or subordinate organization in which to create the port profile.

2 In the L2 Network Membership tab, provide the following information:

• Capability: Bridge Domain or VLAN.

• Mode: Access or Trunk

• VLAN number (Access mode) or VLAN range (Trunk mode).

The NICs table is populated automatically after you bind a service path to the port profile and the service path
is used the first time. For more information about configuring a service path and binding it to a port profile,
see Service Path Configuration Workflow, on page 75.

Creating a Service Node
A service node identifies a virtual service device that can be used in a service path and provides basic
configuration for that device.

The following restrictions apply when creating a service node:

• If you create multiple service nodes for a specific logical service device, the adjacencies must be different.

• You cannot create service nodes under different tenants with the same data IP address, VLAN, and
adjacency, even if the logical service devices are different.
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If either of these situations occurs, an error message will be generated when you attempt to bind the service
path to the VSM port profile.

Before You Begin

Confirm the following:

• A logical device (compute firewall, edge firewall, or load balancer) exists.

• You have Tenant Management privileges.

Procedure

Step 1 Choose Policy Management > Service Policies > root > tenant > Policy Helpers > Service Node, and then
click Add Service Node.

Step 2 In the Add Service Node dialog box, provide the following information, and then click OK:

• Name

• Service Type: Compute Firewall, Edge Firewall, or Load Balancer.

• Network Service: Name of the logical service device.

• Fail Mode: Action to take if the service node loses connectivity:

• Close—Drop the packets.

• Open—Forward the packets.

• Adjacency Type: Layer 2 or Layer 3.

Creating a Service Path
After you create service nodes, you can create a service path that uses the nodes. Traffic using the service
path moves from one service node to another in the sequence that you specify.

You cannot use a service node more than once in a service path.Note

Before You Begin

Confirm that you have Tenant Management privileges.
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Procedure

Step 1 Choose Policy Management > Service Policies > root > tenant > Policies > Service Path, and then click
Add Service Path.

Step 2 In the Add Service Path dialog box, enter a name and description for the service path, and then click Add
Service Entry.

Step 3 In the Add Service Entry dialog box, provide the following information, and then click OK:

• Service type

• Service node

• Service profile

The service profile identifies the policies that apply to the traffic using the service path.

Step 4 Add additional service entries as needed for the service path and click OK.

What to Do Next

You must bind the service path to a port profile so that the service path can be created on the Nexus 1000V
VSM. After the service path is bound to a port profile, the traffic using that port profile follows the service
entries in the sequence indicated in the table.

Binding a Service Path to a Port Profile
Binding a service path to a port profile ensures that all traffic using that port profile will follow the configured
service path. When you bind a service path to a port profile, the NICs table that is displayed in the Edit Port
Profile dialog box remains empty until the service path is used for the first time. When the service path is
used, the NICs table is populated automatically.

Before You Begin

Confirm the following:

• A service path exists.

• You have Tenant Management privileges.

Procedure

Step 1 Choose one of the following:.

• Resource Management > Managed Resources > root > tenant > Port Profiles Tab

• Resource Management > Resources > VSMs > vsm > Edit.
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Step 2 In the Port Profiles table, select the port profile you want to bind a service path to, then click Edit.
Step 3 In the Service Path field, click Select.
Step 4 In the Select Service Path dialog box, select the required service path, then click OK.
Step 5 In the Edit Port Profile dialog Box, click Apply and then OK to apply and save the change.

Configuring Service Policies
This procedure describes the general steps for configuring service policies for managed resources.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > policy-type.
Step 2 In the General tab, click Add policy-type.
Step 3 In the dialog boxes that follow, enter the required information. For more information on each dialog box,

click the online-help.
The following topics provide specific details on various policies:

• Configuring ACL Policies and Policy Sets, on page 81

• Configuring Connection Timeout Policies, on page 88

• Configuring DHCP Policies, on page 89

• Configuring IP Audit and IP Audit Signature Policies, on page 93

• Configuring NAT/PAT Policies and Policy Sets, on page 95

• Configuring Packet Inspection Policies, on page 100

• Configuring Routing Policies, on page 101

• Configuring TCP Intercept Policies, on page 102

• Configuring Site-to-Site IPsec VPN Policies, on page 103

Configuring ACL Policies and Policy Sets
The following topics describe how to configure ACL policies and policy sets:

• Adding an ACL Policy, on page 82

• Time Ranges in ACL Policy Rules, on page 86

• Adding an ACL Policy Set, on page 87
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Adding an ACL Policy
Prime Network Services Controller enables you to implement access control lists based on the time of day
and frequency, or inclusion in a defined group. Benefits of this feature include:

• Providing closer control of access to network resources throughout the day or week.

• Enhancing policy-based routing and queuing functions.

• Automatically rerouting traffic at specific times of the day to ensure cost-effectiveness.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > ACL > ACL Policies.
Step 2 In the General tab, click Add ACL Policy.
Step 3 In the Add ACL Policy dialog box, enter a name and brief description for the policy, then click Add Rule.
Step 4 In the Add Rule dialog box, specify the required information as described in Add ACL Policy Rule Dialog

Box, on page 82, then click OK.
All Network Port conditions in a single ACL rule must have the same value selected in the Attribute
Value field. For example, you would choose FTP from the Attribute Value drop-down list for all rule
conditions that specify the Attribute Name of Network Port.

Note

The Add Rule dialog box contains settings for time rules for ACL policies. For more information about using
time ranges with ACL policies, see Time Ranges in ACL Policy Rules, on page 86.

Add ACL Policy Rule Dialog Box

DescriptionField

Rule name, containing 2 to 32 characters. The name
can contain alphanumeric characters, hyphen (-),
underscore (_), period (.), and colon (:). You cannot
change the name after it is saved.

Name

Brief rule description, containing 1 to 256 characters.
The name can contain alphanumeric characters,
hyphen (-), underscore (_), period (.), and colon (:).

Description

1 Click the action to take if the rule conditions are
met:

• Drop—Drops traffic or denies access.

• Permit—Forwards traffic or allows access.

• Reset—Resets the connection.

2 Check the Log check box to enable logging.

Action to Take
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DescriptionField

Do one of the following:

• Clickmatch-all for the ACL Policy Rule to
match all the conditions (AND).

• Clickmatch-any for the ACL Policy Rule to
match any one condition (OR).

Condition Match Criteria

Src-Dest-Service Tab

A rule can have a service condition or a protocol condition, but not both.

1 Click Add.

2 Enter the required values for following:

• Attribute Type

• Attribute Name

• Operator

• Attribute Value

3 Click OK.

Source Conditions

1 Click Add.

2 Enter the required values for following:

• Attribute Type

• Attribute Name

• Operator

• Attribute Value

3 Click OK.

Destination Conditions

1 Click Add.

2 Enter the required values for following:

• Operator

• Protocol

• Port

3 Click OK.

Service
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DescriptionField

Specify the protocols to which the rule applies:

• To apply the rule to any protocol, check theAny
check box.

• To apply the rule to specific protocols:

1 Uncheck the Any check box.

2 From the Operator drop-down list, choose
a qualifier: Equal, Not Equal, Member, Not
Member, In range, or Not in range.

3 In the Value fields, specify the protocol,
object group, or range.

Protocol Tab

Specify the encapsulated protocols to be examined
for this rule:

1 From the Operator drop-down list, choose a
qualifier: Equal, Not equal, Greater than, Less
than, Member, Not Member, In range, or Not in
range.

2 In the Value fields, specify the hexadecimal value,
object group, or hexadecimal range.

Ether Type Tab

Time Range Tab

Check the Always check box.To apply the rule all the time

1 Uncheck the Always check box.

2 Check the Range check box.

3 In the Absolute Start Time fields, provide the start
date and time.

4 In the Absolute End Time fields, provide the end
date and time.

To apply the rule for a specific time range
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DescriptionField

1 Uncheck the Always check box.

2 Check the Pattern check box.

3 From the Operator drop-down list, choose
member (Member of).

4 Do any of the following :

• From the Select Object Group drop-down
list, choose an existing object group.

• Click Add Object Group to create a new
object group.

• Click the Resolved Object Group link to
review or modify the specified object group.

To apply the rule based on membership in an object
group

1 Uncheck the Always check box.

2 Check the Pattern check box.

3 From the Operator drop-down list, choose range
(In range).

4 In the Begin fields:

1 From the Begin drop-down list, choose the
beginning day of the week or the frequency
of the time range.

2 Choose the beginning hour and minute, and
AM or PM.

5 In the End fields:

1 From the End drop-down list, choose the
ending day of the week or frequency.

2 Choose the ending hour and minute, and AM
or PM.

If you choose a frequency from the Begin
drop-down list, choose the same frequency
from the End drop-down list. For example,
choose Weekdays from both the Begin and
End drop-down lists.

Note

To apply the rule on a periodic basis, with the
frequency you specify
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DescriptionField

Specify any source port attributes that must be
matched for the current policy to apply:

1 Click Add.

2 Provide the required information in the following
fields, and then click OK:

• Attribute Name

• Operator

• Attribute Value

Advanced Tab

Time Ranges in ACL Policy Rules
Prime Network Services Controller enables you to configure time ranges for ACL policy rules in either of
the following ways:

• By specifying a time range for the ACL policy rule.

• By associating an ACL object group with the ACL policy rule.

Prime Network Services Controller supports the following types of time ranges:

• Periodic—Specified by day-of-week start and end times (such as Sunday to Sunday), or a frequency
(such as Daily, Weekdays, or Weekends). Periodic range start and end times also include options for
hours and minutes.

• Absolute—Specified by a calendar date and time for start and end times, such as 01 Sep 2013 12:00
AM to 31 Dec 2013 12:00 AM.

For each ACL policy rule, you can have:

• One absolute time range.

• Any number of periodic time ranges, or none.

• To specify a single periodic time range, add it to an ACL policy rule.

• To specify multiple periodic time ranges, use an ACL policy object group.
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The following figure shows the Time Range fields for an ACL policy rule.

Figure 3: Time Range Fields in an ACL Policy Rule

Adding an ACL Policy Set

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > ACL > ACL Policy Sets.
Step 2 In the General tab, click Add ACL Policy Set.
Step 3 In the Add ACL Policy Set dialog box, enter the required information as described in the following table,

then click OK:
DescriptionField

Policy set name, containing 2 to 32 characters. The
name can contain alphanumeric characters, hyphen
(-), underscore (_), period (.), and colon (:). You
cannot change the name after it is saved.

Name

Policy set description, containing 1 to 256 characters.
The name can contain alphanumeric characters,
hyphen (-), underscore (_), period (.), and colon (:).

Description
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DescriptionField

Administrative state of the policy: enabled or
disabled.

This field is not available for all policy sets.

Admin State

Policies

Click to add a new policy.Add Policy

Policies that can be assigned to the policy set.

Use the arrows between the columns to move policies
between columns.

Available

Policies assigned to the policy set.Assigned

Changes the priority of the selected policies.

Arrange the policies from highest to lowest priority,
with the highest priority policy at the top of the list.

Up and down arrows

Configuring Connection Timeout Policies
Prime Network Services Controller enables you to configure connection timeout policies so that you can
establish timeout limits for different traffic types.

After you create a connection timeout policy, you can associate it with an edge security profile. For more
information, see Configuring Edge Security Profiles, on page 120.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > Connection Timeout.
Step 2 In the General tab, click Add Connection Timeout Policy.
Step 3 In the Add Connection Timeout Policy dialog box:

a) Enter a policy name and description.
b) Choose whether the administrative status of the policy is to be enabled or disabled.

Step 4 To add a rule to the policy, click Add Rule.
Step 5 In the Add Connection Timeout Policy Rule dialog box, provide the information as described in Add Connection

Timeout Policy Rule Dialog Box, on page 89.
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Add Connection Timeout Policy Rule Dialog Box

Table 6: Add Connection Timeout Policy Rule Dialog Box

DescriptionField

Policy name.Name

Brief policy description.Description

Action

Length of time (in days, hours, minutes, and seconds)
a TCP connection can remain idle before it is closed.

Idle TCP

Length of time (in days, hours, minutes, and seconds)
a half-closed TCP connection can remain idle before
it is freed.

Half-Closed

Check the check box to send a reset to the TCP
endpoints when a TCP connection times out.

Send Reset To Idle Connection

Length of time (in days, hours, minutes, and seconds)
a UDP connection can remain idle before it closes.
The duration must be at least one minute, and the
default value is two minutes. Enter 00:00:00:00 to
disable timeout.

Idle UDP

Length of time (in days, hours, minutes, and seconds)
an ICMP state can remain idle before it is closed.

ICMP

Not available for configuration.Protocol

Source Conditions

Destination Conditions

Configuring DHCP Policies
Prime Network Services Controller enables you to create the following DHCP policies and apply them to
edge firewalls:

• DHCP relay policy

• DHCP server policy

You can also configure DHCP relay servers for inclusion in DHCP relay policies.
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The DHCP relay and DHCP server policies can be authored at the organization level and can be applied only
to the inside interface of an edge firewall. When they are applied, DHCP policies allow the edge firewall to
act either as a DHCP server or a DHCP relay for all VMs in the inside network.

You can apply only one DHCP server or relay profile at a time to the inside interface of the edge firewall.

For more information, see the following topics:

• Adding a DHCP Relay Server, on page 90

• Configuring a DHCP Relay Policy, on page 90

• Configuring a DHCP Server Policy, on page 91

Adding a DHCP Relay Server
DHCP relay servers are used to forward DHCP requests and replies between clients and servers when they
are not on the same physical subnet. In contrast to IP router forwarding, where IP datagrams are switched
between networks, DHCP relay servers receive DHCP messages and then generate a new message to send
out on a different interface.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > DHCP > DHCP Relay Server.
Step 2 In the General tab, click Add DHCP Relay Server.
Step 3 In the NewDHCPRelay Server dialog box, provide the information described in the Add DHCPRelay Server

Dialog Box, on page 90, then click OK.

Add DHCP Relay Server Dialog Box

DescriptionField

Relay server name.Name

Brief description of the relay server.Description

IP address of the relay server.Relay Server IP

Interface to use to reach the relay server.Interface Name

Configuring a DHCP Relay Policy
Prime Network Services Controller enables you to associate a DHCP relay server with a DHCP relay policy,
as described in this procedure.
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Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > DHCP > DHCP Relay.
Step 2 In the General tab, click Add DHCP Relay Policy.
Step 3 In the New DHCP Relay Policy dialog box, provide the information described in Add DHCP Relay Policy

Dialog Box, on page 91, then click OK.

Add DHCP Relay Policy Dialog Box

DescriptionName

Policy name.Name

Brief policy description.Description

Assign a DHCP relay server in one of the following
ways:

• Click Add DHCP Relay Server to add a new
DHCP relay server.

• In the Available Relay Servers list, select one
of the available relay servers and move it to the
Assigned Relay Servers list

You must assign at least one DHCP relay server to
the policy.

DHCP Relay Server Assignment

Configuring a DHCP Server Policy
ADHCP server policy enables you to define the characteristics of the policy, such as ping and lease timeouts,
IP address range, and DNS and WINS settings.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > DHCP > DHCP Server.
Step 2 In the General tab, click Add DHCP Server Policy.
Step 3 In the NewDHCP Server Policy dialog box, provide the information as described in Add DHCP Server Policy

Dialog Box, on page 92, then click OK.
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Add DHCP Server Policy Dialog Box

DescriptionField

General Tab

Policy name.Name

Brief policy description.Description

Amount of time (in milliseconds) that the DHCP
server waits for a ping reply before it stops attempting
to reach a pool address for client assignment.

The valid range is 10 to 10000 milliseconds.

Ping Timeout (Milliseconds)

Amount of time (in days, hour, minutes, and seconds)
that the DHCP server allocates an IP address to a
DHCP client before reclaiming and then reallocating
it to another client.

The default value is 00:01:00:00 (one hour).

Lease Timeout

To enable DHCP server automatic configuration,
enter the name of the edge device interface that uses
the DHCP client. For ASA 1000V instances, this
interface is always an outside interface.

Leaving this field empty indicates that the automatic
configuration feature is disabled.

Edge Device Interface Using the DHCP Client for
DHCP Server Auto Configuration

DNS settings used by the edge firewall when
configuring DHCP clients.

To add a new entry, click Add DNS Setting and add
the required information.

DNS Settings

Windows Internet Naming Service (WINS) name
servers that are available to DHCP clients.

To add a newWINS server, clickAddWINS Server
and enter the WINS server IP address.

WINS servers are listed in the order of preference,
with the most preferredWINS server at the top. Select
an entry in the table, and then use the arrows above
the table to change server priority.

WINS Servers
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DescriptionField

Enter the following information for the DHCP address
pool:

• Start IP Address—Beginning IP address of the
pool.

• End IPAddress—Ending IP address of the pool.

• Subnet Mask—Subnet mask to apply to the
address pool.

IP Address Range

The Advance tab allows you to add Manual and Exclude addresses. You must know the applicable MAC and
IP addresses.

Configuring IP Audit and IP Audit Signature Policies
The IP audit feature provides basic Intrusion Prevention System (IPS) support for ASA 1000V instances.
Prime Network Services Controller supports a basic list of signatures, and enables you to configure policies
that specify one or more actions to apply to traffic that matches a signature.

The following IP audit policies are available:

• Audit policies

• Signature policies

When you associate an IP audit policy with a device, the policy is applied to all traffic on the outside interface
of the device.

The following topics describe how to configure these policies.

Configuring IP Audit Policies

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > IP Audit > Audit Policies.
Step 2 In the General tab, click Add IP Audit Policy.
Step 3 In the Add IP Audit Policy dialog box provide the following information:

• Policy name

• Policy description
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• In the Admin State field, choose whether the administrative state of the policy is to be enabled or disabled.

Step 4 To add a rule to the policy, click Add Rule in the Rule Table toolbar.
Step 5 In the Add IP Audit Policy Rule dialog box, provide the information as described in Add IP Audit Policy Rule

Dialog Box, on page 94, then click OK in the open dialog boxes.

Add IP Audit Policy Rule Dialog Box

Table 7: IP Audit Policy Rule Dialog Box

DescriptionField

Rule name.Name

Brief rule description.Description

Check the check boxes of the actions to take for
signature type Attack if the conditions of the rule are
met:

• Log—Send a message indicating that a packet
matched the signature.

• Drop—Drop the packet.

• Reset Flow—Drop the packet and reset the
connection.

Attack-Class Action

Check the check boxes of the actions to take for
signature type Informational if the conditions of the
rule are met:

• Log—Send a message indicating that a packet
matched the signature.

• Drop—Drop the packet.

• Reset Flow—Drop the packet and reset the
connection.

Informational-Class Action

Not available for configuration.Protocol

Source Conditions

Destination Conditions
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Configuring IP Audit Signature Policies
An IP audit signature policy identifies the signatures that are enabled and disabled. By default, all signatures
are enabled. You can disable a signature when legitimate traffic matches the signature in most situations,
resulting in false alarms. However, disabling the signature is performed at a global level, meaning that no
traffic will trigger the signature (even bad traffic) when it is disabled.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > IP Audit > Signature Policies.
Step 2 In the General tab, click Add IP Audit Signature Policy.
Step 3 In the Add IP Audit Signature Policy dialog box, enter a name and description for the policy.
Step 4 In the Signatures area, move signatures between the Enabled Signatures and Disabled Signatures lists as

required.
We recommend that you do not disable signatures unless you are sure you understand the consequences
of doing so.

Note

You can view additional information about a signature by selecting the required signature and clicking
Properties.

Step 5 After you have made all adjustments, click OK.

Configuring NAT/PAT Policies and Policy Sets
PrimeNetwork Services Controller supports Network Address Translation (NAT) and Port Address Translation
(PAT) policies for controlling address translation in the deployed network. These policies support both static
and dynamic translation of IP addresses and ports.

Prime Network Services Controller enables you to configure the following policy items:

• NAT policy—Can contain multiple rules, which are evaluated sequentially until a match is found.

Edge routers support a limited set of NAT policy options.Note

• NAT policy set—Group of NAT policies that can be associated with an edge security profile. When the
profile is applied, the NAT policies are applied only to ingress traffic.

• PAT policy—Supports source dynamic and destination static interface PAT on edge firewalls.

The following topics describe how to configure NAT and PAT policies, and NAT policy sets.

Configuring NAT/PAT Policies
This procedure describes how to configure NAT/PAT policies with Prime Network Services Controller.
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Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > NAT > NAT Policies.
Step 2 In the General tab, click Add NAT Policy.
Step 3 In the Add NAT Policy dialog box, enter a name and description for the policy.
Step 4 In the Admin State field, indicate whether the administrative state of the policy is to be enabled or disabled.
Step 5 To add a rule to the policy, click Add Rule.
Step 6 In the Add NAT Policy Rule dialog box, provide the information as described in Add NAT Policy Rule Dialog

Box, on page 96, then click OK in the open dialog boxes.

Add NAT Policy Rule Dialog Box

Add NAT Policy Rule Dialog Box

DescriptionField

Rule name.Name

Brief rule description.Description

Original Packet Match Conditions

Source attributes that must be matched for the current
policy to apply.

To add a new condition, click Add Rule Condition.

Available source attributes are IP Address and
Network Port.

Source Match Conditions

Destination attributes that must be matched for the
current policy to apply.

To add a new condition, click Add Rule Condition.

Available destination attributes are IP Address and
Network Port.

Destination Match Conditions
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DescriptionField

Specify the protocols to which the rule applies:

• To apply the rule to any protocol, check theAny
check box.

• To apply the rule to specific protocols:

1 Uncheck the Any check box.

2 From the Operator drop-down list, choose
a qualifier: Equal, Not equal, Member, Not
Member, In range, or Not in range.

3 In the Value fields, specify the protocol,
object group, or range.

Protocol

NAT Action Table

From the drop-down list, choose the required
translation option: Static or Dynamic.

NAT Action

Identify a translated address pool for each original
packet match condition from the following options:

• Source IP Pool

• Source Port Pool

• Source IP PAT Pool

• Destination IP Pool

• Destination Port Pool

For example, if you specify a source IP address match
condition, you must identify a Source IP Pool object
group. Similarly, a destination network port match
requires a Destination Port Pool object group.

The Source IP PAT Pool option is available only if
you choose dynamic translation.

Click Add Object Group to add object groups for
the translation actions.

Translated Address
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DescriptionField

Check and uncheck the check boxes as required:

• Enable Bidirectional—Check the check box for
connections to be initiated bidirectionally; that
is, both to and from the host. Available only for
static address translation.

• Enable DNS—Check the check box to enable
DNS for NAT.

• Enable Round Robin IP—Check the check box
to allocate IP addresses on a round-robin basis.
Available only for dynamic address translation.

• Disable Proxy ARP—Check the check box to
disable proxy ARP. Available only for static
address translation.

NAT Options

Edge routers support a limited set of NAT policy options.Note

Configuring NAT Policy Sets
Policy sets enable you to group multiple policies of the same type (such as NAT, ACL, or Interface) for
inclusion in a profile. NAT policy sets are groups of NAT policies that can be associated with an edge security
profile.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > NAT > NAT Policy Sets.
Step 2 In the General tab, click Add NAT Policy Set.
Step 3 In the Add NAT Policy Set dialog box, enter a name and description for the policy set.
Step 4 In the Admin State field, indicate whether the administrative status of the policy is to be enabled or disabled.
Step 5 In the Policies area, select the policies to include in this policy set:

a) In the Available list, select one or more policies and move them to the Assigned list.
b) Adjust the priority of the assigned policies by using the arrow keys above the list.
c) If required, click Add NAT Policy to add a new policy and include it in the Assigned list.

For information on configuring a NAT policy, see Configuring NAT/PAT Policies, on page 95.

Step 6 Click OK.
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Configuring PAT for Edge Firewalls
Prime Network Services Controller enables you to configure source and destination interface PAT for edge
firewalls, such as the ASA 1000V. For more information, see the following topics.

Configuring Source Dynamic Interface PAT

Prime Network Services Controller enables you to configure source dynamic interface PAT for edge firewalls,
such as ASA 1000Vs.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > NAT > NAT Policies.
Step 2 In the General tab, click Add NAT Policy.
Step 3 In the Add NAT Policy dialog box, enter a name and description for the policy.
Step 4 In the Admin State field, indicate whether the administrative state of the policy is to be enabled or disabled.
Step 5 Click Add Rule to add a rule to this policy.
Step 6 In the Add NAT Policy Rule dialog box, provide the information described in Add NAT Policy Rule Dialog

Box, on page 96 with the following specific settings, then click OK:
a) From the NAT Action drop-down list, choose Dynamic.
b) In the Translated Address area, add a Source IP Pool object group that contains the ASA 1000V outside

interface IP address.

Step 7 Click OK.

Configuring Destination Static Interface PAT

Prime Network Services Controller enables you to configure destination static interface PAT for edge firewalls,
such as ASA 1000Vs, as described in the following procedure.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > NAT > NAT Policies.
Step 2 In the General tab, click Add NAT Policy.
Step 3 In the Add NAT Policy dialog box, enter a name and description for the policy.
Step 4 In the Admin State field, indicate whether the administrative state of the policy is to be enabled or disabled.
Step 5 Click Add Rule to add a rule to this policy.
Step 6 In the Add NAT Policy Rule dialog box, enter the IP address of the ASA 1000V outside interface as a rule

condition for Destination Match Conditions.
Step 7 Configure other options in the Add NAT Policy Rule dialog box as described in Add NAT Policy Rule Dialog

Box, on page 96, then click OK.
If any of the IP address fields includes a range that starts or ends with the IP address of the outside
interface of the ASA 1000V, an error message will be displayed that identifies an overlap with the
ASA 1000V interface IP address.

Note
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Step 8 Click OK.

Configuring Packet Inspection Policies
Prime Network Services Controller enables you to configure policies for application-layer protocol inspection.
Inspection is required for services that embed IP addressing information in the user data packet, or that open
secondary channels on dynamically assigned ports. When inspection is configured, the end device performs
a deep packet inspection instead of quickly passing the packet on. As a result, inspection can affect overall
device throughput.

Protocols Supported for Packet Inspection Policies, on page 100 lists the application-layer protocols supported
by Prime Network Services Controller.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > Packet Inspection.
Step 2 In the General tab, click Add Packet Inspection Policy.
Step 3 In the Add Packet Inspection Policy dialog box, enter a name and description for the policy.
Step 4 In the Admin State field, indicate whether the administrative status of the policy is enabled or disabled.
Step 5 To add a rule to the policy, click Add Rule.
Step 6 In the Add Packet Inspection Policy Rule Dialog box, provide the information as described in Add Packet

Inspection Policy Rule Dialog Box, on page 101, then click OK in the open dialog boxes.

Protocols Supported for Packet Inspection Policies

SQL *NetPPTPICMPCTIQBE

SunRPCRSHICMP ErrorDCE/RPC

TFTPRSTPILSDNS

WAASSIPIP OptionsFTP

XDMCPSkinnyIPsec Pass-ThroughH323 H225

SMTPMGCPH323 RAS

SNMPNetBIOSHTTP
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Add Packet Inspection Policy Rule Dialog Box

DescriptionField

Rule name.Name

Brief rule description.Description

Under Enable Inspections, check the check boxes of
protocols to be inspected if the rule conditions are
met.

Action

Not available for configuration.Protocol

Source Conditions

Destination Conditions

Configuring Routing Policies
Prime Network Services Controller enables you to use routing policies to configure static, OSPF, and BGP
routes for managed resources.

You can configure only inside and outside interfaces on edge firewalls by using Prime Network Services
Controller. Use the CLI to configure routes on the edge firewall management interface.

Note

After you configure a static route routing policy, you can implement the policy by:

• Including the routing policy in an edge device profile.

• Applying the edge device profile to an edge firewall that has managed endpoints.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > Routing.
Step 2 In the General tab, click Add Routing Policy.
Step 3 In the Add Routing Policy dialog box, enter a name and brief description for the routing policy.
Step 4 To add a new static route, click Add Static Route.
Step 5 In the Add Static Route dialog box, enter the following information:

a) In the Destination Network fields, enter the IP route prefix and prefix mask for the destination.
b) In the Forwarding (Next Hop) fields, enter the IP address of the next hop that can be used to reach the

destination network.
The Forwarding Interface field applies only to ASA 1000V data interfaces. Use the CLI to
configure routes on the ASA 1000V management interface.

Note
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c) (Optional) In the Distance Metric field, enter the distance metric.

Step 6 Click OK.

Configuring TCP Intercept Policies
Prime Network Services Controller enables you to configure TCP intercept policies that you can then associate
with an edge security profile. TCP intercept policies that you associate with a device via an edge security
profile are applied to all traffic on the outside interface of the device.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > TCP Intercept.
Step 2 In the General tab, click Add TCP Intercept Policy.
Step 3 In the Add TCP Intercept Policy dialog box, enter a name and brief description for the policy.
Step 4 In the Admin State field, indicate whether the administrative status of the policy is to be enabled or disabled.
Step 5 To add a rule to the policy, click Add Rule.
Step 6 In the Add TCP Intercept Policy Rule dialog box, provide the information as described in Add TCP Intercept

Policy Rule Dialog Box, on page 102.

Add TCP Intercept Policy Rule Dialog Box

DescriptionField

Rule name.Name

Brief rule description.Description

Number of embryonic TCP connections allowed
overall and per client:

1 In the Total field, enter the maximum number of
embryonic TCP connections allowed.

2 In the client field, enter the maximum number of
embryonic TCP connections allowed per client.

The default value 0 (zero) indicates unlimited
connections.

Maximum Number of Embryonic TCP Connections
(0-65535)

Not available for configuration.Protocol

Not available for configuration.Source Conditions
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DescriptionField

Not available for configuration.Destination Conditions

Configuring Site-to-Site IPsec VPN Policies
Prime Network Services Controller enables you to configure site-to-site IPsec VPNs. In addition, you can
configure a crypto map policy and attach it to an edge profile. For ease of configuration and to keep logical
IPsec entities separate, configuration is divided into the following sections:

• Configuring Crypto Map Policies

• Configuring IKE Policies

• Configuring Interface Policy Sets

• Configuring IPsec Policies

• Configuring Peer Authentication Policies

• Configuring VPN Device Policies

To access VPN policies, choose Policy Management > Service Policies > root > Policies > VPN.

Configuring Crypto Map Policies
Prime Network Services Controller enables you to create crypto map policies that include:

• Rules for source and destination conditions.

• IP Security (IPsec) options, including an IPsec policy.

• Internet Key Exchange (IKE) options, including a peer device.

Crypto map policies are applied to interfaces by means of their inclusion in interface policy sets and edge
security policies.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > VPN > Crypto Map Policies.
Step 2 In the General tab, click Add Crypto Map Policy.
Step 3 In the Add Crypto Map Policy dialog box, provide the information as described in Add Crypto Map Policy

Dialog Box, on page 104, then click OK.
Step 4 To add a policy rule, click Add Rule in the General tab and provide the required information as described in

Add Crypto Map Policy Rule Dialog Box, on page 106.
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Add Crypto Map Policy Dialog Box

DescriptionField

General Tab

Policy name.Name

Brief policy description.Description

Whether the administrative status of the policy is
enabled or disabled.

Admin State

Rule Table

Click Add Rule to add a new rule to the current
policy.

Add Rule

IPsec Settings Tab

Length of time (in days, hours, minutes, and seconds)
that a security association (SA) lives before expiring.

SA Lifetime

Volume of traffic, in kilobytes, that can pass between
IPsec peers using a given SA before that association
expires.

SA Lifetime Traffic (KB)

Whether or not Perfect Forward Secrecy (PFS) is
enabled.

PFS is a cryptographic characteristic associated with
a derived shared secret value. With PFS, if one key
is compromised, previous and subsequent keys are
not compromised, because subsequent keys are not
derived from previous keys.

Enable Perfect Forwarding Secrecy

Available if PFS is enabled.

Choose the Diffie-Hellman (DH) group for this
policy:

• Group 1—The 768-bit DH group.

• Group 2—The 1024-bit DH group.

• Group 5—The 1536-bit DH group.

Diffie-Hellman Group

The IPsec policy that applies to the current policy.

Select an existing IPsec policy or click Add IPsec
Policy to create a new policy.

IPsec Policies
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DescriptionField

Peer device.

Choose an existing peer or clickAdd Peer Device to
add a new peer.

In the Add Peer Device dialog box, enter the peer
device IP address or hostname.

Peer Device

Other Settings Tab

Whether or not IPsec peers can establish a connection
through a NAT device.

Enable NAT Traversal

Whether or not static routes are automatically added
to the routing table and then announced to neighbors
on the private network.

Enable Reverse Route Injection

Connection type for this policy:

• Answer-Only—Responds only to inbound IKE
connections during the initial proprietary
exchange to determine the appropriate peer to
which to connect.

• Bidirectional—Accepts and originates
connections based on this policy.

• Originate-Only—Initiates the first proprietary
exchange to determine the appropriate peer to
which to connect.

Connection Type

Mode to use for exchanging key information and
setting up SAs:

• Aggressive Mode—Faster mode, using fewer
packets and exchanges, but does not protect the
identity of the communicating parties.

• MainMode—Slowermode, usingmore packets
and exchanges, but protects the identities of the
communicating parties.

Negotiation Mode

DH group to use when in aggressive mode: Group 1,
Group 2, or Group 5.

DH Group for Aggressive Mode
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Add Crypto Map Policy Rule Dialog Box

DescriptionField

Rule name.Name

Brief rule description.Description

Action to take based on this rule: Permit or Deny.VPN Action

Protocols to examine for this rule:

• To examine all protocols, check the Any check
box.

• To examine specific protocols:

1 Uncheck the Any check box.

2 From the Operator drop-down list, choose
a qualifier: Equal, Not equal, Member, Not
Member, In range, or Not in range.

3 In the Value fields, specify the protocol,
object group, or range.

Protocol

Source attributes that must be matched for the rule to
apply.

To add a new condition, click Add Rule Condition.

Available source attributes are IP Address and
Network Port.

Source Conditions

Destination attributes that must be matched for the
rule to apply.

To add a new condition, click Add Rule Condition.

Available destination attributes are IP Address and
Network Port.

Destination Conditions

Configuring IKE Policies
The Internet Key Exchange (IKE) protocol is a hybrid protocol that implements Oakley and SKEME key
exchanges inside the Internet Security Association and Key Management Protocol (ISAKMP) framework.
The initial IKE implementation used the IPsec protocol, but IKE can be used with other protocols. IKE provides
authentication of the IPsec peers, negotiates IPsec keys, and negotiates the IPsec Security Associations (SAs).
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Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > VPN > IKE Policies.
Step 2 In the General tab, click Add IKE Policy.
Step 3 In the Add IKE Policy dialog box, enter a name and description for the policy.
Step 4 Configure either an IKE V1 or IKE V2 policy:

• IKE V1 Policy

1 Click Add IKE V1 Policy.

2 In the Add IKE V1 Policy dialog box, provide the information described in IKE V1 Policy Dialog
Box, on page 107, then click OK.

• IKE V2 Policy

1 Click Add IKE V2 Policy.

2 In the Add IKE V2 Policy dialog box, provide the information described in IKE V2 Policy Dialog
Box, on page 107, then click OK.

Step 5 Click OK.

IKE V1 Policy Dialog Box

DescriptionField

Diffie-Hellman group: Group 1, Group 2, or Group
5.

DH Group

Encryptionmethod: 3DES,AES,AES-192, AES-256,
or DES.

Encryption

Hash algorithm: MD5 or SHA.Hash

Authentication method is Preshared key.Authentication

Length of time (in days, hours, minutes, and seconds)
that an SA lives before expiring.

SA Lifetime

IKE V2 Policy Dialog Box

DescriptionField

Diffie-Hellman group: Group 1, Group 2, Group 5,
or Group 14.

DH Group
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DescriptionField

Encryptionmethod: 3DES,AES,AES-192, AES-256,
or DES.

Encryption

Hash integrity algorithm: MD5, SHA, SHA256,
SHA384, or SHA512.

Hash

Pseudo-random function (PRF) has algorithm:MD5,
SHA, SHA256, SHA384, or SHA512.

Pseudo Random Function Hash

Length of time (in days, hours, minutes, and seconds)
that an SA lives before expiring.

SA Lifetime

Configuring Interface Policy Sets
Interface policy sets enable you to group multiple policies for inclusion in an edge security profile.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > VPN > Interface Policy Sets.
Step 2 In the General tab, click Add Interface Policy Set.
Step 3 In the Add Interface Policy Set dialog box, provide the information as described in Add Interface Policy Set

Dialog Box, on page 108, then click OK.

Add Interface Policy Set Dialog Box

General Tab

DescriptionField

Policy set name.Name

Brief description of the policy set.Description

Administrative state of the policy set: enabled or
disabled.

Admin State

Policies Area

Click to add a new policy.Add Crypto Map Policy
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DescriptionField

Policies that can be assigned to the policy set.

Use the arrows between the columns to move policies
between columns.

Available

Policies assigned to the policy set.Assigned

Changes the priority of the selected policies.

Arrange the policies from highest to lowest priority,
with the highest priority policy at the top of the list.

Up and down arrows

Domain Settings Tab

DescriptionField

Check the appropriate check box to specify IKE V1
or IKE V2.

Enable IKE (Must check at least one)

Check the check box to fragment packets before
encryption. Pre-fragmentation minimizes
post-fragmentation (fragmentation after encryption)
and the resulting reassembly before decryption,
thereby improving performance.

Enable IPsec Pre-fragmentation

Available only if the Enable IPsec Pre-fragmentation
check box is checked.

From the drop-down list, choose the action to take
with the Don't Fragment (DF) bit in the encapsulated
header:

• Clear

• Copy

• Set

Do Not Fragment

Configuring IPsec Policies
IPsec policies define the IPsec policy objects used to create a secure IPsec tunnel for a VPN.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > VPN > IPsec Policies.
Step 2 In the General tab, click Add IPsec Policy.
Step 3 In the Add IPsec Policy dialog box, enter a name and description for the policy.
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You must configure ethier an IKE V1 or IKE V2 proposal for an IPsec policy.

Step 4 To configure an IKE V1 proposal:
a) In the IKE v1 Proposal Table area, click Add IPsec IKEv1 Proposal.
b) In the IPsec IKEv1 Proposal dialog box, provide the information described in IPsec IKEv1 Proposal Dialog

Box, on page 110, then click OK.

Step 5 To configure an IKE V2 proposal:
a) In the IKE v2 Proposal Table area, click Add IPsec IKE v2 Proposal.
b) In the IPsec IKEv2 Proposal dialog box, provide the information described in IPsec IKEv2 Proposal Dialog

Box, on page 111, then click OK.

Step 6 Click OK to save the policy.

IPsec IKEv1 Proposal Dialog Box

DescriptionField

Mode in which the IPsec tunnel operates.

In Tunnel mode, the IPsec tunnel encapsulates the
entire IP packet.

Mode

Encapsulating Security Protocol (ESP) encryption
method:

• 3DES—Encrypts three times according to the
Data Encryption Standard (DES) using 56-bit
keys.

• AES—Encrypts according to the Advanced
Encryption Standard (AES) using 128-bit keys.

• AES-192—Encrypts according to theAES using
192-bit keys.

• AES-256—Encrypts according to theAES using
256-bit keys.

• DES—Encrypts according to the DES using
56-bit keys.

• Null—Null encryption algorithm. Transform
sets defined with ESP-Null provide
authentication without encryption; this method
is typically used for testing purposes only.

ESP Encryption
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DescriptionField

Hash authentication algorithm:

• MD5—Produces a 128-bit digest.

• Null—Does not perform authentication.

• SHA—Produces a 160-bit digest.

ESP Authentication

IPsec IKEv2 Proposal Dialog Box

DescriptionField

To add an ESP encryption method:

1 Click Add ESP Encryption Algorithm.

2 From the ESP Encryption drop-down list, choose
the encryption method:

• 3DES—Encrypts three times according to
the Data Encryption Standard (DES) using
56-bit keys.

• AES—Encrypts according to the Advanced
Encryption Standard (AES) using 128-bit
keys.

• AES-192—Encrypts according to the AES
using 192-bit keys.

• AES-256—Encrypts according to the AES
using 256-bit keys.

• DES—Encrypts according to the DES using
56-bit keys.

• Null—Null encryption algorithm. Transform
sets defined with ESP-Null provide
authentication without encryption; this
method is typically used for testing purposes
only.

ESP Encryption Algorithm Table
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DescriptionField

To add an integrity algorithm:

1 Click Add Integrity Algorithm.

2 From the Integrity Algorithm drop-down list,
choose the authentication algorithm:

• MD5—Produces a 128-bit digest.

• Null—Does not perform authentication.

• SHA—Produces a 160-bit digest.

Integrity Algorithm Table

Configuring Peer Authentication Policies
Use a peer authentication policy to define the method used to authenticate a peer.

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > VPN > Peer Authentication Policies.
Step 2 In the General tab, click Add Peer Authentication Policy.
Step 3 In the Add Peer Authentication Policy dialog box, enter a name and description for the policy.
Step 4 Click Add Policy to Authenticate Peer.
Step 5 In the Add Policy to Authenticate Peer dialog box, provide the information described in Add Policy to

Authenticate Peer Dialog Box, on page 112, then click OK.
Step 6 Click OK to save the policy.

Add Policy to Authenticate Peer Dialog Box

DescriptionField

Unique IP address or hostname of the peer.Peer Device (Unique)

IKEv1 Area

Preshared key.Local

Preshared key for confirmation.Confirm

Whether or not the preshared key has been set and is
properly configured (read-only).

Set

IKEv2 Area
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DescriptionField

Local preshared key.Local

Local preshared key for confirmation.Confirm

Whether or not the local preshared key has been set
and is properly configured (read-only).

Set

Remote preshared key.Remote

Remote preshared key for confirmation.Confirm

Whether or not the remote preshared key has been
set and is properly configured (read-only).

Set

Configuring VPN Device Policies
A VPN device policy enables you to specify VPN global settings, such as:

• IKE policy

• IKE global settings

• IPsec global settings

• Peer authentication policy

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policies > VPN > VPN Device Policies.
Step 2 In the General tab, click Add VPN Device Policy.
Step 3 In the Add VPN Device Policy dialog box, provide the information as described in Add VPN Device Policy

Dialog Box, on page 114.
Step 4 As needed, provide the information described in the following tables:

• Configuring IKE Policies, on page 106

• Configuring Peer Authentication Policies, on page 112

Step 5 Click OK to create the policy.
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Add VPN Device Policy Dialog Box

General Tab

A VPN device policy requires both an IKE policy and a peer authentication policy.Note

DescriptionField

Policy name.Name

Brief policy description.Description

Choose an existing policy from the drop-down list,
or click Add IKE Policy to add a new policy.

IKE Policy

Choose an existing policy from the drop-down list,
or click Add Peer Authentication Policy to add a
new policy.

Peer Authentication Policy

IKE Settings Tab

DescriptionField

Whether or not IPsec traffic is allowed over TCP. If
IPsec over TCP is enabled, this method takes
precedence over all other connection methods.

Enable IPsec over TCP

Whether or not clients are notified that sessions will
be disconnected.

Send Disconnect Notification

Whether or not inbound aggressivemode is permitted.Allow Inbound Aggressive Mode

Whether or not a reboot can occur only when all
active sessions have terminated voluntarily.

Wait for Termination before Rebooting

Percentage of the maximum number of allowed
Security Associations (SAs) that can be in-negotiation
(open) before cookie challenges are issued for future
SA negotiations.

Threshold for Cookie Challenge (0-100 Percent)

Percentage of the maximum number of allowed SAs
that can be in-negotiation before additional
connections are denied.

The default value is 100 percent.

Negotiation Threshold for Maximum SAs (0-100
Percent)
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DescriptionField

Phase 2 identification method:

• Automatic—Determines ISAKMP negotiation
by connection type:

◦IP address for a preshared key.

◦Cert DN for certificate authentication.

• IP Address—IP address of the host exchanging
ISAKMP identity information.

• Hostname—Fully qualified domain name of the
host exchanging ISAKMP identity information.

• Key ID—String used by the remote peer to look
up the preshared key.

IKE Identity

The key to use for IKE identify if the IKE
identification method is Key ID.

Key for IKE Identity

Whether or not IPsec peers can establish a connection
through a NAT device.

NAT Traversal

Length of time (in hours, minutes, and seconds) that
a tunnel can exist with no activity before the device
sends keepalive messages to the peer.

Values range from 10 to 3600 seconds, with a default
of 20 seconds.

Keep-Alive Time for NAT Traversal

Whether or not the total number of IKE V2 SAs on
the node can be set.

IKEv2 IPsec Maximum Security Associations

Maximum number of SA connections allowed.Maximum Number of SA

1 ClickAdd IKEV1Over TCP Port to add a new
port.

2 In the Port field, enter the TCP port to use for IKE
V1.

IKEv1 over TCP Port Table

IPsec Settings Tab

DescriptionField

Whether or not SA anti-replay is enabled.Anti Replay
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DescriptionField

Window size to use to track and prevent duplication
of packets. Using a larger window size allows the
decryptor to track more packets.

Anti Replay Window Size

Length of time (in days, hours, minutes, and seconds)
that an SA can live before expiring.

SA Lifetime

Volume of traffic, in kilobytes, that can pass between
IPsec peers using a given SA before the association
expires.

SA Lifetime Volume (KB)

Configuring Zone-Based Firewall Policies
A zone policy defines the traffic that you want to allow or deny between zones. A zone-pair policy allows
you to specify a unidirectional firewall policy between two zones. The direction is defined by specifying a
source and destination zone.

A firewall zone is a group of interfaces to which a policy can be applied. By default, traffic can flow freely
within that zone but all traffic to and from that zone is dropped. To allow traffic to pass between zones, you
must explicitly declare it by creating a zone-pair and a policy for that zone.

This workflow is part of the Edge Router Configuration Workflow, on page 191.

For more information on Zone Based Firewall policies and options, see http://www.cisco.com/en/US/partner/
products/sw/secursw/ps1018/products_tech_note09186a00808bc994.shtml.

Procedure

Step 1 Choose Policy Management > Service Policies > tenant > Policies and select Zone Based Firewall.
Step 2 Choose Zone Pair Policies and add a zone pair policy. In this step you designate a source and destination

zone and apply a policy map. If you have not configured a policy map, you can create one now and also
configure associated class maps and rules.

Step 3 Choose Policy Sets and create a policy set by identifying zone pair policies.

Working with Profiles
A profile is a collection of policies. By creating a profile with policies that you select, and then applying that
profile to multiple objects, such as edge firewalls, you can ensure that those objects have consistent policies.

A device must be registered to Prime Network Services Controller before you can apply a profile to it.

Prime Network Services Controller enables you to create and apply the following types of profiles:

• Compute security profiles—Compute firewall profiles that include ACL policies and user-defined
attributes.
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• Edge device profiles—Edge firewall profiles that include routing, VPN, DHCP, and IP Audit policies.

• Edge security profiles—Edge firewall profiles that include access and threat mitigation policies.

The following topics describe how to configure and apply profiles.

Configuring Compute Security Profiles
Prime Network Services Controller enables you to create compute security profiles at the root or tenant level.
Creating a compute security profile at the root level enables you to apply the same profile to multiple tenants.

Procedure

Step 1 Choose Policy Management > Service Profiles > root > Compute Firewall > Compute Security Profiles.
Step 2 In the General tab, click Add Compute Security Profile.
Step 3 In the Add Compute Security Profile dialog box, provide the information as described in Add Compute

Security Profile Dialog Box, on page 117, then click OK.

Add Compute Security Profile Dialog Box

General Tab

DescriptionField

Profile name. This name can be between 2 and 32
identifier characters. You can use alphanumeric
characters including hyphen, underscore, dot, and
colon. You cannot change this name after it is saved.

Name

Brief profile description. This description can be
between 1 and 256 identifier characters. You can use
alphanumeric characters including hyphens,
underscore, dot, and colon.

Description

Drop-down list of policy sets.Policy Set

Click the link to add an ACL policy set.Add ACL Policy Set

Click the link to edit the resolved policy set.Resolved Policy Set

Resolved Policies Area

Click the link to assign or unassign a policy.(Un)assign Policy

Rule name.Name
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DescriptionField

Source condition for the rule.Source Condition

Destination condition for the rule.Destination Condition

Service or protocol to which the rule applies.Service/Protocol

Encapsulated protocol to which the rule applies.EtherType

Action to take if the rule conditions are met.Action

Rule description.Description

Attributes Tab

DescriptionField

Opens a dialog box for adding an attribute.Add User Defined Attribute

Attribute name.Name

Attribute value.Value

Verifying Compute Firewall Policies
Use this procedure to verify active policies and optionally modify policy objects for compute firewalls.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant > Compute Firewalls >
compute-firewall.

Step 2 In the Compute Security Profiles tab, select the required policy, then click Show Resolved Policies.
Step 3 In the Edit dialog box, click the required policy in the Resolved Policies table to view the policy details, such

as source and destination conditions.
Step 4 To modify a policy, in the Policy Set area, either choose a different policy from the drop-down list, or click

Add ACL Policy Set to configure a new policy.
Step 5 Click Apply to accept any changes or OK when you have finished reviewing the policies.

Configuring Edge Device Profiles
Edge device profiles contain the following policies in addition to a timeout value for address translation:
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• DHCP

• IP audit signature

• Routing

• VPN device

You can create an edge device profile at any level of the organization hierarchy (root, tenant, virtual data
center (VDC), app, or tier). Creating an edge device profile at the root level enables you to apply it to multiple
edge firewalls for different tenants.

Procedure

Step 1 Choose Policy Management > Service Profiles > root > Edge Firewall > Edge Device Profiles.
Step 2 In the General tab, click Add Edge Device Profile.
Step 3 In the Add Edge Device Profile dialog box, enter the information as described in Edge Device Profile Dialog

Box, on page 119, then click OK.

Edge Device Profile Dialog Box

DescriptionField

General Tab

Profile name.Name

Brief profile description.Description

Policies Tab

Choose an existing policy or click Add Routing
Policy to add a new policy.

Click the Resolved Policy link to review or modify
the assigned policy.

Routing Policy

Choose an existing policy or click Add IP Audit
Signature Policy to add a new policy.

Click the Resolved Policy link to review or modify
the assigned policy.

IP Audit Signature Policy

Choose an existing policy or click Add VPN Device
Policy to add a new policy.

Click the Resolved Policy link to review or modify
the assigned policy.

VPN Device Policy
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DescriptionField

Length of time (in days, hours, minutes, and seconds)
that a translation can remain unused before it expires.

Address Translations Timeout

DHCP Policy

Adds a DHCP policy.Edge DHCP Policy

Type of DHCP service: relay or server.Type

Interface to which the DHCP policy is applied.Interface Name

DHCP policy name.Server/Relay Policy

Configuring Edge Security Profiles
Edge security profiles can include any of the following:

• ACL policy sets (ingress and egress)

• Connection timeout policies

• IP audit policies

• NAT policy sets

• Packet inspection policies

• TCP intercept policies

• VPN interface policy sets

You can create an edge security profile at any level of the organizational hierarchy (root, tenant, VDC, app,
or tier). Creating an edge security profile at the root level enables you to apply it to multiple edge firewalls
for different tenants.

Procedure

Step 1 Choose Policy Management > Service Profiles > Edge Firewall > Edge Security Profiles.
Step 2 In the General tab, click Add Edge Security Profile.
Step 3 In the Add Edge Security Profile dialog box provide the information as described in Add Edge Security Profile

Dialog Box, on page 121.

   Cisco Prime Network Services Controller 3.2 User Guide
120

Configuring Service Policies and Profiles
Configuring Edge Security Profiles



Add Edge Security Profile Dialog Box

DescriptionField

General Tab

Profile name.Name

Brief profile description.Description

Ingress Tab

Choose an existing policy set or click Add ACL
Policy Set to add a new policy set.

Click theResolved Ingress Policy Set link to modify
the assigned policy set.

Policy Set

Click (Un)assign Policy to assign or remove a policy
for the current policy set.

Resolved Policies

Egress Tab

Choose an existing policy set or click Add ACL
Policy Set to add a new policy set.

Click theResolved Egress Policy Set link to modify
the assigned policy set.

Policy Set

Click (Un)assign Policy to assign or remove a policy
for the current policy set.

Resolved Policies

NAT Tab

Choose an existing policy set or click Add NAT
Policy Set to add a new policy set.

Click the Resolved NAT Policy Set link to modify
the assigned policy set.

Policy Set

Click (Un)assign Policy to assign or remove a policy
for the current policy set.

Resolved Policies

VPN Tab

Choose an existing policy set or clickAdd Interface
Policy Set to add a new policy set.

Click the Resolved VPN Interface Policy Set link
to modify the assigned policy set.

Policy Set

Advanced Tab
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DescriptionField

Choose an existing policy or click Add Packet
Inspection Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

Packet Inspection Policy

Choose an existing policy or click Add Connection
Timeout Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

Connection Timeout Policy

Choose an existing policy or click Add TCP
Intercept Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

TCP Intercept Policy

Choose an existing policy or click Add IP Audit
Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

IP Audit Policy

Applying an Edge Device Profile
After you have created an edge device profile, you can apply the profile to multiple edge firewalls to ensure
consistent policies across the firewalls.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant > Edge Firewalls > edge-firewall.
Step 2 In the General tab, click Select in the Edge Device Profile field.
Step 3 In the Select Edge Device Profile dialog box, select the required profile, then click OK.
Step 4 Click Save.

Applying an Edge Security Profile
After you have created an edge security profile, you can apply it to edge firewall instances to ensure consistent
policies on the interfaces.
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Edge security profiles can be applied only on outside interfaces of edge firewalls.Note

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant > Edge Firewalls > edge-firewall.
Step 2 In the Interfaces table, select the required outside interface, then click Edit.
Step 3 In the Edit dialog box, click Select in the Edge Security Profile field.
Step 4 In the Select Edge Security Profile dialog box, select the required profile, then click OK.
Step 5 Click OK in the open dialog boxes, then click Save.

Verifying Edge Firewall Policies
Use this procedure to verify active policies and optionally modify policy objects for edge firewalls.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant > Edge Firewalls > edge-firewall.
Step 2 In the Edge Security Profiles tab, select the required policy, then click Show Resolved Policies.
Step 3 To view policy or policy set details, use the tabs in the Edit dialog box to navigate to the required policy or

policy set, then click the required policy or policy set in Resolved field
Step 4 To use a different policy or policy set, navigate to the required policy or policy set, then either choose a

different policy or policy set from the drop-down list, or add a new policy or policy set.
Step 5 Click Apply to accept any changes or OK when you have finished reviewing the policies.

Configuring Security Profiles

Editing a Security Profile for a Compute Firewall

Procedure

Step 1 Choose PolicyManagement > Service Profiles > root > Compute Firewalls > Compute Security Profiles.
Step 2 In the General tab, select the profile you want to edit, then click Edit.
Step 3 In the Edit Compute Security Profile dialog box, edit the fields as required by using the information in the

following tables, then click OK.
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DescriptionField

Profile name.Name

Brief policy description.Description

List of available policy sets.Policy Set

Click to add a new ACL policy set.Add ACL Policy Set

Click the link to view and optionally edit the resolved
policy set.

Resolved Policy Set

Resolved Policies

Click to assign or unassign policies.(Un)assigned Policy

Policy name.Name

Source condition for the policy.Source Condition

Destination condition for the policy.Destination Condition

Protocol specify by the policy.Service/Protocol

EtherType specified by the policy.EtherType

Action to take if the specified condition is met.Action

Brief policy description.Description

DescriptionField

Click to add a custom attribute.Add User Defined Attribute

Attribute name.Name

Attribute value.Value

Editing a Security Profile for an Edge Firewall
This procedure enables you to edit a security profile associated with an edge firewall.
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Procedure

Step 1 Choose Policy Management > Service Profiles > root > Edge Firewall > Edge Security Profiles.
Step 2 In the General tab, select the edge security profile that you want to edit, then click Edit.
Step 3 In the Edit Edge Security Profile dialog box, edit the entries as required by using the information in the

following table, then click OK.
DescriptionField

General Tab

Profile name (read-only).Name

Brief profile description.Description

Unique profile identifier (read-only).ID

Ingress Tab

Choose an existing policy set or click Add ACL
Policy Set to add a new policy set.

Click theResolved Ingress Policy Set link to modify
the assigned policy set.

Policy Set

Click (Un)assign Policy to assign or remove a policy
for the current policy set.

Resolved Policies

Egress Tab

Choose an existing policy set or click Add ACL
Policy Set to add a new policy set.

Click theResolved Egress Policy Set link to modify
the assigned policy set.

Policy Set

Click (Un)assign Policy to assign or remove a policy
for the current policy set.

Resolved Policies

NAT Tab

Choose an existing policy set or click Add NAT
Policy Set to add a new policy set.

Click the Resolved NAT Policy Set link to modify
the assigned policy set.

Policy Set

Click (Un)assign Policy to assign or remove a policy
for the current policy set.

Resolved Policies

VPN Tab
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DescriptionField

Choose an existing policy set or clickAdd Interface
Policy Set to add a new policy set.

Click the Resolved VPN Interface Policy Set link
to modify the assigned policy set.

Policy Set

Advanced Tab

Choose an existing policy or click Add Packet
Inspection Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

Packet Inspection Policy

Choose an existing policy or click Add Connection
Timeout Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

Connection Timeout Policy

Choose an existing policy or click Add TCP
Intercept Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

Threat Migration

Choose an existing policy or click Add IP Audit
Policy to add a new policy.

Click theResolved Policy link to modify the assigned
policy.

IP Audit Policy

Deleting a Security Profile

Procedure

Step 1 In the Navigation pane, choose Policy Management > Security Policies> root > Security Profiles.
Step 2 In theWork pane, click the security profile you want to delete.
Step 3 Click Delete.
Step 4 In the Confirm dialog box, click OK.
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Deleting a Security Profile Attribute

Procedure

Step 1 In the Navigation pane, choose Policy Management > Security Profiles > root > Security Profiles >
security profile. The security profile is the profile that contains the attribute you want to delete.

Step 2 In theWork pane, click the Attributes tab.
Step 3 Click the attribute you want to delete.
Step 4 Click Delete.
Step 5 In the Confirm dialog box, click OK.

Assigning a Policy

Procedure

Step 1 In the Navigation pane, expand Policy Management > Security Profiles > root > Security Profiles.
Step 2 Click the profile where you want to assign the policy.
Step 3 In theWork pane, click the (Un)assign Policy link.
Step 4 In the (Un)assign Policy dialog box, move the policy you want assigned to the Assigned list.
Step 5 Click OK.

Unassigning a Policy

Procedure

Step 1 In the Navigation pane, expand Policy Management > Security Profiles > root > Security Profiles.
Step 2 Click the profile where you want to unassign the policy.
Step 3 In theWork pane, click the (Un)assign Policy link.
Step 4 In the (Un)assign Policy dialog box, move the policy you want unassigned to the Available list.
Step 5 Click OK.
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Configuring Security Policy Attributes

Configuring Object Groups
An object group defines a collection of condition expressions on a system-defined or user-defined attribute.
An object group can be referred to in a policy rule condition when the member or not-member operator is
selected. A rule condition that refers to an object group resolves to true if any of the expressions in the object
group are true.

Object groups can be created at any level in the organizational hierarchy.

Adding an Object Group

Procedure

Step 1 Choose Policy Management > Service Policies > root > tenant > Policy Helpers > Object Groups.
Step 2 In the General tab, click Add Object Group.
Step 3 In the Add Object Group dialog box, complete the following fields, then click OK:

You must specify an attribute type and name before adding an object group expression. If VNMC
was installed on Hyper-V hypervisor: the attribute type VM is not supported and if you choose the
attribute type Network, attribute name Service is not supported.

Note

DescriptionField

Object group name.

This name can be between 2 and 32 identifier
characters. You can use alphanumeric characters
including hyphen, underscore, dot, and colon. You
cannot change this name after it is saved.

Name

Brief description of the object group.

This description can be between 1 and 256 identifier
characters. You can use alphanumeric characters
including hyphens, underscore, dot, and colon.

Description

Available attribute types: Network, VM, User
Defined, vZone, and Time Range.

Youmust configure an attribute type and name to add
an object group expression.

Attribute Type

Available attribute names for the selected attribute
type.

Attribute Name

Expression Table

Click to add an object group expression.Add Object Group Expression
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DescriptionField

Operator for the selected expression.Operator

Value for the selected expression.Value

Adding an Object Group Expression

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Object Groups.
Step 2 In the General tab, select the object group you want to add an object group expression to, then click Edit.

For new object groups, you must specify the attribute type and name before adding an object group
expression.

Note

Step 3 In the Edit Object Group dialog box, click Add Object Group Expression.
Step 4 In the Add Object Group Expression dialog box, specify the object group expression by using the information

in the following table, then click OK in the open dialog boxes.
DescriptionField

Attribute (read-only).Attribute Name

Available operators for this attribute.Operator

Attribute value for this expression.Attribute Value

Editing an Object Group

Procedure

Step 1 Choose Policy Management > Service Policies > root > tenant > Policy Helpers > Object Groups.
Step 2 In the General tab, select the object group you want to edit, then click Edit.
Step 3 In the Edit Object Group dialog box, update the fields as follows, then click OK in the open dialog boxes:

DescriptionField

Object group name (read-only).Name
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DescriptionField

Object group description.

This description can be between 1 and 256 identifier
characters. You can use alphanumeric characters
including hyphens, underscore, dot, and colon.

Description

Specified attribute type (read-only).Attribute Type

Specified attribute name (read-only).Attribute Name

Expression Table

Click to add a new object group expression.Add Object Group Expression

Enables you to edit the selected object group
expression.

Edit

Deletes the selected object group expression.Delete

Expression operator.Operator

Expression attribute value.Value

Editing an Object Group Expression

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Object Groups.
Step 2 In the General tab, select the object group with the expression you want to edit, then click Edit.
Step 3 In the Expression table in the Edit Object Group dialog box, select the expression you want to edit, then click

Edit.
Step 4 In the Edit Object Group Expression dialog box, edit the fields as required, then click OK in the open dialog

boxes.
DescriptionField

Attribute name (read-only).Attribute Name

Available operators for this expression.Operator

Attribute value for this expression.Attribute Value
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Deleting an Object Group

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Object Groups.
Step 2 In the General tab, select the Object Group you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Deleting an Object Group Expression

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Object Groups.
Step 2 In the General tab, select the object group that contains the expression you want to delete, then click Edit.
Step 3 In the Edit Object Group dialog box, select the expression that you want to delete In the Expression table,

then click Delete.
Step 4 When prompted confirm the deletion.
Step 5 Click OK in the open dialog box to save the change.

Configuring Security Profile Dictionary

Adding a Security Profile Dictionary

Procedure

Step 1 Choose Policy Management > Service Policies > root > tenant > Policy Helpers > Security Profile
Dictionary.

You can have one security profile dictionary at the root level and one for each
tenant.

Note

Step 2 In the General tab, click Add Security Profile Dictionary.
Step 3 In the Add Security Profile Dictionary dialog box, complete the following fields as appropriate, then click

OK:
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DescriptionField

Name of the security profile dictionary.

This name can contain 1 to 16 alphanumeric
characters. You cannot use spaces or any special
characters, and you cannot change this name after the
object has been saved.

You can have one security profile dictionary
at the root level and one for each tenant.

Note

Name

A description of the security profile dictionary.

This description can be between 1 and 256 identifier
characters. You can use alphanumeric characters
including hyphens, underscore, dot, and colon.

Description

Attributes Table

Click to add a new attribute.Add Security Profile Custom Attribute

Custom attribute name.Name

Custom attribute description.Description

Adding a Security Profile Dictionary Attribute

Procedure

Step 1 Choose Policy Management > Service Policies > root > tenant > Policy Helpers > Security Profile
Dictionary.

Step 2 In the General tab, select the security profile dictionary that you want to add an attribute to, then click Edit.
Step 3 In the Edit Security Profile Dictionary dialog box, click Add Security Profile Custom Attribute.
Step 4 In the Add Security Profile Custom Attribute dialog box, complete the following fields, then click OK:

DescriptionField

Attribute name.

This name can be between 1 and 16 alphanumeric
characters. You cannot use spaces or any special
characters, and you cannot change this name after the
object has been saved.

Name
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DescriptionField

Attribute description.

This description can be between 1 and 256 identifier
characters. You can use alphanumeric characters
including hyphens, underscore, dot, and colon.

Description

Editing a Security Profile Dictionary

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Security Profile Dictionary.
Step 2 In the General tab, select the security profile dictionary you want to edit, then click Edit.
Step 3 In the Edit Security Profile Dictionary dialog box, modify the fields as appropriate, then click OK:

DescriptionField

Name of the security profile dictionary (read-only).Name

Description of the security profile dictionary.Description

Attributes

Click to add a custom attribute.Add Security Profile Custom Attribute

Attribute name.Name

Attribute description.Description
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Editing a Security Profile Dictionary Attribute

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Security Profile Dictionary.
Step 2 In the General tab, select the security profile dictionary that contains the attribute you want to edit, then click

Edit.
Step 3 In the Edit Security Profile Dictionary dialog box, select the attribute you want to edit, then click Edit.
Step 4 In the Edit Security Custom Attribute dialog box, edit the Description field as required, then click OK in the

open dialog boxes to save the change.

Deleting a Security Profile Dictionary

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Security Profile Dictionary.
Step 2 In the General tab, select the security profile dictionary you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Deleting a Security Profile Dictionary Attribute

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > Security Profile Dictionary.
In the General tab, select the dictionary that contains the attribute you want to delete, then click Edit.

Step 2 In the Edit Security Profile Dictionary dialog box, in Attributes table, select the attribute you want to delete,
then click Delete.

Step 3 When prompted, confirm the deletion.

Working with vZones
A virtual zone (vZone) is a logical grouping of VMs or hosts. vZones facilitate working with policies and
profiles because vZones enable you to write policies based on vZone attributes by using vZone names.

The high level flow for working with vZones in Prime Network Services Controller is as follows:

1. Define a vZone, each with one or more conditions for inclusion in the vZone.
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2. Define a service policy with the rules based on zone or network conditions.

3. Create a policy set that includes the service policy defined in Step 2.

4. Create a security profile that includes the policy set created in Step 3.

5. Bind the security profile to the ASA 1000V or VSG port profile.

6. Assign the security profile to the ASA 1000V or VSG in Prime Network Services Controller.

See the following topics for more information about working with vZones.

Adding a vZone

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > vZones.
Step 2 In the General tab, click Add vZone.
Step 3 In the Add vZone dialog box provide the required information as described in the following table, then click

OK:
DescriptionField

vZone name. The name can be between 2 and 32
characters. You can use alphanumeric characters
including hyphen, underscore, dot, and colon. You
cannot change the name after it is saved.

Name

vZone description. The description can be between
1 and 256 identifier characters. You can use
alphanumeric characters including hyphens,
underscore, dot, and colon.

Description

Condition match options:

• Choose match-all for the zone to match all the
conditions (AND).

• Choose match-any for the zone to match any
one condition (OR).

Condition Match Criteria

vZone Condition

Condition type.Attribute Type

Condition attribute name.

vZone conditions cannot be created using
the service attribute.

Note

Attribute Name

Condition operator.Operator

Condition attribute value.Attribute Value
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Editing a vZone

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > vZones.
Step 2 In the General tab, select the vZone that you want to edit, then click Edit.
Step 3 In the Edit vZone dialog box in the General tab, right-click the attribute that you want to edit, and choose

Edit.
Step 4 In the Edit Zone Condition dialog box, edit the fields as required, then click OK in the open dialog boxes.

DescriptionField

vZone name (read-only).Name

Brief vZone description.Description

Choose the required match option:

• Match-all—Match all of the criteria (AND).

• Match-any—Match any one of the criteria (OR).

Condition Match Criteria

vZone Condition

Toolbar

Adds a zone condition.Add Zone Condition

Enables you to edit the selected condition.Edit

Deletes the selected condition.Delete

Filters the contents by the string or value that you
enter.

Filter

Table

Zone condition attribute name.Attribute Name

Zone condition operator.Operator

Value for the zone condition.Attribute Value
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Deleting a vZone Condition

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > vZones.
Step 2 In the General tab, select the vZone with the condition that you want to delete, then click Edit.
Step 3 In the Edit vZone dialog box, select the condition in the vZone Condition table that you want to delete, then

click Delete.
Step 4 Confirm the deletion.
Step 5 In the Edit vZone dialog box, click OK or Apply.

Deleting a vZone

Procedure

Step 1 Choose Policy Management > Service Policies > root > Policy Helpers > vZones.
Step 2 In the General tab, select the vZones that you want to delete, then click Delete.
Step 3 Confirm the deletion.
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C H A P T E R  10
Configuring Device Policies and Profiles

This section includes the following topics:

• Device Policies and Profiles, page 139

• Device Configuration, page 140

• Device Policies, page 141

• Configuring Device Policies, page 141

• Configuring Device Profiles, page 168

• Configuring NTP, page 173

• Associating Device Policies with Profiles, page 175

Device Policies and Profiles
Prime Network Services Controller enables you to create device profiles and policies at any organizational
level.

Device Profiles
A Prime Network Services Controller device profile is a set of custom security attributes and device policies.
For Nexus 1000V VSMs, the device profile is added to the port profile. The port profile is assigned to the
Nexus 1000VVSM vNIC, making the device profile part of the virtual machine (VM). Adding a device profile
to the VM allows the addition of custom attributes to the VM. Firewall rules can be written using custom
attributes such that traffic between VMs can be allowed to pass or be dropped.

You apply device profiles to compute and edge firewalls by choosing Resource Management > Managed
Resources and then navigating to the required compute or edge firewall at the root or tenant level. The Firewall
Settings area of the firewall pane includes the Device Profile option.

Prime Network Services Controller includes a default device profile at root level. The default device profile
can be edited but cannot be deleted.
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Policies
Prime Network Services Controller supports the following objects related to policies:

• Policy set—Contains policies. After a policy set is created, it can be assigned to a profile. An existing
default policy set is automatically assigned at system boot up.

• Policy—Contains rules that can be ordered. An existing default policy is automatically assigned at system
boot up. The default policy contains a rule with an action of drop.

• Rule—Contains conditions for regulating traffic. The default policy contains a rule with an action of
drop. Conditions for a rule can be set using the network, custom, and virtual machine attributes.

• Object group—Can be created under an organization node. An object group defines a collection of
condition expressions on a system-defined or user-defined attribute. An object group can be referred to
in a policy rule condition when the member or not-member operator is selected. A rule condition that
refers to an object group resolves to true if any of the expressions in the object group are true.

• Security Profile Dictionary—Logical collection of security attributes. You define dictionary attributes
for use in a security profile. A security profile dictionary is created at the root or tenant node. You can
create only one dictionary for a tenant and one for root. The security profile dictionary allows the user
to define names of custom attributes. Custom attribute values are specified on security profile objects.
Custom attributes can be used to define policy rule conditions. Attributes configured in a root level
dictionary can be used by any tenant. You cannot create a dictionary below the tenant level.

• Zone—Set of VMs based on conditions. The zone name is used in the authoring rules.

Security policies are created and then pushed to the Cisco VSG or ASA 1000V.

Device Configuration
Prime Network Services Controller enables you to configure devices by adding policies to a device profile
and then applying that profile to a device. To create a root device profile, choose Policy Management >
Device Configurations > root and clickAddDevice Profile. Device profiles contain options for the following
policies and settings:

• DNS server and domain

• NTP server

• SNMP policy

• Syslog policy

• Fault policy

• Core policy

• Log file policy

• Policy engine logging

• Authentication policy
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Device Policies
Prime Network Services Controller enables you to create the following policies and assign them to device
profiles for application to service devices:

• AAA policy

• Core file policy

• Fault policy

• Logging policy

• SNMP policy

• Syslog policy

Prime Network Services Controller provides default polices for fault, logging, SNMP, and syslog. The default
policies cannot be deleted but can be modified. A device profile uses name resolution to resolve policy
assignments. For details, see Name Resolution in a Multi-Tenant Environment, on page 68.

Policies created under root are visible to both the Prime Network Services Controller profile and the Device
profile.

Configuring Device Policies
PrimeNetwork Services Controller enables you to configure andmanage the following types of device policies:

• AAA

• Core File

• Fault

• Log File

• SNMP

• Syslog

Configuring AAA Policies
Authentication, authorization, and accounting (AAA) policies verify users before they are allowed access to
a network and network services. By creatingAAApolicies in PrimeNetwork Services Controller and associating
the policies with objects through device profiles, you can ensure that only authenticated users can access the
objects.

Prime Network Services Controller supports authentication and authorization for edge firewalls and server
groups using the following protocols:

• Kerberos

• Lightweight Directory Access Protocol (LDAP)

•Windows NT
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• RADIUS

• RSA SecurID (SDI)

• TACACS+

You can use Prime Network Services Controller to configure an AAA policy on ASA 1000V. Prime Network
Services Controller does not support AAA policies on VSG, VPX, or CSR 1000V.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > AAA > Auth Policies.
Step 2 In the General tab, click Add Auth Policy.
Step 3 In the Add Auth Policy dialog box, enter the information as described in Add Auth Policy Dialog Box, on

page 142, then click OK.
If you add a remote server group with a new server group with a new server host, the information
that youmust provide for the host depends on the protocol used. For example, the information required
for a RADIUS server host is different from the information required for an LDAP server host. See
the online help for the information required for the selected protocol.

Note

Field Descriptions

Add Auth Policy Dialog Box

DescriptionField

Policy name.Name

Brief policy description.Description

Check the Enable check box to enable authorization
via server authentication.

Authorization

Remote Access Methods

Adds a remote access method to the policy.

For more information, see Remote Access Method
Dialog Box, on page 143.

Add Remote Access Method

One of the following access methods:

• Enable Mode

• HTTP

• Serial

• SSH

• Telnet

Access Method
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DescriptionField

Whether the administrative state of the policy is
enabled or disabled.

Admin State

Remote server group name.Remote Server Group

This column is not used.Local Auth

Remote Access Method Dialog Box

DescriptionField

One of the following access methods:

• Enable Mode

• HTTP

• Serial

• SSH

• Telnet

Access Method

Whether the administrative state of the access method
is enabled or disabled.

Admin State

Indicate the server group to use:

1 In the Protocol for Creation field, choose the
required protocol.

2 In the Server Group fields, do one of the
following:

• From the drop-down list, choose an available
remote server group.

• Click Add Remote Server Group -
protocolto add a new remote server group.

If you add a new remote server group, the
information that you must provide for the
server group and host depends on the
protocol used. For example, the information
required for a RADIUS server group and
host is different from the information
required for an LDAP server group and host.

Note

Server Group

Cisco Prime Network Services Controller 3.2 User Guide    
143

Configuring Device Policies and Profiles
Configuring AAA Policies



Configuring Core File Policies

Adding a Core File Policy for a Device
You can add a core file policy at any organizational level.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Core File.
Step 2 In the General tab, click Add Core File Policy.
Step 3 In the Add Core File Policy dialog box, add the information as described in the following table, then click

OK:
DescriptionField

Core file policy name, containing 1 to 32 characters.
You can use alphanumeric characters, hyphen (-),
underscore (_), and period (.). You cannot change the
name after the policy has been saved.

Name

Brief policy description, containing 1 to 256
characters. You can use alphanumeric characters,
hyphen (-), underscore (_), and period (.).

Description

Indicate whether the administrative state of the policy
is to be enabled or disabled.

Admin State

Hostname or IP address to use for this policy. If you
use a hostname rather than an IP address, you must
configure a DNS server in Prime Network Services
Controller.

Hostname/IP Address

Port number for sending the core dump file.

This field is read-only for InterCloud policies.

Port

Protocol for exporting the core dump file (tftp only).Protocol

Path to use when storing the core dump file on a
remote system. The default path is /tftpboot; for
example, /tftpboot/test, where test is the subfolder.

Path
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Editing a Core File Policy for a Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Core File.
Step 2 In the General tab, select the core file policy you want to edit, then click Edit.
Step 3 In the Edit Core File Policy dialog box, edit the fields as required, using the information in the following table,

then click OK.
DescriptionField

Name of the core file policy (read-only).Name

Brief policy description.Description

Administrative status of the policy: enabled or
disabled.

Admin State

Hostname or IP address.

If you use a hostname, you must configure
a DNS server.

Note

Hostname

Port number to use when exporting the core dump
file.

This field is read-only for InterCloud policies.

Port

Protocol used to export the core dump file (tftp only).Protocol

Path to use when storing the core dump file on the
remote system.

The default path is /tftpboot. To specify a subfolder
under tftpboot, use the format /tftpboot/folder where
folder is the subfolder.

Path

Deleting a Core File Policy from a Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Core File.
Step 2 In the General tab, select the core file policy you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.
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Configuring Fault Policies

Adding a Fault Policy for a Device Profile
You can add a fault policy at any organizational level.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Fault.
Step 2 In the General tab, click Add Fault Policy.
Step 3 In the Add Fault Policy dialog box, enter the information as described in the following table, then click OK.

DescriptionField

Fault policy name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name

Brief policy description.Description

Length of time (in hours, minutes, and seconds) that
must elapse before the system allows a fault to change
its state.

Flapping occurs when a fault is raised and cleared
several times in rapid succession. To prevent this, the
system does not allow a fault to change its state until
this amount of time has elapsed since the last state
change.

If the condition reoccurs during the flapping interval,
the fault returns to the active state. If the condition
does not reoccur during the flapping interval, the fault
is cleared. What happens at that point depends on the
setting in the Clear Faults Retention Action field.

The default flapping interval is ten seconds.

Flapping Interval

Action to be taken when faults are cleared:

• retain—Retain the cleared faults.

• delete—Delete fault messages as soon as they
are marked as cleared.

Clear Faults Retention Action

   Cisco Prime Network Services Controller 3.2 User Guide
146

Configuring Device Policies and Profiles
Configuring Fault Policies



DescriptionField

How long the system is to retain cleared fault
messages:

• Forever—The system retains all cleared fault
messages regardless of their age.

• Other—The system retains cleared fault
message for a specified the length of time.
In the spinbox that is displayed when you select
this option, enter the length of time (in days,
hours, minutes, and seconds) that the system is
to retain cleared fault messages.

Clear Faults Retention Interval

Editing a Fault Policy for a Device Profile

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Fault.
Step 2 In the General tab, select the fault policy you want to edit, then click Edit.
Step 3 In the Edit Fault Policy dialog box, modify the following fields as required, then click OK.

DescriptionField

Policy name (read-only).Name

Brief policy description.Description
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DescriptionField

Length of time (in hours, minutes, and seconds) that
must elapse before the system allows a fault to change
its state.

Flapping occurs when a fault is raised and cleared
several times in rapid succession. To prevent this, the
system does not allow a fault to change its state until
this amount of time has elapsed since the last state
change.

If the condition recurs during the flapping interval,
the fault returns to the active state. If the condition
does not recur during the flapping interval, the fault
is cleared. The next action depends on the setting in
the Clear Faults Retention Action field.

The default flapping interval is ten seconds.

Flapping Interval

Available fault retention actions:

• retain—The system retains fault messages.

• delete—The system deletes fault messageswhen
they are marked as cleared.

Clear Faults Retention Action

How long the system is to retain cleared fault
messages:

• Forever—The system retains all cleared fault
messages regardless of their age.

• Other—The system retains cleared fault
message for a specified the length of time.
In the spinbox that is displayed when you select
this option, enter the length of time (in days,
hours, minutes, and seconds) that the system is
to retain cleared fault messages.

Clear Faults Retention Interval

Deleting a Fault Policy for a Device Profile

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note
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Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Fault.
Step 2 In the General tab, select the fault policy that you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Configuring Log File Policies

Adding a Logging Policy for a Device Profile
You can add a logging policy for a device at any organizational level.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Log File.
Step 2 In the General tab, click Add Logging Policy.
Step 3 In the Add Logging Policy dialog box, complete the following fields, then click OK.

DescriptionField

Logging policy name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name

Brief policy description.Description
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DescriptionField

One of the following logging severity levels:

• debug0

• debug1

• debug2

• debug3

• debug4

• info

• warning

• minor

• major

• critical

The default log level is info.

Log Level

Number of backup files that are filled before they are
overwritten.

The range is 1 to 9 files, with a default of 2 files.

Backup Files Count

Backup file size.

The range is 1MB to 100MBwith a default of 5MB.

File Size (bytes)

Editing a Logging Policy for a Device Profile

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Log File.
Step 2 In the General tab, select the log file policy that you want to edit, then click Edit.
Step 3 In the Edit Log File Policy dialog box, edit the fields as required by using the information in the following

table, then click OK.
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DescriptionField

Logging policy name (read-only).Name

Brief policy description.Description

One of the following logging levels:

• debug0

• debug1

• debug2

• debug3

• debug4

• info

• warning

• minor

• major

• critical

The default log level is info.

Log Level

Number of backup files that are filled before they are
overwritten.

The range is 1 to 9 files, with a default of 2 files.

Backup Files Count

Backup file size.

The range is 1MB to 100MBwith a default of 5MB.

File Size (bytes)

Deleting a Logging Policy for a Device Profile

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note
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Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Log File.
Step 2 In the General tab, select the logging policy you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Configuring SNMP Policies

Adding an SNMP Policy
You can add an SNMP policy at any organizational level.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > SNMP.
Step 2 In the General tab, click Add SNMP Policy.
Step 3 In the Add SNMP dialog box, complete the following fields as appropriate:

Table 8: General Tab

DescriptionField

SNMP policy name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name

SNMP policy description.

This description can be between 1 and 256 identifier
characters. You can use alphanumeric characters
including hyphens, underscore, dot, and colon.

Description

Indicate whether the administrative status of the
policy is enabled or disabled.

Admin State

Physical location of the device.Location

Contact person for the device.Contact

Port that the SNMP agent listens to for requests.

You cannot edit this field.

SNMP Port
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Step 4 Click the Communities tab, then complete the following steps:
a) Click Add SNMP Community.
b) In the Add SNMP Community dialog box, complete the following fields as appropriate, then click OK:

DescriptionName

SNMP community name.Community

Role associated with the community string.

You cannot edit this field.

Role

Step 5 In the Add SNMP dialog box, click OK.

Editing an SNMP Policy

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > SNMP.
Step 2 In the General tab, select the SNMP policy that you want to edit, then click Edit.
Step 3 In the Edit SNMP Policy dialog box, edit the information in the General tab as required, using the information

in the following table:
DescriptionField

SNMP policy name (read-only).Name

Brief policy description.Description

Administrative state of the policy: enabled (default)
or disabled.

Admin State

Physical location of the device.Location

Contact person for the device.Contact

Port that the SNMP agent listens to for requests
(read-only).

SNMP Port
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Step 4 In the Communities tab, edit the information as required:
DescriptionField

Adds an SNMP community.Add SNMP Community

Deletes the selected SNMP community.Delete

Enter the string or value that you want to filter the
table contents by.

Filter

SNMP community name.Community

Role associated with the SNMP community.Role

Step 5 In the Traps tab, edit the information as required:
DescriptionField

Adds an SNMP trap.Add SNMP Trap

Enables you to edit the selected SNMP trap.Edit

Deletes the selected SNMP trap.Delete

Enter the string or value that you want to filter the
table contents by.

Filter

IP address of the SNMP host.Hostname/IP Address

Port where the SNMP agents listens for requests.Port

SNMP community name.Community

Step 6 Click OK.

Deleting an SNMP Policy

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note
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Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > SNMP.
Step 2 In the General tab, select the SNMP policy that you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Adding an SNMP Trap Receiver

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > SNMP.
Step 2 In the General tab, click Add SNMP Policy > Traps > Add SNMP Trap..
Step 3 In the Add SNMP Trap dialog box, enter the following information, then click OK:

DescriptionField

Hostname or IP address of the SNMP host.Hostname/ IP Address

Port that the SNMP agent listens to for requests.

The default port is 162.

Port

SNMP community name.Community

Editing an SNMP Trap Receiver

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > SNMP.
Step 2 In the General tab, select the SNMP policy with the SNMP trap that you want to edit, then click Edit.
Step 3 In the Edit SNMP Policy dialog box, click the Traps tab.
Step 4 In the Traps tab, select the entry that you want to edit, then click Edit.
Step 5 In the Edit SNMP Trap dialog box, edit the information in the General tab as required, using the following

information:
DescriptionField

Hostname or IP address of the SNMP host
(read-only).

Hostname/IP Address
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DescriptionField

Port that the SNMP agent listens to for requests.Port

SNMP community name.Community

Step 6 Click OK in the open dialog boxes.

Deleting an SNMP Trap Receiver

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > SNMP.
Step 2 In the General tab, select the SNMP policy with the SNMP trap that you want to delete, then click Edit.
Step 3 In the Edit SNMP Policy dialog box, click the Traps tab.
Step 4 In the Traps tab, select the entry that you want to delete, then click Delete.
Step 5 When prompted, confirm the deletion.

Configuring Syslog Policies

Adding a Syslog Policy for a Device
Prime Network Services Controller enables you to configure syslog policies for syslog messages and then
attach a created syslog policy to a device profile for implementation on all devices using that profile.

You can create syslog policies for logging syslog messages to a remote syslog server or to a local buffer for
later review.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Syslog.
Step 2 In the General tab, click Add Syslog Policy.
Step 3 In the Add Syslog dialog box, provide the information as described in Add Syslog Policy Dialog Box, on

page 157, then click OK.
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Field Descriptions

Add Syslog Policy Dialog Box

DescriptionField

General Tab

Policy name.Name

Brief policy description.Description

Check the check box to use the EMBLEM format for
syslog messages.

This option appears only on supported devices.

Use Emblem Format

Check the check box to continue logging if the syslog
server is down.

This option only appears on supported devices.

Continue if Host is Down

Servers Tab

Click to add a new syslog server.Add Syslog Server

List of configured syslog servers.Syslog Servers table

Local Destinations Tab

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: alert, critical, or
emergency.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

Console
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DescriptionField

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: emergency, alert,
critical, error, warning, notification, information,
or debugging.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

Monitor

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: emergency, alert,
critical, error, warning, notification, information,
or debugging.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

• File Name—Name of the file to whichmessages
are logged.

• Size (bytes)—Maximum size, in bytes, that the
file can reach before the system begins to
overwrite the messages.

File
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DescriptionField

Buffer options are not available for InterCloud
policies.

• Admin State—Administrative state of the
policy: disabled or enabled.

• Level—Message level: emergency, alert,
critical, error, warning, notification, information,
or debugging.

If the Admin State is enabled, select themessage
level that you want displayed. The system
displays that level and above on the console.
For example, if you choose critical, the system
also displays messages with the severities alert
and emergency.

• Buffer Size (Bytes)—In bytes, the size of the
buffer for syslog messages.

•Wrap to Flash—Indicates whether or not the
buffer contents are saved to flash memory when
the buffer wraps (becomes full). Check the
check box to save the contents to flash memory
if the buffer wraps.

• Max File Size in Flash (KB)—Maximum size,
in kilobytes, that can be used by the syslog
buffer. This option is enabled if the Wrap to
Flash option is enabled.

• Min Free Flash Size (KB)—Minimum size, in
kilobytes, that is allocated for the syslog buffer.
This option is enabled if the Wrap to Flash
option is enabled.

Buffer

Check the check box for each of the following options
that you want to enable for timestamp display:

• Enable Timestamp

• Include Year

• Include Milliseconds

• Show Time Zone

• Use Local Time Zone

Time Stamp
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Editing a Syslog Policy for a Device Profile
Prime Network Services Controller enables you to edit existing syslog policies as described in this procedure.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Syslog.
Step 2 In the General tab, select the policy you want to edit, then click Edit.
Step 3 In the Edit Syslog Policy dialog box, in the General tab, edit the information as required, using the following

information:
DescriptionField

Policy name (read-only).Name

Brief policy description.Description

Check the check box to use the EMBLEM format for
syslog messages.

This option is supported for ASA 1000Vs. It is not
supported for VSGs.

Use Emblem Format

Check the check box to continue logging if the syslog
server is down.

This option is supported for ASA 1000Vs. It is not
supported for VSGs.

Continue if Host is Down

Step 4 In the Servers tab, click Add Syslog Server to add a new syslog server, or select an existing server and click
Edit to edit it.

Step 5 In the Local Destinations tab, edit the information as required, using the following information:
DescriptionField

• Admin State—Administrative state of the
policy: enabled or disabled.

• Level—Message level: alerts, critical, or
emergencies.

If the Admin State is enabled, select the lowest
message level that you want displayed. The
system displays that level and above on the
console.

Console
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DescriptionField

• Admin State—Administrative state of the
policy: enabled or disabled.

• Level—Message level: alert, critical,
emergency, error, warning, notification,
information, or debugging.

If the Admin State is enabled, select the lowest
message level that you want displayed. The
system displays that level and above on the
console.

Monitor

• Admin State—Administrative state of the
policy: enabled or disabled.

• Level—Message level: alert, critical,
emergency, error, warning, notification,
information, or debugging.

If the Admin State is enabled, select the lowest
message level that you want displayed. The
system displays that level and above on the
console.

• File Name—Name of the file to whichmessages
are logged.

• Size (bytes)—Maximum size, in bytes, that the
file can reach before the system begins to
overwrite the messages.

File
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DescriptionField

• Admin State—Administrative state of the
policy: enabled or disabled.

• Level—Message level: alert, critical,
emergency, error, warning, notification,
information, or debugging.

If the Admin State is enabled, select the lowest
message level that you want displayed. The
system displays that level and above on the
console.

• Buffer Size (Bytes)—In bytes, the size of the
buffer for syslog messages.

•Wrap to Flash—Indicates whether or not the
buffer contents are saved to flash memory with
the buffer wraps (becomes full). Check the
check box to save the contents to flash memory
if the buffer wraps.

• Max File Size in Flash (KB)—Maximum size,
in kilobytes, that can be used by the syslog
buffer. This option is enabled if the Wrap to
Flash option is enabled.

• Min Free Flash Size (KB)—Minimum size, in
kilobytes, that is allocated for the syslog buffer.
This option is enabled if the Wrap to Flash
option is enabled.

Buffer

Check the check box for each of the following options
that you want to enable for displaying timestamps:

• Enable Timestamp

• Include Year

• Include Milliseconds

• Show Time Zone

• Use Local Time Zone

Time Stamp

Step 6 Click OK.
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Deleting a Syslog Policy for a Device Profile

When the system boots up, a default policy already exists. You can modify the default policy, but you
cannot delete it.

Note

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Syslog.
Step 2 In the General tab, select the syslog policy that you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Adding a Syslog Server for a Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Syslog.
Step 2 In the General tab, click Add Syslog Policy.
Step 3 In the Add Syslog Policy dialog box, click the Servers tab, then click Add Syslog Server.
Step 4 In the Add Syslog Server dialog box, provide the information as described in Add Syslog Server Dialog Box,

on page 163, then click OK in the open dialog boxes.

Field Descriptions

Add Syslog Server Dialog Box

DescriptionField

One of the following server types:

• primary

• secondary

• tertiary

Server Type

Hostname or IP address where the syslog file
resides.

If you use a hostname, you must
configure a DNS server.

Note

Hostname/IP Address
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DescriptionField

One of the following severity levels:

• emergencies (0)

• alerts (1)

• critical (2)

• errors (3)

• warnings (4)

• notifications (5)

• information (6)

• debugging (7)

Severity

One of the following forwarding facilities:

• auth

• authpriv

• cron

• daemon

• ftp

• kernel

• local0

• local1

• local2

• local3

• local4

• local5

• local6

• local7

• lpr

• mail

• news

• syslog

• user

• uucp

Forwarding Facility
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DescriptionField

Administrative state of the server: disabled or
enabled.

Admin State

Port to use to send data to the syslog server.

The default port selection is 514 for UDP.

This option is not available for InterCloud
policies.

Port

Protocol to use: TCP or UDP (default).

This option is not available for InterCloud
policies.

Protocol

Check the check box to use Transport Layer
Security.

This option is available only for TCP.

This option is not available for InterCloud
policies.

Use Transport Layer Security

Interface to use to access the syslog server.Server Interface

Editing a Syslog Server for a Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Syslog.
Step 2 In the General tab, select the required syslog policy, then choose Edit.
Step 3 In the Edit Syslog Policy dialog box, from the Servers tab, select the syslog server you want to edit, then

click Edit
Step 4 In the Edit Syslog Server dialog box, edit the fields as required, using the information in the following table.

DescriptionField

One of the following server types: primary,
secondary, or tertiary (read-only).

Server Type

Hostname or IP address where the syslog file
resides.

Hostname/IP Address
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DescriptionField

One of the following severity levels:

• emergencies (0)

• alerts (1)

• critical (2)

• errors (3)

• warnings (4)

• notifications (5)

• information (6)

• debugging (7)

Severity

One of the following forwarding facilities:

• auth

• authpriv

• cron

• daemon

• ftp

• kernel

• local0

• local1

• local2

• local3

• local4

• local5

• local6

• local7

• lpr

• mail

• news

• syslog

• user

• uucp

Forwarding Facility

   Cisco Prime Network Services Controller 3.2 User Guide
166

Configuring Device Policies and Profiles
Configuring Syslog Policies



DescriptionField

Administrative state of the policy: enabled or
disabled.

Admin State

Port to use to send data to the syslog server.

Valid port values are 1025 through 65535 for
both TCP and UDP. The default TCP port is
1470. The default UDP port is 514.

Port

Protocol to use: TCP or UDP.Protocol

Check the check box to use Transport Layer
Security.

This option is available only for TCP.

Use Transport Layer Security

Interface to use to access the syslog server.

This option applies to ASA 1000V only. Enter
the data interface name specify in the edge
firewall.

Use the device CLI to configure a route through
the management interface.

Server Interface

Step 5 Click OK in the open dialog boxes to save your changes.

Deleting a Syslog Server for a Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Policies > Syslog.
Step 2 In the General tab, select the syslog policy with the server you want to delete, then click Edit.
Step 3 In the Edit Syslog Policy dialog box, click the Servers tab.
Step 4 In the Servers tab, select the syslog server that you want to delete, then click Delete.
Step 5 When prompted, confirm the deletion.
Step 6 Click OK to save the policy.
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Configuring Device Profiles

Adding a Firewall Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Device Profiles.
Step 2 In the General tab, click Add Device Profile.
Step 3 In the New Device Profile dialog box, enter the required information in the General and Policies tabs, then

click OK:
DescriptionField

You can:

• Add a new server.

• Select an existing server and edit or delete it.

• Use the arrows to change priority.

DNS Servers

You can:

• Add a new domain.

• Select an existing domain and edit or delete it.

DNS Domains

You can:

• Add a new server.

• Select an existing server and edit or delete it.

• Use the arrows to change priority.

NTP Servers

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

This option is not available for InterCloud
Management device profiles.

SNMP
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DescriptionField

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

Syslog

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

This option is not available for InterCloud
Management device profiles.

Fault

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

Core File

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

Policy Agent Log File

Select the appropriate radio button to enable or disable
logging.

This option is not available for InterCloud
Management device profiles.

Policy Engine Logging
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DescriptionField

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

This option is not available for InterCloud
Management device profiles.

Auth Policy

Editing a Firewall Device Profile
After you create a firewall device profile, you can edit it as needed.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Device Profiles.
Step 2 In the Device Profiles pane, select the profile you want to edit, then click Edit.
Step 3 In the Edit Firewall Device Policy dialog box, update the information in the General tab as described in the

following table:
DescriptionField

Profile name.

This name can be between 1 and 32 identifier
characters. You can use alphanumeric characters
including hyphen, underscore, dot, and colon. You
cannot change this name after it is saved.

Name

Brief profile description.

The description can be between 1 and 256 identifier
characters. You can use alphanumeric characters
including hyphen, underscore, dot, and colon.

Description

Select the required time zone from the drop-down
list.

Time Zone

Step 4 In the Policies tab, update the information as described in the following table, then click OK:
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DescriptionField

DNS Servers

Adds a DNS server.Add DNS Server

Enables you to edit the selected DNS server.Edit

Deletes the selected DNS server.Delete

Change the priority of the selected DNS server.

Prime Network Services Controller uses the DNS
servers in the order in which they appear in the table.

Up and down arrows

DNS Servers Table

IP addresses for the DNS servers configured in the
system.

IP Address

Interface to use to access the DNS server.Server Interface

NTP Servers

Click to add an NTP server.Add NTP Server

Enables you to edit the selected NTP server.Edit

Deletes the selected NTP server.Delete

Change the priority of the selected NTP Server
hostname.

Prime Network Services Controller uses the NTP
servers in the order in which they appear in the table.

Up and down arrows

NTP Servers Table

Hostnames or IP addresses for NTP servers
configured in the system.

Hostname / IP Address

Interface to use to access the NTP server.Interface Name

DNS Domains

Click to add a DNS domain name.Add

Click to edit the DNS domain name selected in the
DNS Domains table.

The default DNS name cannot be edited.

Edit
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DescriptionField

Click to delete the DNS domain name selected in the
DNS Domains table.

Delete

Default DNS domain name and domain in the system.DNS Domains table

Other Options

Select, add, or edit SNMP policies as needed.SNMP

Select, add, or edit syslog policies as needed.Syslog

Select, add, or edit fault policies as needed.Fault

Select, add, or edit core file policies as needed.Core File

Select, add, or edit the policy agent log file policies
as needed.

Policy Agent Log File

Select the appropriate radio button to enable or disable
logging.

Policy Engine Logging

Select an available authentication policy, or clickAdd
Auth Policy to add a new authentication policy.

Auth Policy

Deleting a Firewall Device Profile

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Device Profiles.
Step 2 In theWork pane, click the device profile you want to delete.
Step 3 Click Delete.
Step 4 In the Confirm dialog box, click OK.
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Configuring NTP
Network Time Protocol (NTP) is a networking protocol used to synchronize the time on a network of machines.
An NTP network usually gets its time from an authoritative time source, such as a radio clock or an atomic
clock attached to a time server.

Prime Network Services Controller enables you to configure NTP for compute firewalls, edge firewalls, and
Prime Network Services Controller itself.

Configuring NTP for a compute or edge firewall requires the following steps:

1 Configuring a device profile with NTP.

2 Applying the device profile to a compute or edge firewall

The following topics describe how to perform these steps.

For information on configuring NTP on Prime Network Services Controller, see Adding an NTP Server, on
page 65.

Creating a Device Profile with NTP
This procedure describes how to create a device profile with NTP that you can apply to an edge or compute
firewall.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Device Profiles.
Step 2 In the General tab, click Add Device Profile.
Step 3 In the New Device Profile dialog box, provide the following information:

• Name—Profile name.

• Description—Brief profile description.

• Time Zone—From the drop-down list, choose the time zone.

Step 4 Click the Policies tab.
Step 5 In the NTP servers area, click Add NTP Server.
Step 6 In the Add NTP Server dialog box, enter the information as described in Add NTP Server Dialog Box, on

page 174, then click OK.
Step 7 Click OK.

What to Do Next

After you have configured the device profile, you can apply it to a firewall as described in the following topics:

• Applying Device Profiles to Edge Firewalls, on page 174

• Applying Device Profiles to Compute Firewalls, on page 174
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Field Descriptions

Add NTP Server Dialog Box

Add NTP Server Dialog Box

DescriptionField

NTP server name or IP address.

For Prime Network Services Controller andVSGs, you can enter either a hostname or
IP address. For ASA 1000Vs, you must enter an IP address.

Hostname/IP
Address

(Policy Management Device Profiles only) Device interface to reach the NTP server.
Only ASA 1000Vs support interface names.

• If you specify an interface, use the interface name specified by the edge firewall.

• To use the management interface, you must configure the route by using the CLI.

Interface Name

(Policy Management Device Profiles only) Authentication key to access the NTP
server. Only ASA 1000Vs support authentication keys.

AuthenticationKey

Applying Device Profiles to Compute Firewalls
After you have created a device profile, you can apply the profile to a compute firewall.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant > Compute Firewalls >
compute-firewall.

Step 2 In the General tab, click Select in the Device Profile field.
Step 3 In the Select Device Profile dialog box, select the desired profile, then click OK.
Step 4 Click Save.

Applying Device Profiles to Edge Firewalls
After you have created a device profile, you can apply the profile to an edge firewall.
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Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant > Edge Firewalls > edge-firewall.
Step 2 In the General tab, click Select in the Device Profile field.
Step 3 In the Select Device Profile dialog box, select the desired profile, then click OK.
Step 4 Click Save.

Associating Device Policies with Profiles
After you create a device policy, you can associate it with a device profile. By doing so, you can ensure that
all devices associated with the device profile use the same policy.

Procedure

Step 1 Choose Policy Management > Device Configurations > root > Device Profiles > profile where profile is
the device profile that you want to add the device policy to.

Step 2 Click the Policies tab.
Step 3 In the Policies tab, locate the drop-down list for the type of policy you want to associate, such as Syslog or

Auth Policy.
Step 4 From the drop-down list, choose the policy to add to the profile, then click Save.

The policy is automatically applied to all devices using the selected profile.

Cisco Prime Network Services Controller 3.2 User Guide    
175

Configuring Device Policies and Profiles
Associating Device Policies with Profiles



   Cisco Prime Network Services Controller 3.2 User Guide
176

Configuring Device Policies and Profiles
Associating Device Policies with Profiles



C H A P T E R  11
Configuring Managed Resources

This section contains the following topics:

• Resource Management, page 177

• Registering Third-Party VMs, page 178

• Verifying VM Registration, page 182

• Importing Service Images, page 182

• Compute Firewalls, page 183

• Edge Firewalls, page 189

• Edge Routers, page 191

• Load Balancers, page 196

• Adding a Port Profile to a VSM, page 203

• Updating Discovered VSM Port Profiles, page 204

• Troubleshooting Devices and Services, page 204

• Launching ASDM, page 205

• Managing VSG Pools, page 206

Resource Management
Prime Network Services Controller enables you to manage the following resources:

• Compute firewalls—A virtual firewall that delivers security and compliance for a virtual computing
environment at the VM level. Context-based and VLAN-independent policies can be applied to VM
zones, thereby providing topology-invariant, policy-based security controls. In addition, traffic from
external sources to VMs, and from VM to VM can be protected.

• Edge firewalls—A virtual appliance that secures the tenant edge in a multitenant environment. An
example of an edge firewall is a Cisco Adaptive Security Appliance 1000V (ASA 1000V). An edge
firewall:
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Supports site-to-site VPN, NAT, and DHCP.•

• Acts as a default gateway.

• Secures the VMs within a tenant against network-based attacks.

• Edge routers—A virtual edge router that serves as a single-tenant WAN gateway in a multitenant cloud.
It allows enterprises to extend their WANs into external provider-hosted clouds.

• Load balancers—A virtual appliance that distributes network and application traffic across multiple
servers. It improves application performance and prevents server failures by alleviating loads on servers.

• Virtual Security Gateways (VSGs)—VSGs evaluate policies based on network traffic. Themain functions
of a VSG are as follows:

◦Receive traffic from Virtual Network Service Data Path (vPath).
For every new flow, the vPath component encapsulates the first packet and sends it to a VSG as
specified in the Nexus 1000V port profiles. It assumes that the VSG is Layer 2 adjacent to vPath.
Themechanism used for communication between vPath and the VSG is similar to VEM andNexus
1000V communication on a packet VLAN.

◦Perform application fix-up processing such as FTP, TFTP, and RSH.

◦Evaluate policies by inspecting the packets sent by vPath using network, VM, and custom attributes.

◦Transmit the policy evaluation results to vPath.

Each vPath component maintains a flow table for caching VSG policy evaluation results.Note

• Virtual Supervisor Modules (VSMs)—A virtual appliance that runs on a Nexus 1000V switch and that
manages, monitors, and configures multiple Virtual Ethernet Modules (VEMs). VEMs run as part of a
hypervisor where they act as virtual switches. VSMs are tightly integrated with hypervisors, so that
configurations made on a VSM are automatically propagated to the VEMs. As a result, instead of
configuring soft switches inside the hypervisor on a host-by-host basis, you can define configurations
for immediate use on all VEMs that are managed by the VSM from a single interface.

You manage resources by placing them in service. The general workflow for placing devices in service is as
follows:

1 Create tenants and subordinate organizations.
2 Configure device policies.
3 Register or instantiate service devices from service images.

Registering Third-Party VMs
Registering third-party VMs in Prime Network Services Controller is a two-step process, as described in the
following topics:

1 Installing the Prime Network Services Controller Device Adapter, on page 180
2 Deploying and Registering Third-Party VMs, on page 179
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Deploying and Registering Third-Party VMs
This procedure describes how to deploy third-party VMs (such as Citrix NetScaler 1000V and Citrix NetScaler
VPX) and register them with Prime Network Services Controller.

Before You Begin

Confirm the following:

• Prime Network Services Controller Device Adapter is successfully registered with Prime Network
Services Controller by choosing Administration > Service Registry > Providers. The Providers table
should includemanaged-endpoint andmgmt-controller entries for the PrimeNetwork Services Controller
Device Adapter VM.

• The third-party OVA is available from the VMware vSphere Client.

If you are prompted with a third-party login screen requesting information (for example, management IP
information or upload feature licenses), you can do either of the following:

Note

• Use the existing configuration and ignore this screen.

• Refer to the followingURL for additional Citrix licensing features: http://support.citrix.com/proddocs/
topic/netscaler-getting-started-map-10-1/ns-initial-config-using-ftu-wizard-tsk.html

Procedure

Step 1 In VMware, choose the host on which to deploy the third-party VM.
Step 2 Choose File > Deploy OVF Template.
Step 3 In the wizard, provide the information as described in the following table.

The same information is required for both Citrix NetScaler 1000V and Citrix NetScaler VPX
VMs.

Note

ActionScreen

Choose the OVA that you want to deploy.Source

Review the details.OVF Template Details

Enter a name and choose a location for the VM.Name and Location

Choose the location for the VM files.Storage

Choose the format in which to store the virtual disks.Disk Format

Choose the destination networks for the VM.Network Mapping
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Step 4 In the Ready to Complete screen, review the deployment settings for accuracy, and then click Finish.
Step 5 Open the VM console so that you can monitor the deployment status.
Step 6 When prompted in the console, enter the following information for the VM:

• IP address

• Subnet mask

• Gateway IP address

Step 7 When the information is correct, enter 4 and press Return.
You can continue to monitor the progress in the console.

Step 8 Confirm that the VM is registered in PrimeNetwork Services Controller by choosingResourceManagement
> Resources > resource. For example, for Citrix NetScaler load balancer VMs, you would choose Resource
Management > Resources > VPX.

Installing the Prime Network Services Controller Device Adapter
The Prime Network Services Controller Device Adapter enables third-party VMs (such as Citrix NetScaler
load balancers) to register with Prime Network Services Controller.

Note • Prime Network Services Controller Device Adapter is required and must be installed before you
deploy and register third-party service nodes, such as Citrix NetScaler 1000V and Citrix NetScaler
VPX service nodes.

• Adding or editing policies from the Prime Network Services Controller Device Adapter is not
supported. All configuration must be performed using the Prime Network Services Controller GUI.

• You need to install the Prime Network Services Controller Device Adapter only once for each Prime
Network Services Controller instance.

Before You Begin

Make sure that a network path exists between the Prime Network Services Controller Device Adapter IP
address and the Prime Network Services Controller management IP address.

Procedure

Step 1 Use the VMware vSphere Client to log in to the vCenter server.
Step 2 Choose the host on which to deploy the Prime Network Services Controller Device Adapter.
Step 3 Choose File > Deploy OVF Template.
Step 4 In the wizard, provide the required information as described in the following table:
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ActionScreen

Navigate to and choose the
nsc-device-adapter.3.2.nx.ova file.

Source

Review the details of the Prime Network Services
Controller Device Adapter template.

OVF Template Details

Review the agreement and click Accept.End User License Agreement

Specify a name and location for the VM. The name
must begin with a letter.

Name and Location

Choose Installer.Deployment Configuration

Choose the data store for the VM.Storage

Choose the required format.Disk Format

Choose the management network port group for the
VM.

Network Mapping

Provide the required information with particular
attention to the following fields:

• NTP—Enter the IP address for an NTP server.

• Prime Network Services Controller Device
Adapter IP Address RegIP—Enter the IP
address for the Prime Network Services
Controller server.

Properties

Review the deployment settings for accuracy.Ready to Complete

Step 5 Click Finish.
Step 6 After the deployment is complete, power up the VM.

You can monitor the progress of the deployment by opening the VM console.
Step 7 Confirm that the Prime Network Services Controller Device Adapter VM is successfully registered with Prime

Network Services Controller by logging in to the Prime Network Services Controller server and choosing
Administration > Service Registry > Providers.
The Providers table should include managed-endpoint and mgmt-controller entries for the Prime Network
Services Controller Device Adapter VM that you deployed.
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Verifying VM Registration
Use this procedure to verify that the following VMs are successfully registered in Prime Network Services
Controller:

• ASA 1000V

• CSR 1000V

• InterCloud

• Citrix NetScaler load balancer

• VSG

• VSM

To confirm registration with Prime Network Services Controller, chooseResourceManagement > Resources
> resource. In the content pane, the consolidated status for each resource is displayed in the Status column.
This consolidated status is determined by assessing the following attributes in sequence:

1 Reachability
2 Association
3 Config State
4 Running

If any of these attributes fail, the failure of that attribute is displayed. For example, if the device cannot be
reached, the status unreachable is displayed. Similarly, if the device is reachable and associated, but the
configuration fails, the status config failed is displayed.

Importing Service Images
Prime Network Services Controller enables you to import service images that you can then use to instantiate
a service device.

After you import an image, Prime Network Services Controller automatically places the file in the correct
location and populates the Images table.

For information on instantiating a service VM from a service image, see the following topics:

• Adding a Compute Firewall, on page 183

• Adding an Edge Firewall, on page 189

• Adding Edge Routers, on page 195

• Adding Load Balancers, on page 199

Before You Begin

Confirm that the service images are available for importing into Prime Network Services Controller.
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Procedure

Step 1 Choose Resource Management > Resources > Images.
Step 2 Click Import Service Image.
Step 3 In the Importing Service Image Dialog box:

a) Enter a name and description for the image you are importing.
b) In the Type field, choose the type of image to import.
c) In the Version field, enter a version number that you want to assign to the image.
d) In the Import area, provide the following information, and then click OK:

• Protocol to use for the import operations: FTP, SCP, or SFTP.

• Hostname or IP address of the remote host with the images.

• Account username and password for the remote host.

• Absolute image path and filename, starting with a slash (/).

Compute Firewalls

Adding a Compute Firewall
You can add a compute firewall and assign it to a VSG, thereby placing the VSG in service. A wizard walks
you through the configuration process, which includes assigning profiles, assigning a VSG or instantiating a
VSG service image, and configuring interfaces.

When you add a new compute firewall, the firewall data IP address can be the same as the data IP address of
an existing compute firewall in Prime Network Services Controller as long as the firewalls have different
organizational paths. That is, as long as the firewalls do not reside in the same organization, including parent
and child organizations.

We recommend that you add the compute firewall at the tenant level or below, and not at the root level.Note

Before You Begin

• You must have at least one of the following:

◦An available VSG that is registered in Prime Network Services Controller. For more information,
see Verifying VM Registration, on page 182.

◦A VSG pool with at least one available VSG.

◦An imported VSG service image.

• A VMManager must be configured in Prime Network Services Controller.
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For HA-specific configurations, refer to the appropriate Cisco Adaptive Security Appliance 1000V (ASA
1000V) configuration guide for additional information.

Note

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose Add Compute Firewall.
Step 3 In the Properties screen, provide the information as described in Properties Screen, on page 185, and then

click Next.
Step 4 In the Service Device screen, select the required VSG service device, provide any required information as

described in Service Device Screen, on page 185, and then click Next.
Step 5 (Instantiate option only) If you instantiate a VSG service device from an image, do one or both of the following

in the Placement screen, and then click Next:

• Navigate to and choose the host or resource pool to use for the VSG instance.

• If you enabled high availability, either check the Same as Primary check box, or navigate to and choose
the host or resource pool to use for the secondary VSG instance.

Step 6 In the Interfaces screen, configure interfaces as follows, and then click Next:

• If you assigned a VSG, enter the data IP address and subnet mask.

• If you assigned a VSG pool, enter the data IP address and subnet mask.

• If you instantiated a VSG service device without high availability, add management and data interfaces.

• If you instantiated a VSG service device with high availability, add management, data, and HA interfaces.

For field-level help when configuring the interfaces, see the online help.

Step 7 In the Summary screen, confirm that the information is correct, and then click Finish.

Compute Firewall Deployment Options
VSG compute firewalls are available in the following deployment models based on the memory, CPU speed,
and number of virtual CPUs. Choose the deployment size that is appropriate for your environment.

Number of Virtual
CPUs

CPU SpeedMemoryDeployment Size

11.0 GHz2 GBSmall

11.5 GHz2 GBMedium

21.5 GHz2 GBLarge
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Field Descriptions

Properties Screen

DescriptionField

Compute firewall name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name

Compute firewall description.Description

Management hostname of the firewall.Host Name

Do either of the following:

• Click the profile name to view or optionally
modify the currently assigned device
configuration profile.

• Click Select to choose a different device
configuration profile.

Device Profile

Service Device Screen

DescriptionField

Assign a VSG to the compute firewall.

From the VSG Device drop-down list, choose the
required service device.

Assign VSG

Assign a VSG pool to the compute firewall.

In theVSGPool field, either choose the required pool
from the drop-down list or click Add Pool to add a
new pool.

Assign VSG Pool
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DescriptionField

Instantiate a VSG service device from an available
image.

1 In the list of available images, select the image to
use to instantiate a new VSG service device.

2 In the High Availability field, check the Enable
HA check box to enable high availability.

3 From the Deployment Size drop-down list, choose
the size of the deployment. For more information,
see Compute Firewall Deployment Options, on
page 184.

4 In the VM Access password fields, enter the
password for the admin user account.

Instantiate

Managing Compute Firewalls
You can edit and view fault information on existing compute firewalls as needed.

Procedure

Step 1 In the Resource Management tab, chooseManaged Resources > root > tenant.
Step 2 In the Network Services tab, select the required compute firewall, and then click Edit or Delete.
Step 3 If you chose Edit, modify the fields as appropriate, using the information in the following tables, and then

click OK.
To view additional information about an entry in the Faults tab, double-click the entry, or select the
entry and then click Properties.

Note

General Tab

DescriptionField

Compute firewall name.Name

Compute firewall description.Description

Management IP address for the compute firewall.Management IP Address

High availability role of the compute firewall:
standalone or active standby.

HA Role

Size of the deployment: Small, Medium, or Large.Deployment Size

Device profile associated with the compute firewall.Device Profile

Status
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DescriptionField

Deployment state of the firewall.Deploy State

Whether the firewall is powered off or on.Power State

Configuration status of the compute firewall: applied,
applying, failed-to-apply, or not-applied.

Config Status

Association state of the firewall: associated,
associating, disassociating, failed, or unassociated.

Association Status

Whether or not the compute firewall is reachable.Reachable

Placement Tab

This tab is displayed only if the compute firewall is instantiated from a service image.

DescriptionField

Image Table (read-only)

Radio-button indicating image selection.Select

Service image name.Name

Service image version.Version

VMManager Details

If high availability is enabled, the following fields are displayed for both the primary and secondary service
devices.

VM Manager for the service device.VM Manager

IP address of the VM host.Host

VM instance name.Instance Name

Network Interfaces Tab—VSG Assigned

This tab is displayed only if a VSG was assigned to the compute firewall.

DescriptionField

Management hostname for the compute firewall.Management Hostname

Compute firewall data IP address.Data IP Address

Netmask for the data IP address.Data IP Subnet
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DescriptionField

VLAN to use for service path configuration if the
device is running in Layer 2 mode.

VLAN

Network Interfaces Tab—VSG Instantiated

This tab is displayed only if the compute firewall was instantiated from a service image.

DescriptionField

Toolbar

Adds an interface.Add Interface

Enables you to edit the selected interface.Edit

Deletes the selected interface.Delete

Filters the table contents by the string or value that
you enter.

Filter

Table

Interface type: Data, HA, or Management.Type

Interface IP address.IP Address

Port group or subnetwork associated with the
interface.

Port Group / Sub Network

Unassigning a VSG
Use this procedure to remove a VSG from a compute firewall.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose the compute firewall with the VSG that you want to unassign.
Step 3 In the toolbar, choose Actions > Unassign VSG.
Step 4 When prompted, confirm the action.
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Edge Firewalls

Adding an Edge Firewall
You can add an edge firewall and assign it to an ASA 1000V, thereby placing the ASA 1000V in service. A
wizard walks you through the configuration process, which includes assigning configuration and service
profiles, assigning an ASA 1000V or instantiating an ASA 1000V service image, and configuring interfaces.

Before You Begin

• At least one of the following must exist:

• An ASA 1000V must be registered in Prime Network Services Controller and must be available
for assignment.

• An imported ASA 1000V service image.

• A VMManager must be configured in Prime Network Services Controller. For more information about
VM registration, see the Cisco Prime Network Services Controller 3.2 Quick Start Guide.

For HA-specific configurations, refer to the appropriate Cisco Adaptive Security Appliance 1000V (ASA
1000V) configuration guide for additional information.

Note

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose Add Edge Firewall.
Step 3 In the Properties screen, provide the information described in Properties Screen, on page 190, and then click

Next.
Step 4 In the Service Device screen, do one of the following, and then click Next:

• To assign an existing ASA 1000V service device:

1 Click Assign ASA 1000V.

2 From the ASA 1000V Device drop-down list, choose the required ASA 1000V.

• To instantiate a new ASA 1000V:

1 Click Instantiate.

2 Choose the image to use to instantiate a new ASA 1000V service device.

3 In the VM Access password fields, enter the password for the admin user account.

Step 5 (Instantiate option only) If you instantiate a ASA 1000V service device from an image, do one or both of the
following in the Placement screen, and then click Next:
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• Navigate to and choose the host or resource pool to use for the ASA 1000V instance.

• If you enabled high availability, either check the Same as Primary check box, or navigate to and choose
the host or resource pool to use for the secondary ASA 1000V instance.

Step 6 In the Interfaces screen, add the required interfaces as follows, and then click Next:

• If you assigned an ASA 1000V without high availability, configure one inside and one outside interface.

• If you assigned an ASA 1000V with high availability, configure one inside and one outside interface,
each with a secondary IP address.

• If you instantiated an ASA 1000V without high availability, configure management, inside, and outside
interfaces.

• If you instantiated an ASA 1000V with high availability, configure management, inside, outside, and
HA interfaces.

Themanagement andHA interfacesmust use different port profiles.Note

Step 7 In the Summary screen, confirm that the information is accurate, and then click Finish.
Step 8 If you instantiated the ASA 1000V from a service image, you must do the following to ensure registration

with Prime Network Services Controller:
a) Within 15 minutes of instantiation, manually register the ASA 1000V to Prime Network Services

Controller by using the ASA 1000V CLI.
b) If you do not register the ASA 1000V within 15 minutes of instantiation, the instantiated ASA 1000V will

enter a failed state, and you must delete it manually from Prime Network Services Controller and the
hypervisor.

Field Descriptions

Properties Screen

DescriptionField

Edge firewall name.

This name can contain 1 to 32 identifier characters.
You can use alphanumeric characters including
hyphen, underscore, dot, and colon. You cannot
change this name after it is created.

Name

Edge firewall description.Description

Management hostname of the firewall.Host Name

Check the Enable HA check box to enable high
availability.

High Availability
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DescriptionField

Do either of the following:

• Click the profile name to view and optionally
modify the currently assigned device
configuration profile.

• Click Select to choose a different device
configuration profile.

Device Configuration Profile

Do either of the following:

• Click the profile name to view and optionally
modify the currently assigned device service
profile.

• Click Select to choose a different device service
profile.

Device Service Profile

Unassigning an ASA 1000V
If required, you can unassign an ASA 1000V from an edge firewall.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose the required edge firewall.
Step 3 In the toolbar, choose Actions > Unassign ASA 1000V.
Step 4 When prompted, confirm the action.

Edge Routers

Edge Router Configuration Workflow
This workflow describes how to create an edge router under a tenant.

NotesSteps

See Prerequisites for Configuring Edge Routers, on
page 192.

1. Confirm that prerequisites are met.
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NotesSteps

• ChoosePolicyManagement > Service Profiles
> tenant > Edge Router and select Device
Service Profiles or Interface Service Profiles

• ChoosePolicyManagement > Service Policies
> tenant and select Policies or Policy Helpers

2. (Optional) Configure Edge Router configuration
and service profiles and policies. If needed, you can
use the default profiles.

Choose Resource Management > Managed
Resources > tenant and select Add Edge Router
from the Network Services Actions drop-down list.

3. Add an edge router under a tenant.

See Adding Edge Routers, on page 195.4. Enter the appropriate information in the Add Edge
Router Wizard.

Choose Resource Management > Resources and
select the edge router device and view the device
status in the table.

It takes some time for the logical device to
associate with the physical device.

Note

5. Verify that the edge router has been created.

Prerequisites for Configuring Edge Routers
The following table lists the information you should have on hand and any prerequisites for configuring edge
routers. For information on adding and configuring edge routers, see Edge Router Configuration Workflow,
on page 191 and Adding Edge Routers, on page 195.

By default, CSR 1000V OVA images contain three vNICs and Prime Network Services Controller will
instantiate CSR 1000V service images with only three interfaces. If you need more than three edge router
interfaces, see http://www.cisco.com/en/US/docs/routers/csr1000/software/configuration/vminterface.html
for information on how to configure additional interfaces.

Note
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NotesItem

Note all the necessary edge router information needed
for configuration.

• To assign an edge router to Prime Network
Services Controller, an edge router VM must
be installed. Use VM management software
(such as VMware) to deploy a device image
from an OVA template and register the device
with Prime Network Services Controller. For
Cisco Cloud Services Router 1000V, see the
Cisco CSR 1000V Configuration Guide.

• To instantiate an edge router, an edge router
service image must be available. For more
information, see Importing Service Images, on
page 182.

Decide whether you are assigning or instantiating an
edge router.

See Creating a Tenant.At least one tenant is configured

Loopback interfaces cannot be added or deleted after
an edge router is instantiated. Therefore, all required
loopback interfaces must be configured before
assignment or during instantiation.

Determine the number of loopback interfaces required
on the edge router.

Data interfaces cannot be added or deleted after an
edge router is instantiated. Therefore, all required
data interfaces must be configured before assignment
or during instantiation.

Determine the number of data (Gigabit Ethernet)
interfaces required on the edge router.

Prime Network Services Controller offers a default
configuration profile that contains common policies
for all devices managed in Prime Network Services
Controller. You can use or edit the default profile, or
customize a new profile. To create a new device
configuration profile, choose PolicyManagement >
Device Configurations > root (or tenant) > Device
Profiles and click Add Device Profile.

Decide whether to create a new edge router device
profile
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NotesItem

To create or edit a device service profile, note the
following applicable router policy and interface
information you need for configuration:

Device Service Profile (Policies)

• Routing Policy

◦Static

◦BGP

◦OSPF

• NAT
Edge routers support a limited set of
NAT policy options.

Note

• Zone-Based Firewall
For more information on zone-based
firewall configuration, see Configuring
Zone-Based Firewall Policies, on page
116.

Note

A zone policy defines the traffic that
you want to allow or deny between
zones. A zone-pair policy allows you
to specify a unidirectional firewall
policy between two zones. The
direction is defined by specifying a
source and destination zone.

Note

Interface Service Profiles

• Ingress

• Egress

• NAT Membership

• Firewall Zone Membership

A firewall zone is a group of interfaces to
which a policy can be applied. By default,
traffic can flow freely within that zone but
all traffic to and from that zone is dropped.
To allow traffic to pass between zones, you
must explicitly declare it by creating a
zone-pair and a policy for that zone.

Note

Decide whether to configure or use the default device
service profiles.
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Adding Edge Routers
This procedure describes the steps in the Add Edge Router wizard. The Add Edge Router wizard is part of
the Edge Router Configuration Workflow, on page 191. Before using the Add Edge Router wizard, see
Prerequisites for Configuring Edge Routers, on page 192.

Procedure

Step 1 Choose Resource Management > Managed Resources > tenant, and then choose Add Edge Router.
Step 2 Enter edge router device information in the Properties window and click Next.
Step 3 If you are instantiating an edge router, do the following, and then click Next:

a) Select the image to use to instantiate the edge router.
b) In the Compute area, enter the number of virtual CPUs and amount of memory you need to meet the

required throughput. For more information, see Edge Router Deployment Options, on page 195.
c) In the VM Access area, enter the access credentials.

Step 4 In the Service Device screen, if you are assigning an edge router, choose the deployed edge router, configure
the applicable interfaces and IP addresses, and then click OK.
Note • You must configure at least two Gigabit interfaces.

• The primary IP address and the sub management IP address must be in the same
subnet.

Step 5 In the Placement screen, choose the location for the edge router.
Step 6 In the Interface screen, assign the IP address. Keep in mind that the the primary IP address and the sub

management IP address must be in the same subnet.
Step 7 Click Finish if the summary details are correct.

Edge Router Deployment Options
Edge routers can support different amounts of throughput based on the number of virtual CPUs and amount
of memory. Choose the number of virtual CPUs and amount of memory that are appropriate for your
environment and for the desired throughput.

Technology PackageThroughput

PremiumAdvancedStandardSpeed

1 vCPU, 2.5 GB RAM1 vCPU, 2.5 GB RAM1 vCPU, 2.5 GB RAM10 Mbps

1 vCPU, 2.5 GB RAM1 vCPU, 2.5 GB RAM1 vCPU, 2.5 GB RAM50 Mbps

1 vCPU, 2.5 GB RAM1 vCPU, 2.5 GB RAM1 vCPU, 2.5 GB RAM100 Mbps

4 vCPU, 4 GB RAM4 vCPU, 4 GB RAM4 vCPU, 4 GB RAM250 Mbps
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Technology PackageThroughput

——4 vCPU, 4 GB RAM500 Mbps

——4 vCPU, 4 GB RAM1 Gbps

Managing Edge Routers
You can do the following edge router management tasks:

• Edit information and network interfaces.

• Modify the device profile, device service profile, and the interface service profile.

• Delete an edge router.

• Monitor status and view fault information.

• You can start, stop, and reboot edge routers that have been instantiated.

• You can perform assign and unassign operations for edge routers that have been registered.

For information on initial edge router configuration, see Edge Router Configuration Workflow, on page 191
and Prerequisites for Configuring Edge Routers, on page 192.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose the required edge router and then click Edit or Delete.
Step 3 If you chose Edit, modify or view the appropriate tab information in the Edit dialog box, and then clickOK.

To view additional information about an entry in the Faults tab, double-click the entry, or select the
entry and then click Properties.

Note

Load Balancers

Load Balancer Configuration Workflow
This workflow describes how to create a load balancer under a tenant. The workflow includes creating a virtual
server profile and an associated service if one does not exist.
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NotesSteps

See Prerequisites for Configuring Load Balancers, on page 197. This
topic also includes the following information:

• Importing load balancer licenses.

• Installing the device adapter.

1. Confirm that the prerequisites
are met.

Add a service and enter general and server farm information. See Load
Balancing ServiceDialog Boxes, on page 200 for server farm information.

2. Add a virtual server profile to
a tenant.

Choose Policy Management > Service Profiles > tenant > Load
Balancer and confirm that the virtual server has been created in the
Virtual Server Profiles table.

3. Verify that the virtual server
profile has been created.

Choose Resource Management > Managed Resources > tenant and
then choose Add Load Balancer from the Network Services Actions
drop-down list.

4. Add a load balancer device
under a tenant.

The wizard maps a logical load balancer and configures the virtual IP
addresses to the selected virtual servers. For more information, see Adding
Load Balancers, on page 199.

5. Enter the appropriate
information in the Add Load
Balancer Wizard.

Choose Resource Management > Resources > VPX > load-balancer
and then view the device status in the table.

It takes some time for the logical device to associate with the physical
device.

6. Verify that the load balancer
has been created.

After a load balancer is added and configured, you can view faults, edit, and monitor the load balancer. For
more information, see Managing Load Balancers, on page 202. Also, if you would like to edit services on a
server profile (for example, add ping monitors), choose Policy Management > Service Profiles > tenant >
Load Balancer > Virtual Server Profiles > service and click Edit.

Prerequisites for Configuring Load Balancers
The following table lists the information you should have on hand and any prerequisites for configuring load
balancers:

For load balancer configuration, see Load Balancer Configuration Workflow, on page 196 and Adding
Load Balancers, on page 199.

Note

NotesItem

At least one existing tenant configured.Tenant

Load Balancer Information
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NotesItem

See Registering Third-Party VMs.For Citrix NetScaler load balancers, the Prime
Network Services Controller Device Adapter must
be deployed

Note all the necessary load balancer information
needed before configuration.

To assign a load balancer, the load balancer OVA
must first be deployed. For Citrix NetScaler load
balancers, see Citrix Netscaler documentation and
also Registering Third-Party VMs.

To instantiate a load balancer, a load balancer service
image must be available. See Importing Service
Images for information on how to import a service
image.

Decide whether you are assigning or instantiating a
load balancer

Virtual Server Profile Information

Virtual servers cannot be added or deleted after a load
balancer is instantiated. All required virtual servers
must be configured before registration or during
instantiation.

Determine the number of virtual servers required on
the load balancer

• Protocol

• Port

• Algorithm

• Persistence

• Real server

• Host name or IP address

For more information, see Load Balancing Service
Dialog Boxes, on page 200.

Service and server farm information

• TCP

• HTTP

• Ping

Monitor information
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Adding Load Balancers
This procedure describes the steps in the Add Load Balancer wizard. Before using the Add Load Balancer
wizard, confirm that the prerequisites are met in Prerequisites for Configuring Load Balancers, and see Load
Balancer Configuration Workflow.

Procedure

Step 1 Enter load balancer device information in the Properties window and click Next.
If you choose to enable vPath, only vPath-enabled devices (like Citrix Netscaler 1000V) will be
available for selection in the instantiation image list.

Note

Step 2 Choose whether you want to register or instantiate a load balancer in the Service Device window.
Step 3 Do one of the following:

1 If you are registering a load balancer:

• Enter all required information (device IP address, subnet mask and gateway information).

• Select the device type and version from the drop-down lists.

• Enter the device access credentials.

• Configure one data interface and one virtual IP interface in the Configure Interface window, then
clickNext. All interfacesmust be in different subnetworks. Themanagement interface is automatically
taken from the device IP address that you entered above.

2 If you are instantiating a load balancer:

• Select the instantiation image and locate where the VM will be hosted.

• Enter the virtual machine access credentials and click Next.

• Navigate to VM placement.

• Configure one data interface and one management interface in the Configure Interface window, then
click Next.

Step 4 Configure a virtual server by selecting an existing virtual server profile and assigning virtual IP addresses
(VIPs) in the Configure Virtual Server window, then click Next.
Note • VIPS are public IP addresses that clients connect to and where all traffic is directed to. Behind

VIPs are real servers where load balancing occurs. Limit the number of VIPs to 64 VIPs per
load balancer.

• The VIP IP address cannot be on the management network.

Step 5 Click Finish if the summary details are correct.

For troubleshooting information, view errors in the Faults tab (see Managing Load Balancers). If you would
like to modify the virtual server profile services (for example, add monitors to your server farm) choose Policy
Management > Service Profiles > tenant > Load Balancer > Virtual Server Profiles > service and click
Edit. Navigate to the Server Farm tab to modify any information.
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Load Balancing Service Dialog Boxes
Various Service dialog boxes appear when configuring a virtual server service for a load balancer profile. For
more information on how to configure a load balancer profile, see the Load Balancer ConfigurationWorkflow
topic.

Server Farm Information

Note • If you need to add a new server farm, you must enter information in the Real Server and Monitor
tabs.

• To confirm that your configurations were applied, you can view the device's UI.

NotesField

If you select SSL or SSL_TCP, a security policymust
be configured. See the Security Policy Dialog Boxes
topic which describes.

Protocol

Select the scheduling algorithm for the server farm.

• Least Connection—New connections are sent
to the server with the fewest connections.

• Destination IP Hash—Selects a server based on
a hash of the source IP address of each packet.

• Least Bandwidth—New connections are sent
to the server with the least bandwidth.

• Least Packets—New connections are sent to the
server with the least packets.

• Least Response Time—New connections are
sent to the server with the least response time.

• Round Robin—Each server is used in turn
according to the weight assigned to it.

• URL Hash—The left part of the URL (before
the question mark) is hashed and divided by the
total weight of the running servers. The result
designates which server will receive the request.
Applicable to only HTTP service load
balancing.

Algorithm

Interval at which the server is pinged.Increment Interval
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NotesField

Select the persistence method that will define how
the load balance service handles information. The
following persistence restrictions exist:

• SSL—Applies only to SSL-based services.

• Cookie Insert—Applies only to HTTP-based
services.

If the service protocol and persistence
is an invalid combination, a
"failed-to-apply" status appears in the
Network Services tab.

Note

Persistence

Monitors

Monitors HTTP traffic.HTTP

Pings real servers to see if they are up and running.Ping

Monitors TCP traffic.TCP

Limitations

• 64 real servers per server farm

• 64 monitors per server farm

• 16 services per virtual server

Security Policy Dialog Boxes

Load Balancing Security Policy Information

For load balancing, if SSL and SSL-TCP protocols are selected, security policies must be configured. You
can configure security policies so that cryptographic authentication is enabled using the SSL Params, Cipher
Groups, Certificate, and Certificate Key File dialog boxes.

SSL offload configuration requires a valid certificate and key file.Note
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DescriptionDialog Box

Allows you to customize the SSL configuration. From
this dialog box you may choose to enable and
configure the following:

• Ephemeral RSA

• Session reuse

• Cipher redirect

• SSL and SSLv2 redirect

• Selection of TLSv1, SSLv3, and SSLv2
protocols

• Close notifications

• SSL redirect port rewrite

SSL Params

Allows you to select or add cipher groups. A cipher
group is a set of cipher suites that you attach to an
SSL service.

Cipher Group

Allows you to configure or add certificates and
certificate key files.

Certificate and Certificate Key File

Managing Load Balancers
You can do the following load balancer management tasks:

• Edit information and network interfaces.

Management and data IP interfaces cannot be modified after creation.Note

• Delete a load balancer.

• Monitor status and view fault information.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose the required load balancer, and then click Edit or Delete.
Step 3 If you chose Edit, modify or view the appropriate tab information in the Edit dialog box, and then clickOK.

To view additional information about an entry in the Faults tab, double-click the entry, or select the
entry and then click Properties.

Note
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If you would like to modify the virtual server profile services (for example, add monitors to your server farm)
choose Policy Management > Service Profiles > tenant > Load Balancer > Virtual Server Profiles >
service and click Edit. Navigate to the Server Farm tab to modify any information.

Adding a Port Profile to a VSM
Prime Network Services Controller enables you to add a port profile to an enterprise VSM. You cannot add
a port profile to a cloud VSM.

If an enterprise VSM has preconfigured port profiles or virtual service configurations that were created outside
of Prime Network Services Controller, these configurations will not be displayed in the Prime Network
Services Controller GUI.

If you create a port profile in Prime Network Services Controller and specify a VLAN, you must create the
VLAN itself on the VSM and then add it to the necessary system and uplink port profiles. The same steps
apply for VLANs that you specify while creating service devices, such as edge or compute firewalls: you
must create the VLANs on the devices, and then add them to the appropriate system and uplink port profiles.

Before You Begin

Confirm the following:

• An enterprise VSM is registered and in the applied state in Prime Network Services Controller by
choosing Resource Management > Resources > VSMs.

• You have admin privileges.

Procedure

Step 1 Choose Resource Management > Resources > VSMs > vsm, then click Edit.
Step 2 Above the Port Profile table, click Add.
Step 3 In the Add Port Profile dialog box, enter the required information as follows, then click OK:

1 In the General tab, provide the following information:

• Name

• Description

• State: Enabled or Disabled.

• Type of Binding: Dynamic, Ephemeral, or Static.

• Binding Option: Auto, AutoExpand, or None.

• Maximum and minimum number of ports.

• Tenant or subordinate organization in which to create the port profile.

2 In the L2 Network Membership tab, provide the following information:

• Capability: Bridge Domain or VLAN.
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• Mode: Access or Trunk

• VLAN number (Access mode) or VLAN range (Trunk mode).

The NICs table is populated automatically after you bind a service path to the port profile and the service path
is used the first time. For more information about configuring a service path and binding it to a port profile,
see Service Path Configuration Workflow, on page 75.

Updating Discovered VSM Port Profiles
When Prime Network Services Controller discovers a VSM port profile that was configured directly on the
Nexus 1000V, only some of the configuration information is available to Prime Network Services Controller.
As a result, you need to provide the missing information in Prime Network Services Controller.

This situation usually occurs under the following circumstances:

• A VSM port profile with an organization and virtual service have been configured on a Nexus 1000V.

• VMs with vNICs that use the port profile have also been configured on the device.

Procedure

Step 1 Log in to the Prime Network Services Controller GUI and choose Resource Management > Resources >
VSM.

Step 2 Choose the VSM with the port profile that was configured using the CLI, and then click Edit.
Step 3 In the Port Profiles table, choose the required port profile, and then click Edit.
Step 4 Update the port profile properties so that they are consistent with the configured port profile, and save your

changes. You can then use the port profile as needed.
Step 5 If any port profile properties are modified via the CLI, update them in Prime Network Services Controller so

that the configurations remain synchronized.

Troubleshooting Devices and Services
You can use Prime Network Services Controller to troubleshoot faults associated with managed devices and
services.
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Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, choose the required service or device, and then click Edit.
Step 3 In the General tab, review the Status area for any issues or states affecting reachability, configuration, or

association.
Step 4 In the Faults tab, review the displayed faults. To view additional information about a fault, double-click the

entry, or choose the entry and then click Properties.

Launching ASDM
Prime Network Services Controller enables you to launch Cisco Adaptive Security Device Manager (ASDM)
as a Web Start application on your desktop.

You can set up ASDM to be used by the ASA 1000V when it is configured for either Prime Network Services
Controller managementmode or ASDMmanagementmode.When the ASA 1000V is configured to use Prime
Network Services Controller management mode, you can use ASDM tomonitor the status of the ASA 1000V,
but you cannot use it to manage configurations.

Before You Begin

You must complete the following tasks before launching ASDM from Prime Network Services Controller:

1 Do one of the following:

• If you have not already deployed the ASA 1000V OVA, do so; during the deployment, provide the
ASDM client IP address.

• If you have already deployed the ASA 1000V OVA, apply the following configuration by using the
VM console in the vSphere client:

• Add a route on the management interface to the ASDM client subnet by issuing the following
command:
ASA1000V(config)# route interface ip subnet next-hop-ip

where interface is the management interface to the ASDM client subnet, ip is the IP address
of the host that accesses ASDM, subnet is the ASDM client subnet, and next-hop-ip is the IP
address of the gateway.

Perform this step only if the next hop gateway IP address was not specified when
deploying the ASA 1000V.

Note

• Allow HTTP access via the management interface for the ASDM client subnet by entering the
following command:
ASA1000V(config)# http ip subnet interface

where ip is the IP address of the host that accesses ASDM, and interface is the ASDM client
interface.
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Perform this step only if the ASDM client IP address was not specified when deploying
the ASA 1000V.

Note

2 Confirm the following:

• The ASA 1000V is registered to Prime Network Services Controller.

• A valid username and password exist for the ASA 1000V VM console.

3 Assign the edge firewall to an ASA 1000V instance. If the edge firewall is not assigned to an ASA 1000V
instance, the ASDM options are not displayed in the UI.

4 Confirm that your system is configured to run downloaded Java Web Start applications.

For more information about configuring ASDM, see the Cisco ASA 1000V Cloud Firewall Getting Started
Guide.

Procedure

Step 1 Choose Resource Management > Managed Resources > tenant.
Step 2 In the Network Services tab, choose the required edge firewall, and then click Edit.
Step 3 In the Edit dialog box, click Launch ASDM.

The ASDM Launch screen opens.
Step 4 In the ASDM Launch screen, click Run ASDM.

The ASDMWeb Start application is automatically downloaded and runs. If prompted, accept the certificates.
If an ASDM login dialog box is displayed, you can clickOKwithout entering login credentials.Note

Managing VSG Pools

Adding a VSG Pool

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the VSG Pools tab, click Add Pool.
Step 3 In the Add Pool dialog box, enter a name and description for the pool.
Step 4 To assign members to the pool:

a) Click (Un)Assign.
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b) In the Available list, choose the VSGs that you want to add to the pool, and then click the arrow to move
them to the Assigned list.

c) Click OK.

Step 5 Click OK.

Assigning a VSG Pool
You can assign a VSG pool to a compute firewall when you add a compute firewall to a tenant or other
organization. For information on assigning a VSG to a compute firewall, see Adding a Compute Firewall,
on page 183.

Editing a VSG Pool
After you create a VSG pool, you can change its description and add or remove VSGs from the pool as
required.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the VSG Pools tab, choose the pool that you want to edit, and then click Edit.
Step 3 In the Edit Pool dialog box, modify the following information as required, and then click OK:

a) Edit the description.
b) To add or remove VSGs from the pool, click (Un)Assign.
c) To delete a VSG from the pool, choose the required VSG from the list of pool members, and then click

Delete.

Unassigning a VSG Pool
If required, you can unassign a pool from a compute firewall.

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the Network Services tab, select the required firewall, and then choose Actions > Unassign VSG/Pool.
Step 3 When prompted, confirm the action.
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Deleting a VSG Pool

Procedure

Step 1 Choose Resource Management > Managed Resources > root > tenant.
Step 2 In the VSG Pools tab, choose the pool that you want to delete, and then click Delete.
Step 3 When prompted, confirm the deletion.
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C H A P T E R  12
Integrating with DCNM

This section includes the following topics:

• DCNM Integration Overview, page 209

• Configuring Connectivity with DCNM, page 212

• Troubleshooting Integration Issues, page 214

DCNM Integration Overview
Prime Network Services Controller supports integration with Cisco Data Center Network Manager (DCNM).
As part of this integration, Prime Network Services Controller provides the automation of virtual network
services in Cisco Dynamic Fabric Automation (DFA). In the Cisco DFA solution, services like firewalls and
load balancers are deployed at leaf nodes within the spine-leaf topology and in border leaf nodes, in contrast
to more traditional data centers where these services are deployed at the aggregation layer.

The following table describes the primary items in the Prime Network Services Controller integration with
DCNM:

DescriptionItem

Provides central management of network services in
a multi-tenant environment.

Prime Network Services Controller

• Provides the setup, visualization, management,
and monitoring of the data center infrastructure.

• Provides configuration and image management
for the fabric.

DCNM

Provides a simplified spine-leaf architecture, enhanced
forwarding, and distributed control plane.

Dynamic Fabric Automation (DFA) cluster
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DescriptionItem

• Links Prime Network Services Controller with
DCNM.

• Enables DCNM to interoperatewith one ormore
instances of PrimeNetwork Services Controller.

• Maps the tenants and virtual data centers to the
Prime Network Services Controller instances
responsible for network services.

• Listens to network database updates and
communicates those updates to the appropriate
Prime Network Services Controller instance.

• Upon notification of a new network service in
a tenant network, notifies DCNMof the change.

Prime Network Services Controller Adaptor

Prime Network Services Controller provides centralized management of network services by supporting the
following actions:

• The creation, reading, updating, and deletion of vPath-based service chains.

• The creation, updating, and deletion of network services.

• Communicating changes about network services to the Prime Network Services Controller Adapter.

The Prime Network Services Controller GUI reflects this support by displaying information for networks and
subnetworks associated with a tenant, and network services in a tenant's network.

Terminology

The following table identifies the corresponding terms in Prime Network Services Controller and DCNM:

DescriptionDCNM NamePrime Network Services Controller
Name

A collection of VDCs for
tenant-level separation of resources
and data.

OrganizationTenant

An independent routing domain
that includes a collection of
subnetworks. A VDC can belong
to only one tenant.

PartitionVirtual Data Center (VDC)

A unique Layer 2 network
identified by a unique identifier. A
subnetwork can belong to only one
VDC.

NetworkSubnetwork
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Networks

After an admin user provisions one or more tenant networks in DCNM, DCNM sends the information about
the tenant network to Prime Network Services Controller. A tenant-admin user in Prime Network Services
Controller can then deploy network services such as firewalls, load balancers, and routers on those networks.

For each network, DCNM provides Prime Network Services Controller with a handle that uniquely identifies
the network on a VM manager and the network's Layer 3 IP details, such as subnet prefix, mask, and default
gateway.

To view these networks in Prime Network Services Controller, choose Resource Management > Managed
Resources > root > tenant (or other subordinate organization), and then click the Subnetworks tab.

You can place the interfaces of a network service that is deployed at a particular level (or node) in the tenant
organizational hierarchy on available networks at the following locations:

• The organization node on which the service is being deployed.

• Organization nodes that are children of the organization node on which the service is being deployed.

• Organization nodes that are ancestors of the organization node on which the service is being deployed.

Network Roles

Networks are qualified by a role property which identifies their intended usage. The following table describes
the various network roles.

DescriptionNetwork Role

Tenant-specific network intended for tenant
applicationVMs. Service nodes can also be connected
to this network.

Host

Tenant network intended exclusively for service
nodes.

Service

Tenant network that provides external connectivity.
Both tenant application VMs and service nodes can
connect to this network.

External

Shared infrastructure network used for communication
between service nodes and Prime Network Services
Controller. Service node management interfaces
connect to this network.

Management

Shared infrastructure network intended for high
availability communications between service nodes.
Service node HA interfaces connect to this network.

HA

In contrast with tenant networks, which are tenant-specific and provisioned on the data center fabric by DCNM,
infrastructure networks are shared by all tenants and are provisioned on the data center fabric out of band.

Details about infrastructure networks need to be added to Prime Network Services Controller by the admin
user. Because these networks are shared, they can be added only to root (Tenant Management > root).
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To add details about infrastructure networks, choose Resource Management > Managed Resources and
then click the Subnetworks tab.

Roles and Privileges

The following roles support Prime Network Services Controller integration with DCNM:
ResponsibilityRole

• Deploy Prime Network Services Controller if
it is not already deployed.

• Configure the Prime Network Services
Controller instance and credentials on DCNM.

• Confirm communication between Prime
Network Services Controller and DCNM.

• As needed, create tenant-admin user accounts.

• Provide the tenant-admin user with the Prime
Network Services Controller management IP
address.

admin

• Add, modify, or delete network services in the
scope of the tenant organizational hierarchy
provided by DCNM.

• As part of network service creation, connect the
data interfaces on the subnetworks for that
tenant.

tenant-admin

Configuring Connectivity with DCNM
This procedure describes how to configure connectivity between Prime Network Services Controller and
DCNM.

After you have successfully configured connectivity, the following aspects apply:

•When operating with DCNM, you cannot create, modify, or delete tenants or virtual data centers from
the Prime Network Services Controller GUI.

• Prime Network Services Controller allows admin and tenant-admin users to create, modify, and delete
Application and Tier organizational levels under a Virtual Data Center organization.

• The Prime Network Services Controller GUI does not allow admin or tenant-admin users to modify any
information related to tenant-scoped network or subnetworks. This restriction does not apply to
management or HA networks and subnetworks that are managed by Prime Network Services Controller
admin users.

• If you create, update, or delete a network service in Prime Network Services Controller, it will be reflected
in both DCNM and Prime Network Services Controller.
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Before You Begin

Confirm the following:

• The DCNM system is running.

• Enhanced Fabric Network was enabled during DCNM deployment.

• You have network access to the DCNM system.

• You have the appropriate privileges for configuring DCNM.

• You have deployed Prime Network Services Controller in Orchestrator mode.

• You have created a user account with the admin role for use only by the Prime Network Services
Controller Adaptor in DCNM.

For more information about these prerequisites, see the following links:

• Cisco PrimeDataCenterNetworkManager—http://www.cisco.com/en/US/products/ps9369/tsd_products_
support_series_home.html

• PrimeNetwork Services Controller Quick Start Guide—http://www.cisco.com/en/US/products/ps13213/
prod_installation_guides_list.html

Procedure

Step 1 Log in to the DCNM VM console as root.
Step 2 Navigate to the /opt/nscadapter/bin directory.
Step 3 Start the Prime Network Services Controller adaptor by entering the following command: nsc-adapter-mgr

adapter start
Step 4 Using the nsc-adapter-mgr nsc add command, enter the following information to provide DCNMwith access

to Prime Network Services Controller:

• Prime Network Services Controller management IP address

• Username for Prime Network Services Controller access

• Password for Prime Network Services Controller access

The command format is nsc-adapter-mgr nsc add ip-address username password.

Step 5 Log in to the Cisco DCNM GUI and do the following:
a) Choose Admin > Dynamic Fabric Automation > Settings.
b) Choose Config > Dynamic Fabric Automation (DFA) > Auto-Configuration.
c) Click Add Organization and enter the information for the organization. An organization in DCNM

corresponds to a tenant in Prime Network Services Controller.
d) As needed, add partitions to the organization. A partition in DCNM corresponds to virtual data center in

Prime Network Services Controller.
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e) Add a network to the partition.

Step 6 To confirm that connectivity is established between DCNM and Prime Network Services Controller, log in
to Prime Network Services Controller and confirm that the organization is displayed in the TenantManagement
tab.

Troubleshooting Integration Issues
If you encounter issues with the Prime Network Services Controller and DCNM integration, you can look for
information in the following locations:

• On the DCNM server, review the log files in /opt/nscadapter/var/log for information.

• In the Prime Network Services Controller GUI:

◦Review faults for services by choosing Resource Management > Managed Resources > root >
tenant > Network Services > network-service > Edit > Faults tab.

◦Review audit logs and faults by choosing Resource Management > Diagnostics > Audit Logs
or Faults.

For either option, double-click a fault to view more information.

The following table describes specific issues you might encounter and how to address them:

ResolutionCauseSymptom

1 Confirm that the Service
Configuration parameters are
complete for networks created
in DCNM.

2 Confirm that Prime Network
Services Controller is registered
with the VM Manager IP
parameter.

The configurations in DCNM and
PrimeNetwork Services Controller
are incomplete.

Organizations and partitions are
created in DCNM but no tenants
or VDCs are displayed in Prime
Network Services Controller
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ResolutionCauseSymptom

Use the nsc-adapter-mgr adapter
connections command to ensure
there is an active connection to
Prime Network Services
Controller.

The NSC Adapter does not have
an active connection to Prime
Network Services Controller.

Networks are created inDCNMbut
no tenants, VDCs, or subnetworks
are displayed in Prime Network
Services Controller.

Use the nsc-adapter-mgr adapter
connections command to ensure
there is an active connection to
DCNM.

The NSC Adapter is not active on
DCNM.

Confirm that Prime Network
Services Controller is registered
with the correct VM Manager and
provide the VMManager IP in the
VM Manager IP parameter.

PrimeNetwork Services Controller
does not have the VMManager IP.

1 Enter the command
nsc-adapter-mgr adapter
connections and verify that the
connections are correct.

2 In the DCNM GUI, choose the
auto-config interface, select the
network, click Edit, and then
click OK without making
changes.

Networks were added to DCNM
while Prime Network Services
Controller or the NSCAdapter was
down.

1 Enter the command
nsc-adapter-mgr adapter
connections and verify that the
connections are correct.

2 In the DCNM GUI, choose the
auto-config interface, select the
network, click Edit, and then
click OK without making
changes.

Networks were deleted from
DCNM while Prime Network
Services Controller or the NSC
Adapter was down.

Service networks were deleted in
DCNMbut the tenants, VDCs, and
subnetworks are still shown in
Prime Network Services
Controller.

Manually delete the Service Node
IP Address in DCNM for the
affected partition.

The service was deleted from
PrimeNetwork Services Controller
while DCNM or the NSC Adapter
was down.

An edge service was removed from
PrimeNetwork Services Controller
but the Service Node IP Address is
still shown in DCNM.

Manually update the Service Node
IP Address in DCNM auto-config
for the affected partition.

The service was deployed in Prime
Network Services Controller while
DCNM or the NSC Adapter was
down.

An edge service was deployed in
PrimeNetwork Services Controller
but the Service Node IP Address is
not shown in DCNM.
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ResolutionCauseSymptom

• Make sure that the correct
profile is specified in DCNM
for the host network.

• Make sure that the
auto-config profile and
parameters are correct with
particular attention to the
Service Node IP address.

• The wrong profile is
specified in DCNM for host
networks.

• The service is not attached to
the leaf.

Host traffic does not reach the
service node.
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C H A P T E R  13
Configuring InterCloud Resources

This section includes the following topics:

• InterCloud Resources, page 217

• InterCloud Licensing Models, page 218

• InterCloud Configuration Workflow, page 218

• InterCloud Management User Privileges, page 219

• Preparing for InterCloud Configuration, page 219

• Configuring InterCloud Links and Cloud VMs, page 228

• Managing InterCloud Links, page 249

• Creating AMI Images from VMs, page 258

InterCloud Resources
Prime Network Services Controller enables you to extend your enterprise data center into a public cloud
through the configuration andmanagement of InterCloud resources. InterCloud resources include the following
items:

• Provider account—Provider accounts enable users to access and take advantage of cloud resources.
Public cloud providers generally own and operate the cloud infrastructure, and provide accounts to those
who want to use the cloud resources.

• Virtual Private Clouds (VPCs)—VPCs are logical groupings of cloud infrastructure components and
resources that enable an enterprise data center to extend into a public cloud. A provider account is
required to create a VPC.

• InterCloud links—InterCloud links are secure connections between an enterprise data center and a public
cloud. An InterCloud link includes two virtual gateways: one on the enterprise network and one on the
cloud. The gateway on the enterprise network is referred to as the InterCloud extender, and the gateway
on the cloud is referred to as the InterCloud switch. A secure Layer 3 tunnel connects the gateways,
thereby extending the Layer 2 enterprise network into the cloud.

• Cloud VMs—Cloud VMs are VMs that are instantiated within the context of a VPC and InterCloud link
on the public cloud. You can create multiple cloud VMs in a single VPC and InterCloud link.
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InterCloud Licensing Models

Prime Network Services Controller does not support the Provider Licensing model.Note

There are two types of InterCloud licensing models that Prime Network Services Controller provides:

• Platform Licensing—The cloud VSM enforces the number of cloud VMs created in the Amazon Web
Service (AWS). In this licensing model, you must import the bundle into Prime Network Services
Controller. The bundle consists of Cisco InterCloud Switch images that will be available as an option
to select during InterCloud link creation. A template will be created under the Amazon user account
using the available image in the bundle. For more information on this process, see Configuring InterCloud
Links and Cloud VMs.

• Provider Licensing—Prime Network Services Controller enforces the number of cloud VMs created in
the AWS. In this licensing model, you also import the bundle into Prime Network Services Controller,
but during InterCloud link creation, you select the Cisco InterCloud Switch template that is available
on Amazon Marketplace. Each switch template is capable of supporting a maximum number of VMs
and are associated with different costs. Prime Network Services Controller discovers these templates
on AmazonMarketplace and displays them in the InterCloud link creation wizard. For more information
on this process, see Configuring InterCloud Links and Cloud VMs.

You are given an option to select the licensing model during the first InterCloud link deployment in a cloud
VSM. The first InterCloud link deployment per cloud VSM dictates which licensing model is used on that
cloud VSM. For more information on creating an InterCloud link, see Configuring an InterCloud Link.

To switch from one license model to the other, you must delete all previous InterCloud links in a cloud
VSM.

Note

InterCloud Configuration Workflow
The workflow for configuring and managing InterCloud resources includes the following high-level phases
and activities:

Related TopicActivitiesWorkflow Phase

Preparing for InterCloud
Configuration, on page 219• Configuring policies, profiles, and

address pools.

• Downloading the required images.

• Obtaining a provider account.

Preparation

Configuring InterCloud Links
and CloudVMs, on page 228• Creating an InterCloud link.

• Placing VM images on the cloud.

• Creating VM instances on the cloud.

Configuration
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Related TopicActivitiesWorkflow Phase

Managing InterCloud Links,
on page 249• Updating InterCloud links.

• Removing InterCloud links.

• Monitoring InterCloud status.

• Troubleshooting InterCloud issues.

Ongoing management

Creating AMI Images from
VMs, on page 258

Creating AMI files from VMs in your data
center.

Customization

InterCloud Management User Privileges
Prime Network Services Controller provides the following roles and privileges in support of InterCloud
management:

DescriptionDefault PrivilegeRole

Ability to create and manage the following
InterCloud resources:

• MAC address pools

• Cloud provider accounts

• InterCloud bundled images

• InterCloud links

• InterCloud Extenders and Switches

InterCloud-Infrastructureintercloud-infra

Ability to create and manage the following
cloud resources:

• Cloud VMs

• Creation or migration of VM templates
on clouds

• Instantiation of cloud VMs

InterCloud-Serverintercloud-server

Preparing for InterCloud Configuration
Before you can configure an InterCloud link and cloud VMs, you must complete the procedures described in
the following sections.
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Configuring Profiles, Policies, and Pools
Successful implementation of an InterCloud link depends on the appropriate configuration of the following
items:

• IP groups—See Adding an IP Group, on page 220.

Failure to configure an IP group could permit unauthorized access to your cloud VMs,
InterCloud switch, and enterprise data center.

Caution

• Access port profiles and trunk port profiles—See Configuring VSM Port Profiles, on page 221.

• Device profiles—See Configuring an InterCloud Device Profile, on page 221.

• MAC address pools—See Adding a MAC Address Pool, on page 223.

• Policies and profiles for InterCloud tunnels—See Policies and Profiles for InterCloud Tunnels, on page
223.

You can also configure the following additional policies for inclusion in a device profile for InterCloud
resources:

• Core File policies

• Log File policies

• Syslog policies

For more information about these policies and how to configure them, see Configuring Device Policies, on
page 141.

Adding an IP Group
An IP group protects cloud resources by ensuring that SSH access to the public interface of cloud VMs in a
VPC is allowed ONLY from IP addresses in the IP group.

In InterCloud Management in Prime Network Services Controller, IP groups are applied on a per-VPC basis.
That is, only those IP addresses in an IP group that is associated with a VPC have SSH access to the cloud
VMs for that VPC.

Failure to configure an IP group could permit unauthorized access to your cloud VMs, InterCloud switch,
and enterprise data center.

Caution

Procedure

Step 1 Choose InterCloud Management > InterCloud Link > IP Groups.
Step 2 Click Add IP Group.
Step 3 In the Add IP Group dialog box, do the following:

a) Enter a name for the IP Group.
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b) Click IP Address Range.
c) In the Add IP Address Range dialog box, enter the NATed IP address and prefix for the range of IP

addresses to add to the IP group.

Step 4 Click OK in the open dialog boxes.

Configuring VSM Port Profiles
Cisco Virtual SupervisorModules (VSMs) on Cisco Nexus 1000V Series switches must be properly configured
to support InterCloud features. Completing the following steps when configuring port profiles on a VSMwill
ensure that the VSM can communicate with Prime Network Services Controller.

1 Configure at least one port profile for the access port and one for the trunk port. For information on
configuring port profiles, see theCisco Nexus 1000V InterCloud Port Profile Configuration Guide, Release
5.2(1)IC1(1.1) at http://www.cisco.com/en/US/products/ps12904/products_installation_and_configuration_
guides_list.html.

2 Publish the default port profile from the so that VSM so that it will be available to Prime Network Services
Controller. The publish port-profile command uses the format publish port-profile name where name
is the port profile name. For more information, see the Cisco Nexus 1000V InterCloud Port Profile
Configuration Guide, Release 5.2(1)IC1(1.1) at http://www.cisco.com/en/US/partner/products/ps12904/
products_installation_and_configuration_guides_list.html.

3 Add the org root command to each port profile so that the port will be included in the results of the show
org port brief command. For more information, see the command reference guides available on cisco.com
at http://www.cisco.com/en/US/products/ps11208/tsd_products_support_model_home.html.

VSMs that are capable of registering with InterCloud Extender and InterCloud Switch service modules are
automatically displayed when you configure an InterCloud link using either of the following wizards:

• Extend Network to Cloud Wizard

• Add InterCloud Link Wizard

Configuring an InterCloud Device Profile
An InterCloud device profile is a set of custom attributes and device policies that you can apply to an InterCloud
extender or switch. You specify device profiles for the InterCloud extender and switch when you create an
InterCloud link or by applying a different device profile to the InterCloud extender or switch after the link is
deployed.

Prime Network Services Controller includes a default InterCloud device profile. You can edit the default
InterCloud device profile, but you cannot delete it.
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Procedure

Step 1 Choose InterCloud Management > InterCloud Policies > Device Profiles.
Step 2 Click Add Device Profile.
Step 3 In the General tab in the New Device Profile dialog box, enter a profile name and description, and choose the

required time zone.
Step 4 In the Policies tab, provide the following information, then click OK:

DescriptionField

You can:

• Add a new server.

• Select an existing server and edit or delete it.

• Use the arrows to change priority.

DNS Servers

You can:

• Add a new domain.

• Select an existing domain and edit or delete it.

DNS Domains

You can:

• Add a new server.

• Select an existing server and edit or delete it.

• Use the arrows to change priority.

NTP Servers

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

Syslog

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

Core File
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DescriptionField

You can:

• Choose a policy from the drop-down list.

• Add a new policy.

• Click the Resolved Policy link to review or
modify the policy currently assigned.

Policy Agent Log File

Adding a MAC Address Pool
Add a MAC address pool to allocate a group of MAC addresses to a Virtual Private Cloud.

Procedure

Step 1 Choose InterCloud Management > InterCloud Link > MAC Pools.
Step 2 Click Add MAC Address Pool.
Step 3 Enter the following information, then click OK:

a) In the Name field, enter a name for the MAC address pool.
b) In the Start MAC Address field, enter the starting MAC address for the pool in the 12-digit hexadecimal

format.
c) In the Total Count field, enter the number of addresses in the pool. The minimum value is 1000 MAC

addresses, and the default value is 10000 MAC addresses.

Policies and Profiles for InterCloud Tunnels
A tunnel profile pairs a connection parameter policy with a key policy to ensure secure communications for
specific tunnel ports. After you configure tunnel profiles, you can apply them to tunnels between the following
elements:

• InterCloud extender and InterCloud switch

• InterCloud switch and cloud VM

For information on first configuring the individual policies and then tunnel profiles, see the following topics:

• Configuring a Connection Parameter Policy, on page 224

• Adding a Key Policy, on page 225

• Configuring a Tunnel Profile, on page 226
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You can also configure the following additional policies for inclusion in a device profile for InterCloud
resources:

• Core File policies

• Log File policies

• Syslog policies

For more information about these policies and how to configure them, see Configuring Device Policies, on
page 141.

Configuring a Connection Parameter Policy

A connection parameter policy specifies the basic attributes for connecting an enterprise network to a cloud.
A connection parameter policy is used with a key policy in a tunnel profile to ensure secure communications
between the enterprise and the cloud.

Procedure

Step 1 Choose InterCloud Management > InterCloud Policies > Policies > Connection Parameter Policies.
Step 2 Click Add Connection Parameter Policy.
Step 3 In the Add Connection Parameter Policy dialog box, provide the following information, then click OK:

DescriptionField

Connection parameter policy name.Name

Policy description.Description

Protocol to use for this policy: TCP or UDP. The
default protocol is UDP.

Protocol

Tunnel port for this policy (read-only). The default
port is 6644.

Tunnel Port

Data channel port for this policy (read-only). The
default port is 6644.

Data Channel Port

Length of time, in minutes and seconds, that a
connection can exist with no activity before a
keepalive message is sent. The default value is one
second.

Keep Alive Duration

Available if protocol is set to
UDP.

Note

Length of time, in minutes and seconds, that a
connection can remain idle before it closes. The
default value is five minutes.

Keep Alive Timeout

Available if protocol is set to
UDP.

Note
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Adding a Key Policy

A key policy specifies the encryption and hash algorithms, and the length of the rekeying period for a secure
connection. A key policy is used with a connection parameter policy in a tunnel profile to ensure secure
communications between the enterprise and the cloud.

Procedure

Step 1 Choose InterCloud Management > InterCloud Policies > Policies > Key Policies.
Step 2 In the General tab, click Add Key Policy.
Step 3 In the Add Key Policy dialog box, provide the following information, then click OK:

DescriptionField

Policy name.Name

Brief policy description.Description

Length of time (in days, hours, minutes, and seconds)
that can elapse before a new key must be generated.
Theminimum value is five minutes. The default value
of 00:00:00:00 indicates that rekeying does not occur.

ReKey Period

From the drop-down list, choose the encryption
method for this policy:

• AES-128-CBC (default)

• AES-128-GCM (not available if TCP protocol
is used)

• AES-256-CBC

• AES-256-GCM (not available if TCP protocol
is used)

• None

Encrypt Algorithm

This option is available if you choose AES-128-CBC,
AES-256-CBC, or None in the Encrypt Algorithm
field.

Hash algorithm for this policy: None, SHA-1
(default), SHA-256, or SHA-384.

The None option is available if you choose None in
the Encrypt Algorithm field.

Hash Algorithm
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Configuring a Tunnel Profile

A tunnel profile combines a connection parameter policy with a key policy to ensure secure communications
for specific tunnel ports. After you configure a tunnel profile, you can apply the profile to tunnels between
the following elements:

• InterCloud extender and InterCloud switch

• InterCloud switch and cloud VM

Procedure

Step 1 Choose InterCloud Management > InterCloud Policies > Tunnel Profiles.
Step 2 In the General tab, click Add Tunnel Profile.
Step 3 In the Add Tunnel dialog box, enter the following information, then click OK:

DescriptionField

Profile name.Name

Brief profile description.Description

Do any of the following:

• Choose an existing policy from the drop-down
list.

• Click Add Key Policy to create a new key
policy.

• Click the Resolved Policy link to review or
modify the key policy currently associated with
the profile.

Key Policy

Do any of the following:

• Choose an existing policy from the drop-down
list.

• Click Add Connection Parameter Policy to
create a new connection parameter policy.

• Click the Resolved Policy link to review or
modify the connection parameter policy
currently associated with the profile.

Connection Parameter Policy
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Creating a Provider Account
A cloud provider account is required before you can connect to a public cloud.

If you obtain an Amazon provider account, you will have access to Cisco InterCloud images on Amazon
Marketplace. Each InterCloud Switch image supports a different number of cloud VMs, such as 4, 8, or more.

Before You Begin

Obtain the following information:

• Cloud provider access ID.

• Cloud provider access key.

Procedure

Step 1 Choose InterCloud Management > InterCloud Link > Provider Accounts.
Step 2 Click Create Provider Account.
Step 3 In the Create Provider Account dialog box, provide the following information, then click OK:

DescriptionField

Provider account name.

This name can contain 1 to 16 characters. You can use alphanumeric characters
including hyphen, underscore, period, and colon. You cannot change this name
after the object has been saved.

Name

Cloud provider (read-only).Provider Type

Alphanumeric text string that identifies the account owner.Access ID

Unique key for the account.Access Key

Importing Platform Images
To improve usability and simplify the process of creating an InterCloud link, PrimeNetwork Services Controller
enables you to import a single zipped file from the Prime Network Services Controller Download site (http:/
/software.cisco.com/cisco/pub/software/portal/select.html?&i=!m&mdfid=284653427) on www.cisco.com.
The zipped file contains the following images and respective version number:

• InterCloud Extender image for the gateway on the enterprise network

• InterCloud Switch Image for the gateway on the cloud

• Cloud VM driver images
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After the zipped file is imported, Prime Network Services Controller automatically places the zipped files in
the correct locations and populates the Add InterCloud Link Wizard with the images.

Note •Whenmultiple image versions are available, PrimeNetwork Services Controller automatically selects
the latest version during VM cloud migration.

• You cannot import the same bundle twice.

This feature helps ensure that you always have appropriate, compatible images available for creating InterCloud
links and instantiating cloud VMs.

Procedure

Step 1 Choose InterCloud Management > InterCloud Link > Images.
Step 2 Click Import Bundled Image.
Step 3 In the Import Bundled Image dialog box:

a) Select the type of image you want to import.
b) Enter a name and description for the image you are importing.
c) In the Import area, provide the following information, then click OK:

• Protocol to use for the import operations: FTP, SCP, or SFTP.

• Hostname or IP address of the remote host to which you downloaded the images.

• Account username for the remote host.

• Account password for the remote host.

• Image path and filename, starting with a slash (/).

Configuring InterCloud Links and Cloud VMs
To configure an InterCloud link and instantiate one or more VMs in the cloud, complete the following
procedures in the order shown:

Related TopicProcedure

Configuring an InterCloud Link, on page
229

1. Configuring an InterCloud link

Importing a VM Image, on page 2372. Importing a VM image

Creating Cloud VM Templates, on page
239

3. Creating VM templates on the cloud

   Cisco Prime Network Services Controller 3.2 User Guide
228

Configuring InterCloud Resources
Configuring InterCloud Links and Cloud VMs



Related TopicProcedure

Instantiating a Cloud VM from a Cloud
Template, on page 244

4. Instantiating VMs on the cloud

Configuring an InterCloud Link
The Extend Network to Cloud wizard walks you through the process of configuring an InterCloud link. A
configuration summary is displayed at the end of the wizard, allowing you to review the information and
choose whether to deploy the InterCloud link immediately or later.

The wizard also enables you to configure the InterCloud link for high availability. If you enable high availability,
you can configure the following properties the same for both the primary and secondary InterCloud Extender:

• VM placement

• Port profile for the data trunk interface

• Port profile for the management interface

InterCloud links can be configured only on VMware ESXi hypervisors.Note

Before You Begin

• Complete the activities described in Preparing for InterCloud Configuration, on page 219.

• Confirm that at least one VSM is registered in Prime Network Services Controller. For more information,
see Verifying VM Registration, on page 182.

• Confirm that the default port profile has been published from the VSM. For more information, see
Configuring VSM Port Profiles, on page 221.

• Confirm that Prime Network Services Controller has access to a DNS server. If a DNS server is not
accessible, Prime Network Services Controller cannot communicate with the Amazon cloud provider.
To configure a DNS server, choose Administration > System Profile > root > Profile > default, and
add a DNS server.

• Confirm that an NTP server is configured in the InterCloud device profile.

Procedure

Step 1 Choose InterCloud Management > InterCloud Link > VPCs.
Step 2 Click Extend Network to Cloud.
Step 3 In the Configure VPC screen, provide the information described in Configure VPC Screen, on page 231, then

click Next.
If you select a VPC before choosing to add an InterCloud link, the Configure InterCloud Link screen
is displayed initially instead of the Configure VPC screen.

Note
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Step 4 In the Configure InterCloud Link screen, provide the information described in Configure InterCloud Link
Screen, on page 231, then click Next.

Step 5 In the InterCloud Extender screen, select the image to use for the InterCloud Extender, then click Next.
Prime Network Services Controller automatically selects the data store to use for the InterCloud Extender
instance.

Step 6 In the Select VM Placement screen, do one of the following depending on whether or not you enabled high
availability, then click Next:

• If you did not enable high availability, navigate to and select the ESXi host to use for the InterCloud
Extender instance.

• If you enabled high availability, do one of the following:

• To use the same ESXi host as the primary InterCloud Extender, in the Secondary area, check the
Same as Primary check box.

• To use an ESXi host other than the primary InterCloud Extender, in the Secondary area, navigate
to and select the ESXi host to use for the secondary InterCloud Extender instance.

Step 7 In the Configure Properties screen, provide the information described in Configure Extender Properties Screen,
on page 232, then click Next.

Step 8 In the Configure Network Interfaces screen, provide the information described in Configure Extender Network
Interfaces Screen, on page 233, then click Next.

Step 9 In the InterCloud Switch screen, do one of the following:

• If you did not check the UseMarketplace ICS check box in the Configure InterCloud Link screen, select
the template that you want to use, then click Next. The template version must match the version of the
InterCloud extender image that you selected in the InterCloud Extender screen.

• If you checked the Use Marketplace ICS check box in the Configure InterCloud Link screen, select the
required image from Amazon Marketplace as follows, then click Next:

1 Click Refresh Marketplace to ensure that the latest information is displayed.
The Refresh Marketplace button is available when selecting templates from Amazon
Marketplace.

Note

2 Select the required InterCloud Switch template with the number of VMs that you want to purchase.
The template version must match the version of the InterCloud Extender image that you selected in
the InterCloud Extender screen.

Step 10 In the Configure Properties screen, provide the information described in Configure Switch Properties Screen,
on page 235, then click Next.

Step 11 In the Configure Network Interfaces screen, provide the information described in Configure Switch Network
Interfaces Screen, on page 235, then click Next.

Step 12 In the Security screen, provide the information described in Security Screen, on page 236, then click Next.
Step 13 In the Summary screen:

a) Review the configuration to ensure that it is correct.
b) Check the Deploy check box to create the InterCloud link when you click Finish. Uncheck the Deploy

check box to create the InterCloud link later.
c) Click Finish.
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Field Descriptions

Configure VPC Screen

DescriptionField

Virtual Private Cloud (VPC) name.Name

Brief description.Description

Do any of the following:

• Choose a provider account from the drop-down
list.

• ClickCreate Provider Account to create a new
provider account.

• Click the Resolved Provider Account link to
review and optionally modify the provider
account currently associated with the VPC.

Provider Account

Provider region in which to create the VPC. If the
provider account selected in the previous field is
already associated with a region, a check mark and
the status Completed are displayed next to the
drop-down list.

Location

Do any of the following:

• Choose a MAC address pool from the
drop-down list.

• Click Create MAC Address Pool to create a
new MAC address pool.

• Click the Resolved MAC Pool link to review
and optionally modify the MAC address pool
currently associated with the VPC.

MAC Pool

Default VSM to use for the VPC.Default VSM

Configure InterCloud Link Screen

DescriptionField

InterCloud link name.InterCloud Link Name
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DescriptionField

Brief description.Description

Check this check box to select a Cisco InterCloud
Switch template from Amazon Marketplace.

Clear this check box to select a local InterCloud
Switch template.

Use Marketplace ICS

Virtual Supervisor Module (VSM) to use for the
InterCloud link. This drop-down list is automatically
populated with VSMs capable of supporting
InterCloud services.

The VSMs that are available depend on whether or
not you checked the UseMarketplace ICS check box:

• If you checked the check box, Amazon
Marketplace VSMs are listed.

• If you cleared the check box, local VSMs are
listed.

VSM

Check the Enable HA check box to indicate that the
InterCloud link is in active standby mode. Uncheck
the check box to indicate that the InterCloud link is
in standalone mode.

If you check the check box, subsequent screens will
require information for both the primary and
secondary InterCloud Extenders and Switches.

High Availability

Configure Extender Properties Screen

DescriptionField

InterCloud Extender name.Primary Name

(Displayed if high availability is enabled) Secondary
InterCloud Extender name.

Secondary Name

Do one of the following:

• Click the existing profile to review and
optionally modify it.

• Click Select to choose a different device profile.

Device Profile

Username for SSH access (read-only). Default value
is admin.

SSH User Name
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DescriptionField

Password for SSH access.SSH Password

Confirming entry for SSH password.Confirm Password

Configure Extender Network Interfaces Screen

DescriptionField

General Tab

Select the data trunk interface port group to use for
the InterCloud Extender port profile.

Primary Data Trunk Interface Port Profile

Displayed if you did not check the Same as Primary
check box in the Select VM Placement screen.

Select the data trunk interface port group to use for
the secondary InterCloud Extender port profile.

Secondary Data Trunk Interface Port Profile

Management Interface

Primary

Select the port profile to use for the primary
InterCloud Extender management interface.

Port Profile

IP address for the management interface.IP Address

Management interface subnet mask.Netmask

Management interface gateway IP address.Gateway

Secondary

The following fields are displayed only if high availability is enabled.

Displayed if you did not check the Same as Primary
check box in the Select VM Placement screen.

Select the port group to use for the secondary
InterCloud Extender management interface port
profile.

Port Profile

IP address for the secondary management interface.IP Address

Secondary management interface subnet mask.Netmask

Secondarymanagement interface gateway IP address.Gateway
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DescriptionField

Advanced Tab

Do one of the following:

• If the external tunnel interface is the same as
the Management interface, check the Same as
Management Interface check box.

• To specify a different external tunnel interface,
uncheck the Same as Management Interface
check box, and provide the following
information for the external tunnel interface:

• Port group for the port profile

• Interface IP address

• Subnet mask

• Gateway IP address

External Tunnel Interface

Primary

The following fields are displayed if the Same as Management Interface check box is unchecked.

Port group to use for the external tunnel interface port
profile.

Port Profile

External tunnel interface IP address.IP Address

Subnet mask to apply to the external tunnel interface
IP address.

Netmask

IP address of the gateway for the external tunnel
interface.

Gateway

Secondary

The following fields are displayed if the Same asManagement Interface check box is unchecked and high
availability is enabled.

Port group to use for the secondary external tunnel
interface port profile.

Port Profile

Secondary external tunnel interface IP address.IP Address

Subnet mask to apply to the secondary external tunnel
interface IP address.

Netmask

IP address of the gateway for the secondary external
tunnel interface.

Gateway
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DescriptionField

Internal

Do one of the following:

• If the internal interface is the same as the default
internal interface, check the Use Default
Internal Interface check box.

• If the internal interface is not the same as the
default internal interface, uncheck the Use
Default Internal Interface check box, and
choose the port profiles to use for the following
trunk ports:

• Enterprise trunk

• Tunnel trunk

Use Default Internal Interface

Configure Switch Properties Screen

DescriptionField

InterCloud Switch name.Primary Name

(Displayed if high availability is enabled for this link)
Secondary InterCloud Switch name.

Secondary Name

Do one of the following:

• Click the existing profile to review and
optionally modify it.

• Click Select to choose a different device profile.

Device Profile

Username for SSH access (read-only). Default value
is admin.

SSH User Name

Password for SSH access.SSH Password

Confirming entry for SSH password.Confirm Password

Configure Switch Network Interfaces Screen

DescriptionField

General Tab
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DescriptionField

From the drop-down list, choose the port profile to
use for the InterCloud Switch management interface.

Port Profile

Primary

IP address for the management interface.IP Address

Management interface subnet mask.Netmask

Management interface gateway IP address.Gateway

Secondary

The following fields are displayed if high availability is enabled.

IP address for the secondary management interface.IP Address

Secondary management interface subnet mask.Netmask

Gateway IP address for the secondary management
interface.

Gateway

Advanced Tab

Check the check box to use the default internal
interface for the InterCloud Switch. Uncheck the
check box to select a port profile for the tunnel trunk.

Use Default Internal Interface

Displayed if the Use Default Internal Interface check
box is cleared.

From the drop-down list, choose the tunnel trunk port
profile.

Tunnel Trunk Port Profile

Security Screen

DescriptionField

This option is available only during
InterCloud link creation.

Note

Do one of the following:

• Click the existing tunnel profile to review and
optionally modify it.

• Click Select to choose a different tunnel profile.

InterCloud Extender to InterCloud Switch Tunnel
Profile
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DescriptionField

This option is available only during
InterCloud link creation.

Note

Do one of the following:

• Click the existing tunnel profile to review and
optionally modify it.

• Click Select to choose a different tunnel profile.

InterCloud Switch to VM Tunnel Profile

You MUST configure an IP Group with
permitted IP addresses to prevent
unauthorized access to your InterCloud
switch and cloud VMs. Failure to
configure an IP group could permit
unauthorized access to your cloud VMs,
InterCloud switch, and enterprise data
center.

Caution

Do any of the following:

• From the drop-down list, choose an existing IP
group.

• Click Add IP Group to create a new IP group.

• Click the Resolved IP Group link to review or
modify the specified IP group.

Access Protection IP Group

Importing a VM Image
If desired, you can import VM images independently of the bundled platform images to create cloud VMs.
The imported image can be used to create a template on the cloud which, in turn, allows you to instantiate
cloud VMs.

Images are available in ISO, OVA, and Amazon Machine Image (AMI) formats. Windows ISO images are
not supported.

The first InterCloud link deployment dictates which licensing model is used. For more information on
licensing models, see InterCloud Licensing Models.

Note
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Procedure

Step 1 Choose InterCloud Management > Enterprise > VM Images.
Step 2 Click Import VM Image.
Step 3 In the Import VM Image dialog box, provide the information described in Import VM Image Dialog Box, on

page 238, then click OK.

Field Descriptions

Import VM Image Dialog Box

Windows ISO images are not supported.Note

DescriptionField

VM image name.Name

VM image description.Description

VM image format: Amazon Machine Image (AMI),
ISO, or OVA.

Format

Properties

The Properties area is not displayed for OVA images.

(AMI images only) Number of NICs for the VM.

The value in this field must match the value for the
image being imported.

Number of NICs

(AMI images only) VM operating system:
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

The value in this field must match the value for the
image being imported.

OS

(AMI images only) VM architecture: 32-bit, 64-bit,
or Unknown.

The value in this field must match the value for the
image being imported.

Architecture

Amount of disk space (in gigabytes) for the VM.Disk (GB)

Number of CPU cores for the VM.CPU Cores
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DescriptionField

Amount of memory (in megabytes) for the VM.Memory (MB)

Import

Protocol to use for the import operation: FTP, SCP,
or SFTP.

Protocol

Hostname or IP address of the remote host.Hostname / IP Address

Account username on the remote host.User Name

Account password on the remote host.Password

Remote filename, starting with a slash (/).Remote File

Creating Cloud VM Templates
After you establish an InterCloud link and download the required InterCloud Agent and VM images, you are
ready to create VM templates in the cloud. After they are created, these VM templates are used to instantiate
cloud VMs.

You can create VM templates in a cloud in the following ways:

• From an imported VM image—See Creating a Template from a VM Image, on page 239.

• From an existing template in your enterprise data center—See Creating a Cloud Template from an
Enterprise Template, on page 241.

• From an imported VM image or a VM in the data center under a specific VPC—Creating a Template
Under a VPC, on page 242.

Creating a Template from a VM Image
Use this procedure to create a template in a cloud from an existing VM image. The template is created in the
specified VPC and can then be used to create VM instances in the cloud.

Procedure

Step 1 Choose InterCloud Management > Enterprise > VM Images > image.
Step 2 Click Create Template in Cloud.
Step 3 In the Infrastructure screen in the Create Template in Cloud Wizard, select the VPC in which the template is

to reside, then click Next.
Step 4 In the Template Properties screen, provide the information described in Template Properties Screen, on page

240, then click Next.
Step 5 In the Network Properties screen, optionally add a port profile to each NIC as follows, then click Next:
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a) Right-click the NIC, then choose Edit.
b) In the Edit NIC dialog box, choose the required port profile from the Port Profile drop-down list, then

click OK.

Step 6 In the Configure Application Parameters screen, provide the information described in Configure Application
Parameters Screen for ISO Templates, on page 240, then click Next.

Step 7 In the Summary and Apply screen, confirm that the information is accurate, then click Finish.

Field Descriptions

Template Properties Screen

DescriptionField

Cloud template name.Template Name

SSH account username.SSH User

OS Information

VM operating system (read-only):
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

OS

Architecture type (read-only): 32-bit, 64-bit, or
Unknown.

Architecture

Template Properties

The following fields display values for the enterprise image and the cloud template. The enterprise values
are read-only, but you can modify the values for the cloud template.

Amount of memory (in megabytes) for the template.Memory (MB)

Number of CPU cores for the template.CPU Cores

Amount of disk space (in gigabytes) for the template.Disk (GB)

Configure Application Parameters Screen for ISO Templates

DescriptionField

Time zone to use when starting a cloud VM using
this template.

Timezone

VM hostname.Hostname

Password for the root account.Root Password
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DescriptionField

Confirming password entry.Confirm Password

Additional packages available for the image being
imported. The specific packages listed depend on the
ISO image being imported. Check the check boxes
of any packages you want to include with the ISO
image.

Add-on Packages

Creating a Cloud Template from an Enterprise Template
You can use an existing VM template in your data center to create a template on the cloud. After you create
the template on the cloud, you can use it to instantiate cloud VMs.

Before You Begin

Ensure that at least one VM template is available for you to upload to the cloud.

Procedure

Step 1 Choose InterCloud Management > Enterprise > VMManagers.
Step 2 In the navigation pane, navigate to the data center, cluster, host, or resource pool with the required template.
Step 3 In the Templates table, select the required template, then clickMigrate Template to Cloud.
Step 4 In the Infrastructure screen, select the destination VPC, then click Next.
Step 5 In the Template Properties screen, provide the information described in Template Properties Screen, on page

241, then click Next.
Step 6 In the Network Properties screen, optionally assign a port profile to each NIC as follows, then click Next:

a) Right-click a NIC, then choose Edit.
b) In the Edit NIC dialog box, select the required port profile from the drop-down list, then click OK.

Step 7 In the Summary and Apply screen, confirm that the information is correct, then click Finish.

Field Descriptions

Template Properties Screen

DescriptionField

Template name on the cloud.Template Name

Username for SSH access.SSH User

OS Information
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DescriptionField

VM operating system (read-only):
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

OS

VM architecture (read-only): 32-bit, 64-bit, or
Unknown.

Architecture

Template Properties

The following fields display values for both the enterprise VM and the cloud template. The enterprise values
are read-only, but you can modify the values for the cloud template.

Amount of memory (in megabytes) for the template.Memory (MB)

Number of CPU cores for the template.CPU Cores

Amount of disk space (in gigabytes) for the template.Disk (GB)

Creating a Template Under a VPC
Prime Network Services Controller enables you to create a template under a specific VPC from an imported
VM image or a VM in the data center.

Procedure

Step 1 Choose InterCloud Management > Public Cloud > VPCs > vpc > Templates.
Step 2 Click Add New Template.

The Add New Template wizard opens.

Step 3 In the Source Image screen, do one of the following, then click Next:

To use an imported VM image as the source for the template:

1 Click the Images tab.

2 Select the VM image to upload to the cloud.

To use a VM in the data center as the source for the template:

1 Click the Enterprise Data Center tab.

2 In the left pane, select the data center, cluster, host, or resource pool with the required template.

3 In the right pane, select the template to upload to the cloud.

Step 4 In the Template Properties screen, provide the information described in Template Properties Screen, on page
243, then click Next.

Step 5 In the Network Properties screen, optionally assign a port profile to each NIC as follows, then click Next:
a) Right-click the NIC, then choose Edit.
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b) In the Edit NIC dialog box, choose the required port profile from the Port Profile drop-down list, then
click OK.

Step 6 In the Summary and Apply screen, confirm that the information is accurate, then click Finish.

Field Descriptions

Template Properties Screen

DescriptionField

Template name on the cloud.Template Name

Username for SSH access.SSH User

OS Information

VM operating system (read-only):
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

OS

VM architecture (read-only): 32-bit, 64-bit, or
Unknown.

Architecture

Template Properties

The following fields display values for both the enterprise VM and the cloud template. The enterprise values
are read-only, but you can modify the values for the cloud template.

Amount of memory (in megabytes) for the template.Memory (MB)

Number of CPU cores for the template.CPU Cores

Amount of disk space (in gigabytes) for the template.Disk (GB)
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Instantiating Cloud VMs

If you are using an Amazon Marketplace image, you must subscribe to the Amazon Marketplace images
using your Amazon account before Prime Network Services Controller can instantiate instances from the
images. Visit the product links to subscribe to them:

Note

• CiscoNexus 1000V InterCloudwith 8 VMs: https://aws.amazon.com/marketplace/pp/B00FK3WNT8

• CiscoNexus 1000V InterCloudwith 32VMs: https://aws.amazon.com/marketplace/pp/B00FJKRIJW

• CiscoNexus 1000V InterCloudwith 64VMs: https://aws.amazon.com/marketplace/pp/B00FJKQ0XM

The amount of time required to instantiate a cloud VM when using an Amazon Marketplace image depends
on the available bandwidth and current traffic load in the Amazon infrastructure. At times, creating a cloud
VM might take longer than 10 minutes.

You can instantiate cloud VMs in the following ways:

• From a cloud template—See Instantiating a Cloud VM from a Cloud Template, on page 244.

• From a deployed template or VM in your data center—See Instantiating a Cloud VM from a Deployed
Template or Local VM, on page 245.

• By migrating a VM in your data center to the cloud—See Instantiating a Cloud VM by Migrating an
Enterprise VM, on page 247.

Instantiating a Cloud VM from a Cloud Template
After you create a VM template on a cloud, you can instantiate one or more cloud VMs.

Procedure

Step 1 Choose InterCloud Management > Public Cloud > VPCs > vpc > Templates.
Step 2 In the Templates table, choose a deployed template, then click Instantiate VM.
Step 3 In the Infrastructure screen, do the following, then click Next:

a) In the VM Name field, enter a name for the cloud VM.
b) In the InterCloud Link drop-down list, choose the InterCloud link to use for the cloud VM.

Step 4 In the VM Properties screen, provide the information described in VM Properties Screen, on page 245, then
click Next.

Step 5 In the Network Properties screen, provide the following information, then click Next:
a) In the NICs table, assign a port profile to each NIC by selecting a NIC and then clicking Edit. In the Edit

NIC dialog box, select the required port profile from the Port Profile drop-down list, then click OK.
A port profile always belongs to a specific VLAN. Select the port profile according to the VLAN
to which the NIC belongs.

Note

b) In the DNS Server 1 and DNS Server 2 fields, enter the IP addresses for the DNS servers.
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c) In the Domain Name field, enter the DNS domain name.

Step 6 In the Review Summary and Apply screen, confirm that the information is accurate, then click Finish.

Field Descriptions

VM Properties Screen

DescriptionField

OS Information

Cloud VM operating system (read-only):
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

OS

Architecture type (read-only): 32-bit, 64-bit, or
Unknown.

Architecture

Template Properties

The following fields display values for both the template and the cloud VM. The values for the template
are read-only, but you can modify the values for the cloud VM as needed.

Amount of memory (in megabytes) for the cloud VM.Memory (MB)

Number of CPU cores on the cloud VM.CPU Cores

Amount of disk space (in gigabytes) for the cloud
VM.

Disk (GB)

Instantiating a Cloud VM from a Deployed Template or Local VM
You can instantiate a cloud VM if the following are available:

• A deployed template on the cloud

• A VM in your data center

If you instantiate a cloud VM from a VM that has a static IP address in the enterprise data center, you can
access the cloud VM by using the same enterprise IP address. If you instantiate a cloud VM from a VM that
uses DHCP in the enterprise data center, you can access the cloud VM by using the IP address that the VM
obtained from the DHCP server. After the cloud VM is created, the Prime Network Services Controller UI
displays the enterprise IP address details for your reference.
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Procedure

Step 1 Choose InterCloud Management > Public Cloud > VPCs > vpc > VMs.
Step 2 Click Instantiate New VM.

The Instantiate New VMWizard opens.

Step 3 In the Infrastructure screen, choose the required InterCloud Link from the drop-down list, then click Next.
Step 4 In the Source screen, do one of the following:

To use a VM in your data center:

1 In the Source VM tab, navigate to and select the required data center, cluster, host, or resource pool.

2 From the list of VMs, select the VM to use for the cloud VM.

3 Click Next.

To use a deployed template:

1 Click the Source Template tab.

2 From the list of templates, choose the template you want to use for the cloud VM.

3 Click Next.

Step 5 In the VM Properties screen, provide the information as described in VM Properties Screen, on page 247,
then click Next.

Step 6 In the Network Properties screen, provide the following information, then click Next. The information you
need to enter depends on whether you are using a VM or a template to instantiate the cloud VM:
a) For both VMs and templates, in the NICs table, right-click a NIC entry and choose Edit. In the Edit NIC

dialog box, select the required port profile from the drop-down list, then click OK.
The port profile always belongs to a specific VLAN. Select the port profile according to the
VLAN to which the NIC belongs.

Note

b) For templates, also provide the following DNS information:

1 DNS Server 1—Enter the IP address for the first DNS server.

2 DNS Server 2—Enter the IP address for the second DNS server. This IP address cannot be the same
as that for the first DNS server.

3 Domain Name—Enter the DNS domain name.

Step 7 In the Summary and Apply screen, do one of the following, depending to the source of the cloud VM:
If the source is a VM in your data center:

1 In the Upon Successful Migration field, indicate whether or not the source VM should be deleted from
vCenter after the cloud VM is instantiated. If you choose to delete the VM from vCenter, the deletion is
permanent and the VM cannot be retrieved.

2 Confirm that the rest of the information is correct.

3 Click Finish.

If the source is a deployed template:
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1 Confirm that the information is accurate.

2 Click Finish.

Field Descriptions

VM Properties Screen

DescriptionField

Cloud VM name.VM Name

Username for SSH access.SSH User

OS Information

VM operating system (read-only):
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

OS

VM architecture (read-only): 32-bit, 64-bit, or
Unknown.

Architecture

Template Properties

The following fields display values for both the template and the cloud VM. The template values are
read-only, but you can modify the values for the cloud VM as needed.

Amount of memory (in megabytes) for the VM.Memory (MB)

Number of CPU cores for the VM.CPU Cores

Amount of disk space (in gigabytes) for the VM.Disk (GB)

Instantiating a Cloud VM by Migrating an Enterprise VM
You can migrate an existing VM in your data center to the cloud and thereby create a new cloud VM. After
you migrate the enterprise VM to the cloud, you cannot migrate it back to the enterprise data center. However,
when you migrate the VM to the cloud, you can retain the original VM in the data center.

Do not make any changes to a VM or its structure in VMware vCenter while the VM is being migrated
to the cloud. Similarly, do not make any changes to a VM or its structure in VMware while aborting the
migration of the VM to the cloud. If you need to make changes in VMware vCenter that affect the VM,
abort or terminate any migration in progress, make the changes in VMware vCenter, and then migrate the
VM to the cloud.

Note
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Before You Begin

• Ensure that at least one interface is enabled on the VM.

• Disable any service or application on the VM that uses port 22. After migration, the SSH server that is
installed on the cloud VM listens on port 22 for communications with PrimeNetwork Services Controller.

Procedure

Step 1 Choose InterCloud Management > Enterprise > VMManagers.
Step 2 In the navigation pane, navigate to and select the data center, cluster, host, or resource pool with the required

template.
Step 3 In the VMs table, select the VM to use for the VM template, then clickMigrate VM to Cloud.
Step 4 In the Infrastructure screen, select the InterCloud link to use for the VM template, then click Next.
Step 5 In the VM Properties screen, provide the information described in VM Properties Screen, on page 248, then

click Next.
Step 6 In the Network Properties screen, optionally assign a port profile to each NIC as follows, then click Next:

a) Right-click the NIC, then click Edit.
b) In the Edit NIC dialog box, choose the required port profile from the Port Profile drop-down list, then

click OK.

Step 7 In the Summary and Apply screen:
a) In the Upon Successful Migration field, indicate whether or not the data center VM is to be deleted after

the template is successfully created on the cloud.
b) Confirm that the rest of information is correct.
c) Click Finish.

Field Descriptions

VM Properties Screen

DescriptionField

Original VM name.VM Name

Username for SSH access.SSH User

OS Information

VM operating system (read-only):
CommunityEnterprise OS (CentOS), Red Hat
Enterprise Linux (RHEL), Windows, or Unknown.

OS

VM architecture (read-only): 32-bit, 64-bit, or
Unknown.

Architecture
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DescriptionField

Template Properties

The following fields display values for both the enterprise VM and the cloud template. The enterprise values
are read-only, but you can modify the values for the cloud template.

Amount of memory (in megabytes) for the VM.Memory (MB)

Number of CPU cores for the VM.CPU Cores

Amount of disk space (in gigabytes) for the VM.Disk (GB)

Managing InterCloud Links
In addition to creating InterCloud links, you can update them, delete them, monitor their status, or troubleshoot
related issues. For more information, see the following topics:

• Updating an InterCloud Link, on page 249

• Updating an InterCloud Link in High Availability Mode, on page 250

• Deleting an InterCloud Link, on page 250

• Monitoring InterCloud Resources and Status, on page 251

• Troubleshooting InterCloud Issues, on page 255

Updating an InterCloud Link
Prime Network Services Controller enables you to update the images for an InterCloud Extender and Switch
for a deployed link.

If you undeploy an InterCloud link while the InterCloud link is being upgraded, the InterCloud Switch
might not be terminated on the cloud. If this occurs, you will need to manually remove the InterCloud
Switch from the cloud when the link is undeployed.

Note

Before You Begin

Ensure that a VM Manager is configured in Prime Network Services Controller.

Procedure

Step 1 Choose InterCloud Management > InterCloud Link > VPCs > vpc > intercloud-link.
Step 2 Click Update.
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The InterCloud Link Update Wizard is displayed.

Step 3 In the InterCloud Link screen, check the check boxes of the images to update, then clickNext. You can update
one or both images.
The screens that are displayed in the wizard depend on the images that you select. For example, if you select
to update the InterCloud Extender image, the screen for the InterCloud Switch image is not displayed.

Step 4 In the InterCloud Extender screen:
a) Click Refresh to ensure that the latest information is displayed.

The table is refreshed with the available InterCloud Extender templates.

b) Select the required InterCloud Extender template, then click Next.

Step 5 In the Select VM Placement screen, navigate to and select the VM host to use for the update, then click Next.
Step 6 In the InterCloud Switch screen, select the image for the update, then click Next. Whether you update one or

both images, the images must have the same version.
Step 7 In the Summary screen, confirm that the information is correct, then click Finish.

Updating an InterCloud Link in High Availability Mode
Use this procedure to update both the primary and secondary devices in an InterCloud link that is configured
for high availability.

Procedure

Step 1 Update the InterCloud link as described in Updating an InterCloud Link, on page 249.
Step 2 Trigger a switchover as follows:

a) Choose InterCloud Management > InterCloud Link > VPCs > vpc.
b) In the InterCloud Links table, select the link that you updated in Step 1, and click Switchover.

Step 3 Update the InterCloud link again.

Deleting an InterCloud Link
If you need to delete an InterCloud link, you can safely do so after terminating all VMs that are associated
with the link and moving the link to the Undeployed state.

If you undeploy an InterCloud link, the InterCloud Switch template used by this InterCloud link is not deleted
because it can be used by other InterCloud links. Instead, if you undeploy an InterCloud link while the creation
of InterCloud Switch template is in progress, the template creation process continues.

If desired, you can delete the InterCloud Switch template while it is being deployed, which will stop the
template deployment. To delete an InterCloud Switch template, choose InterCloudManagement > InterCloud
Link > InterCloud Switch Templates > switch-template, and then click Delete.

In rare situations, you might encounter a scenario in which the following events occur:
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1 You create an InterCloud link that refers to an InterCloud Extender that is registered to Prime Network
Services Controller.

2 The InterCloud Extender client is in the lost-visibility operational state in the Service Registry
(Administration > Service Registry > Clients).

3 You delete the InterCloud Extender client from the Service Registry and then try to deploy the InterCloud
link, which fails because the InterCloud Extender no longer exists.

If you encounter this situation, after you delete the InterCloud Extender client from the Service Registry, also
delete the InterCloud link that refers to the deleted InterCloud Extender.

Procedure

Step 1 Choose InterCloud Management > Public Cloud > VPCs > vpc > VMs.
Step 2 In the VMs table, select each VM that is associated with the link you want to delete, then click Abort or

Terminate. The Abort option is available while the VM is being created, and the Terminate option is available
after the VM has been created.

Step 3 After the VMs have been terminated or aborted, choose InterCloud Management > InterCloud Link >
VPCs > vpc.

Step 4 In the InterCloud Links table, select the link that you want to delete, then click Undeploy.
Step 5 After Prime Network Services Controller displays Undeployed in the Deploy State column for that link, select

the link and click Delete.
Step 6 When prompted, confirm the deletion.

Monitoring InterCloud Resources and Status
Prime Network Services Controller provides the following options for monitoring InterCloud resources and
status:

• Recent Jobs Table, on page 251

• Monitoring Tab, on page 252

• Status Fields and Labels, on page 253

• Task Tabs, on page 253

• Faults Table, on page 254

• Audit Logs, on page 255

Recent Jobs Table
The Recent Jobs table appears by default for the following tabs under InterCloud Management:

• Enterprise

• Public Cloud
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• InterCloud Link

The table displays recent jobs submitted with the most recent job at the top, and the number of job records in
the table. The jobs are displayed for 12 hours. Each job contains the following information:

DescriptionField

Job name.Name

Job status and duration (in days, hours, minutes, and
seconds).

Status

Job description.Description

Associated message issued for the job.Message

Number of retries for the job.Retry Count

Date and time when the job started.Start Time

Date and time when the job completed.End Time

Some jobs, such as creating an InterCloud link, contain subordinate tasks. Expand the icon next to the job
name in the Recent Jobs table to view subordinate tasks and their status.

You can resize the table as needed to view more or fewer jobs, and you can minimize the table until needed
by clicking the icon next to the table name or the Minimize icon.

Monitoring Tab
Prime Network Services Controller monitors and displays statistical information for InterCloud links and
cloud VMs. This information is displayed in a Monitoring tab that is available by choosing either of the
following:

• InterCloud Management > Public Cloud > VPCs > vpc > intercloud-link > Monitoring tab

• InterCloud Management > Public Cloud > VPCs > vpc > InterCloud Links tab > intercloud-link >
Edit > Monitoring tab

The following table describes the information that is displayed in the Monitoring tab:
DescriptionField

Date and time that the information was last updated.Last Refresh Time

Refreshes the information that is displayed.Refresh

Table

Cloud VM name.Name

Percent CPU used.CPU
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DescriptionField

Percent memory used.Memory

Time that the statistics were collected.Collection Time

Number of receive errors.Rx Errors

Number of receive packets.Rx Packets

Number of transmission errors.Tx Errors

Number of transmission packets.Tx Packets

Status Fields and Labels
Status fields with labels and icons are available in many screens and dialog boxes throughout Prime Network
Services Controller. In InterCloud Management, depending on the object, common statuses are:

• Deploying

• Deployed

• Undeploying

• Undeployed

• In-progress

• Completed

• Failed

• Aborted

• Success

Icons accompany these statuses for quick visual reference.

Task Tabs
Task tabs are available in many of the Edit and Properties dialog boxes for InterCloud resources. These dialog
boxes include:

• Edit InterCloud Extender

• Edit InterCloud Switch

• Edit Infrastructure Image

• Edit InterCloud Agent Image

• InterCloud Switch Template Properties

• Edit Provider Account
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• Edit VM Image

• InterCloud Switch Template Properties

The Task tab includes the following information, enabling you to monitor the status of the specific object:
DescriptionField

Task description.Description

Task status.Status

Description of the current stage.Stage Descriptor

Number of times the task has been tried.Tries

Status of the previous task only.

This field does not provide the status of the current task.

Previous Status

Remote error code.Remote Err Code

Description of the remote error.Remote Err Description

Remote error result.Remote Inv Result

Date and time when the task completed.Time Stamp

Progress of the current task, indicated by the percent complete, a
progress bar, or both.

Progress

Faults Table
Faults tables are present throughout the Prime Network Services Controller UI in main screens and many
dialog boxes. Fault tables assist in troubleshooting andmonitoring status by providing the following information:

DescriptionField

One of the following fault severities:

• Critical

• Major

• Minor

•Warning

• Info

• Condition

• Cleared

Severity
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DescriptionField

Managed object that is affected by this fault.

Click the object name to view the properties for this object.

Affected Object

Unique identifier associated with the event that caused the fault.Cause

Date and time when the severity last changed.

If the severity has not changed, the original creation date is displayed.

Last Transition

Acknowledged state.Ack

One of the following fault types:

• fsm

• environmental

• equipment

Type

Fault description.Description

To view more information about a fault and optionally acknowledge it, double-click the fault. The Fault
Properties dialog box is displayed with additional details.

Audit Logs
The InterCloud Management tab includes a Diagnostics subtab with an Audit Logs entry. When monitoring
InterCloud status or troubleshooting InterCloud issues, the Audit Logs table can provide the following
information:

• Unique entry identifier

• Object associated with the entry

• User associated with the entry

• Date and time the fault occurred

• Action associated with the entry: Creation, Modification, or Deletion

• Cause associated with the entry

• Description

Troubleshooting InterCloud Issues
The following topics describe how to resolve problems that can arise when using InterCloud resources:

• Amazon Marketplace Images Are Not Available, on page 256
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• Incorrect Cloud VM Licensing Model, on page 256

• InterCloud Clients Lose Connectivity to Prime Network Services Controller, on page 256

• Prime Network Services Controller Does Not Display IP Addresses for Cloud VMs, on page 257

Amazon Marketplace Images Are Not Available
If AmazonMarketplace images are not available when you attempt to create an InterCloud link using the Add
InterCloud Link Wizard, use the information in the following table to identify and fix the issue:

Do This:If This Occurs:

In the Configure InterCloud Link Screen, confirm
that the Use Marketplace ICS check box is checked.

In the InterCloud Switch screen, the Refresh
Marketplace button is dimmed or invisible, and only
user-created and local InterCloud Switch images are
displayed.

In the Configure InterCloud Link Screen, confirm
that the Use Marketplace ICS check box is checked.

In the InterCloud Switch screen, only user-provided
and local InterCloud Switch images are displayed.

Confirm that the provider account and the provider
region are correct.

In InterCloud Switch screen, Amazon Marketplace
images are not discovered even after you click
Refresh Marketplace.

Incorrect Cloud VM Licensing Model

Prime Network Services Controller does not support the Provider Licensing model.Note

If you notice that platform (cloud VSM) licensing is being enforced for an InterCloud link even though the
link was created by using Amazon Marketplace, use the following procedure to resolve the issue.

Procedure

Step 1 Confirm that the cloud VSM is the same version as that included in the Prime Network Services Controller
bundle.

Step 2 Confirm that Prime Network Services Controller has indicated that the cloud VSM is to run in Marketplace
mode instead of using InterCloud licensing.

InterCloud Clients Lose Connectivity to Prime Network Services Controller
InterCloud clients might lose connectivity to Prime Network Services Controller upon occasion. For example,
if the Prime Network Services Controller server's IP address and shared secret are changed via the CLI while
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an InterCloud link is configured, the InterCloud clients will lose connectivity with the Prime Network Services
Controller server and will not be able to reconnect.

Use the following procedure to reestablish connectivity for the VSM, InterCloud Extender, and InterCloud
Switch clients.

You must manually update the IP address of the VSM whether or not an InterCloud link is deployed.Note

Procedure

Step 1 Using SSH, connect to the VSM, and update the IP address and shared secret password for Prime Network
Services Controller.

Step 2 Using SSH, connect to the InterCloud Extender and update the Prime Network Services Controller IP address.
Step 3 Using the GUI:

a) Choose InterCloud Management > InterCloud Link > VPCs > vpc > intercloud-link.
b) Click the InterCloud Link tab.
c) In the InterCloud Switch table, select the required switch and click Reboot.

After the InterCloud Switch reboots, it will reestablish connectivity.

Prime Network Services Controller Does Not Display IP Addresses for Cloud VMs
Occasionally, Prime Network Services Controller does not display IP addresses for cloud VM instances. For
example, this situation occurs if you instantiate a cloud VM from a VM that uses DHCP in the enterprise data
center. If this occurs, you can view the cloud VM IP addresses by entering the show org port brief command
on the VSM or by using the following procedure.

Procedure

Step 1 Create a port profile and include the org root command.
Step 2 When creating a cloud VM, assign a port profile that has the org defined.
Step 3 After the cloud VM is instantiated, initiate traffic on the DHCP IP address so that it appears in the IP database

(IPDB) on the InterCloud Switch.
Step 4 On the InterCloud Switch, enter the following command to obtain the IP address:

show intercloud vm vm-name system info
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Creating AMI Images from VMs
Prime Network Services Controller enables you to create Amazon Machine Image (AMI) images from
Windows and Linux VMs in your enterprise data center.

For bothWindows and Linux VMs, you can obtain a virtual machine VMDK file by completing the following
steps:

1 Power off the VM on the vCenter Client.

2 Select the VM.

3 In the vCenter Client, choose File > Export OVF Template to export the VM as a single OVA file.

4 Use the tar utility to untar the exported file and obtain the VM's disk.

For more information on creating AMI images from VMs, see the following topics:

• Creating an AMI Image from a Windows VM, on page 258

• Creating an AMI Image from a Linux VM, on page 259

Creating an AMI Image from a Windows VM
This procedure enables you to create an Amazon Machine Image (AMI) image from a Windows VM and
import it as a VM image into Prime Network Services Controller.

Before You Begin

• Confirm that the following firewall ports are open on the Windows firewall on any third-party firewall
installed in the VM:

• 22—TCP

• 6644—TCP, UDP

• Ensure that IPv4 is enabled on the VM's NICs as follows:

1 Open ncpa.cpl.

2 For each NIC in the VM, right-click and confirm that IPv4 is enabled.
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Procedure

Step 1 Download icami.exe from http://www.cisco.com/go/services-controller.
Step 2 In VMware vCenter, upload the downloaded icami.exe file to your Windows VM running on vCenter.
Step 3 Run icami.exe with admin privileges.
Step 4 Shut down the Windows VM.
Step 5 Using vCenter, export the OVF template as OVA.
Step 6 Extract the VMDK from the OVA.
Step 7 Using dd or a similar utility, convert the VMDK to raw images.
Step 8 Using gzip or bzip, compress the images.
Step 9 Using the Prime Network Services Controller GUI, import the VM image by choosing InterCloud

Management > Enterprise > VM Images > Import VM Image.

Creating an AMI Image from a Linux VM
This procedure describes how to create an Amazon Machine Image (AMI) image from a Linux VM. After
you create the AMI image, you can import it as a VM image into Prime Network Services Controller.
This procedure uses the vmware-mount utility, which is a part of the vSphere disk development tool that
you can download fromhttps://my.vmware.com/web/vmware/details?productId=2&downloadGroup=VDDK50.

Procedure

Step 1 Download the VM disk image (VMDK) onto a Linux host.
Step 2 Mount the VMDK as a flat file by using the vmware-mount command, as follows:

# vmware-mount -f vmdk-image /mount/point

where vmdk-image is the VMDK filename and /mount/point is the desired directory.

Step 3 Attach a loop device to the flat file by using the losetup command:

# losetup /dev/loopn /mnt/vmdk/file

where loopn is the loop device and file is the name of the flat file.

Step 4 Access partitions on the disk image as follows:
a) Enter the fdisk command to view the disk partitions as shown in the following example for loop device

/dev/loop0 :

# fdisk -l /dev/loop0

Device Boot Start End Blocks Id System
/dev/loop0p1 * 1 64 512000 83 Linux
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/dev/loop0p2 64 784 5778432 8e Linux LVM

b) Create a device for each partition on the disk image by entering the kpartx command, as follows:

# kpartx -a /dev/loop0
# ls /dev/mapper/
control loop0p1 loop0p2

This command creates device files for all physical partitions on the disk file and maps the logical volumes
that reside in the partition.

c) (Optional) Enter the pvscan command to identify the volume groups that are present on the disk image.
The command with example output resembles the following:

# pvscan

PV /dev/mapper/loop0p2 VG vg_mowgli lvm2 [5.51 GiB / 0 free]

In this example, the second partition (/dev/mapper/loop0p2) contains the volume group vg_mowgli.

d) (Optional) View the logical volumes by entering the lvscan command as shown in the following example:

# lvscan
inactive '/dev/vg_mowgli/lv_root'[1.85 GiB] inherit
inactive '/dev/vg_mowgli/lv_swap'[3.66 GiB] inherit

Step 5 Mount the partitions and logical volume to recreate the Linux file system hierarchy under / (root) by completing
the following steps:

In this example, the logical volume /dev/vg_mowgli/lv_root is the root (/) partition.Note

a) Activate the logical volume by using the lvchange command so that it can be mounted:

# lvchange -ay /dev/vg_mowgli/lv_root

b) Mount the logical volume on a directory on the host system (/mnt/fs in this example):

# mount /dev/vg_mowgli/lv_root /mnt/fs/

c) List the contents of the logical volume to confirm that this is the root of the filesystem:

# ls /mnt/fs/
bin boot cgroup dev etc home lib lib64 lost+found media mnt opt proc
root sbin selinux
srv sys tmp usr var

d) Obtain the filesystem mount points by entering the cat command:

# cat /mnt/fs/etc/fstab

/dev/mapper/vg_mowgli-lv_root / ext4 defaults 1 1
UUID=44cb64be-62bc-4297-9a8d-beb3493a2362 /boot ext4 defaults

1 2
/dev/mapper/vg_mowgli-lv_swap swap swap defaults 0 0
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In this example:

• /dev/mapper/vg_mowgli-lv_root mounts at /.

• /dev/mapper/vg_mowgli-lv_swap is the swap partition.

• The partition with the UUID 44cb64be-62bc-4297-9a8d-beb3493a2362 mounts at /boot.

e) Obtain the UUID and LABEL of a partition by entering the blkid command on the partition device file:

# blkid /dev/mapper/loop0p1

/dev/mapper/loop0p1:UUID="44cb64be-62bc-4297-9a8d-beb3493a2362"
TYPE="ext4"

f) Recreate the filesystem by using the information gained from the fstab command:

# mount /dev/mapper/loop0p1 /mnt/fs/boot/

The Linux file system is successfully recreated with all partitions mounted as in fstab. That is, the file
system present on vmdk has been recreated inside the /mnt/fs directory on the host system.

Step 6 Validate the image for the Amazon Xen Hypervisor by completing the following steps:
a) Verify that the operating system and version are supported by Prime Network Services Controller by

checking the contents of the file etc/redhat-release:

# cat /mnt/fs/edt/redhat-release
Red Hat Enterprise Linux Server release 6.2 (Santiago)

b) Review the contents of grub.conf to determine the version of Linux kernel present on the filesystem that
is set to boot by default. The following example displays the contents of a grub.conf file and provides the
following information:

• The value of the parameter default identifies the default entry (0).

• A single kernel is present in the disk image and is set to boot by default.

• The version of the kernel that is set to boot by default is displayed in the kernel entry. In this example,
the version is 2.6.32-220.el6.x86_64.

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this
file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/mapper/vg-mowgli-lv_root
# initrd /initrd-[generic-]version.img
# boot
default=0
timeout=5
splashimage-(hd0,0)/grub/splash.xmp.gz
hiddenmenu
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title Red Hat Enterprise Linux (2.6.32-220.el6.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.32.220.el6.x86_64 ro

root=/dev/mapper/vg_mowgli-lv_root
initrd /initramfs-2.6.32-220.el6.x86_64.img

c) In the file /mnt/fs/boot/config-kernel-version, verify that the following flags are set to y:

• CONFIG_PARAVIRT_GUEST=y

• CONFIG_XEN=y

• CONFIG_PARAVIRT=y

• CONFIG_NETFILTER=y

Step 7 Create a new disk image to copy the filesystem present on the VMDK by completing the following steps:
a) Create a new disk by using the qemu-img command:

qemu-img create -f raw myami.img 6G
Formatting 'myami.img', fmt=raw size=6442450944

b) Attach the new image file to a loop device and format it so that it is the same as the source VMDK image
filesystem:

# losetup /dev/loop1 myami.img
# mkfs.ext4 /dev/loop1

c) Label the new image, as in the following example:

# e4label /dev/loop1 _/
# blkid /dev/loop1
/dev/loop1: LABEL="_/" UUID="9cf14199-a0ff-4501-bb2f-9a7bc020b1e2"
TYPE="ext4"

d) Mount the new image file:

# mkdir /mnt/amifs
# mount /dev/loop1 /mnt/amifs

Step 8 Copy the file system contents from the source image to the new image:

# cp -ar /mnt/fs/* /mnt/amifs/

Step 9 Configure the new image as described in the following steps:
a) Modify /mnt/amifs/etc/fstab so that it reflects the partitioning on the new image. For example:

LABEL=_/ ext4 defaults 1 1
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
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b) Create a udev rule to change the first Ethernet interface to csc0 by creating the file
/mnt/amifs/etc/udev/rules.d/70-persistent-net.rules and adding the following content:

SUBSYSTEM=="net", DRIVERS=="vif", ATTRS{nodename}=="device/vif/0",
NAME="csc0"

c) Create an interface file named /mnt/p1/etc/sysconfig/network-scripts/ifcfg-csc0 and add the following
content:

ONBOOT=yes
DEVICE=csc0
BOOTPROTO=dhcp

d) Enable networking by editing the file /mnt/amifs/etc/sysconfig/network and setting NETWORKING to
yes.

e) Edit grub.conf so that it looks similar to the following:

default=0
timeout=2
title Red Hat Enterprise Linux (2.6.32-71.el6.x86_64)

root (hd0)
kernel /boot/vmlinuz-2.6.32-71.el6.x86_64 ro root=LABEL=_/

selinux=0 console=hvc0

Step 10 Add the driver RPM by completing the following steps:
a) Create the directory /mnt/amifs/opt/.cisco and copy the driver RPM into this directory:

mkdir -p /mnt/amifs/opt/.cisco
cp csw.1.1.2.rhel6_2.x86-64.rpm /mnt/amifs/opt/.cisco

b) Create the files version_cur and version_gold in /opt/.cisco and place the driver version in each file. You
can obtain the driver version from the name of the file. For example, a file with the name
csw.1.1.2.rhel6_2.x86_64 has the driver version 1.1.2.

cat /mnt/amifs/opt/.cisco/version_cur
1.1.2
cat /mnt/amifs/opt/.cisco/version_gold
1.1.2

c) For each ifcfg-ethn file in /mnt/amifs/sysconfig/network-scripts/, create an entry in interface.conf using
the syntax interface-interface-number,interface-name,random-mac-address where:

• interface-number is the number assigned to the interface, starting with 1.

• interface-name is the name assigned to the interface.

• random-mac-address is a MAC address.

The following is an example interface.conf file for two interfaces:

cat /mnt/amifs/opt/.cisco/interface.conf
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interface-1,ether0,00:0f:f7:dd:8a:37
interface-2,ether1,00:0f:f7:34:40:ae

Step 11 Add the initialization scripts for starting the subagent:

# cp csw /mnt/amifs/etc/init.d/
# chroot /mnt/amifs/ chkconfig --level 34 csw on

Step 12 Add the getkeys script for fetching Amazon keys:

# cp getkeys /mnt/amifs/etc/init.d/
# chroot /mnt/amifs/ chkconfig --34 getkeys on

Step 13 Unmount and close the AMI image by entering the following commands:

//Unmount the disk image file
# umount /mnt/amifs/

//Detach the loop device
# losetup -d dev/loop0

Step 14 Unmount and close the VMDK by entering the following commands:

//Unmount partitions
# umount /mnt/fs/boot
# umount /mnt/fs

//Deactivate all logical volumes present
# lvchange -an /dev/vg-mowgli/lv_root

//Delete device mappings
# kpartx -d /dev/loop0

//Detach the loop device
# losetup -d /dev/loop0

//Unmount the VMDK file
# vmware-mount -d /mnt/vmdk

   Cisco Prime Network Services Controller 3.2 User Guide
264

Configuring InterCloud Resources
Creating an AMI Image from a Linux VM



C H A P T E R  14
Configuring Administrative Operations

This section includes the following topics:

• Administrative Operation Conventions, page 265

• Managing Backup Operations, page 265

• Restoring a Backup Configuration, page 270

• Managing Export Operations, page 274

• Configuring Import Operations, page 278

Administrative Operation Conventions
The following conventions apply when performing the administrative operations described in this section:

• The remote file location you specify must start with a slash (/) and include the full path and file name.
Do not use relative paths.

• The user name and password on the remote system must be correct, and the user specified must have
read and write permissions on the remote system.

• The file on the remote system must be a valid file, and the size cannot be zero.

• For backup and export operations, if the Task tab contains a Remote Err Description of No such file,
reboot the Prime Network Services Controller VM via vCenter.

Managing Backup Operations
We recommend that you use backup and restore operation as a disaster recovery mechanism. To migrate
configuration data from one Prime Network Services Controller server to another, use export and import
operations.
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Creating a Backup Operation

Before You Begin

Obtain the backup server IP address or hostname and authentication credentials.

Procedure

Step 1 Choose Administration > Operations.
Step 2 Click Create Backup Operation.
Step 3 In the Create Backup Operation dialog box, complete the following fields, then click OK:

DescriptionField

One of the following administrative states:

• enabled—Backup is enabled. The system runs
the backup operation when you click OK.

• disabled—Backup is disabled. The system does
not run the backup operation when you click
OK. If you choose this option, all fields in the
dialog box remain visible.

Admin State

Backup type.

The backup creates a copy of the whole database file.
You can use this file for disaster recovery if you need
to recreate every configuration on your system. This
field is not editable.

Type

Protocol used when communicating with the remote
server:

• FTP

• SCP

• SFTP

Protocol

Hostname or IP address of the device where the
backup file is stored.

This entry cannot be changed when editing the
operation.

If you use a hostname instead of an IP
address, you must configure a DNS server.

Note

Hostname/IP Address

Username the system uses to log into the remote
server.

User
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DescriptionField

Password the system uses to log into the remote
server.

This field is displayed if you choose enabled in the
Admin State field.

Prime Network Services Controller does not
store this password. You do not need to enter
this password unless you intend to enable
and run the backup operation immediately.

Note

Password

Full path of the backup filename.

This entry must start with a slash (/) and must not
contain a relative path.

Absolute Path Remote File

Running a Backup Operation

Procedure

Step 1 Choose Administration > Operations > Backup-server where backup-server is the server on which the
backup file is stored.

Step 2 In the General tab, enter the following information:
a) In the Admin State field, choose enabled.
b) In the Password field, enter the password for the identified user.
c) (Optional) Change the content of the other available fields.

Step 3 Click Save.
Prime Network Services Controller takes a snapshot of the configuration type that you selected and uploads
the file to the network location.

Step 4 (Optional) To view the progress of the backup operation, click the Task tab. The Task tab provides the
information described in the following table. The operation continues to run until it is completed.

DescriptionField

Task description.Description

Task status.Status

Description of the current stage.Stage Descriptor

Number of times the task has been tried.Tries

Cisco Prime Network Services Controller 3.2 User Guide    
267

Configuring Administrative Operations
Running a Backup Operation



DescriptionField

Status of the previous task only.

This field does not provide the status of the current task.

Previous Status

Remote error code.Remote Err Code

Description of the remote error.Remote Err Description

Remote error result.Remote Inv Result

Date and time when the task completed.Time Stamp

Progress of the current task, indicated by the percent complete, a
progress bar, or both.

Progress

Editing a Backup Operation

Before You Begin

Obtain the backup server IP address or hostname and authentication credentials.

Procedure

Step 1 Choose Administration > Operations.
Step 2 Select the backup operation you want to edit, then click Edit.
Step 3 In the Edit Backup dialog box, modify the information as required, then click OK.

DescriptionField

One of the following administrative states:

• enabled—Backup is enabled. The system runs
the backup operation when you click OK.

• disabled—Backup is disabled. The system does
not run the backup operation when you click
OK. If you choose this option, all fields in the
dialog box remain visible.

Admin State
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DescriptionField

Backup type.

The backup creates a copy of the whole database file.
You can use this file for disaster recovery if you need
to recreate every configuration on your system. This
field is not editable.

Type

Protocol used when communicating with the remote
server:

• FTP

• SCP

• SFTP

Protocol

Hostname or IP address of the device where the
backup file is stored.

This entry cannot be changed when editing the
operation.

If you use a hostname instead of an IP
address, you must configure a DNS server.

Note

Hostname/IP Address

Username the system uses to log into the remote
server.

User

Password the system uses to log into the remote
server.

This field is displayed if you choose enabled in the
Admin State field.

Prime Network Services Controller does not
store this password. You do not need to enter
this password unless you intend to enable
and run the backup operation immediately.

Note

Password

Full path of the backup filename.

This entry must start with a slash (/) and must not
contain a relative path.

Absolute Path Remote File
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Deleting a Backup Operation

Procedure

Step 1 Choose Administration > Operations.
Step 2 Select the backup operation you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.

Restoring a Backup Configuration
Procedure

Step 1 Install the Prime Network Services Controller virtual machine. For information, see the Cisco Prime Network
Services Controller 3.2 Quick Start Guide.

Step 2 Uninstall the VSG policy agents. Connect the Secure Shell to the VSG console for this task. This step does
not disrupt traffic.

Perform this step for all VSGs that are associated with the Prime Network Services Controller that
you are restoring.

Note

Example:

VMware

vsg# conf t

vsg(config)# vnmc-policy-agent

vsg(config-vnmc-policy-agent)# no policy-agent-image

Hyper-V Hypervisor

vsg# conf t

vsg(config)# nsc-policy-agent

vsg(config-nsc-policy-agent)# no policy-agent-image

Step 3 Disable the ASA 1000V policy agent.

Example:

VMware
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asa# conf t

asa(config)# no vnmc policy-agent

Hyper-V Hypervisor

Not available.

Step 4 Uninstall the VSM policy agents. Connect the Secure Shell to the VSM console for this task. This step does
not disrupt traffic.

Perform this step for all VSMs that are associated with the Prime Network Services Controller you
are restoring.

Note

Example:

VMware

vsm# conf t

vsm(config)# vnmc-policy-agent

vsm(config-vnmc-policy-agent)# no policy-agent-image

Hyper-V Hypervisor

vsm# conf t

vsm(config)# nsc-policy-agent

vsm(config-nsc-policy-agent)# no policy-agent-image

Step 5 Restore the Prime Network Services Controller database. Connect the Secure Shell to the Prime Network
Services Controller CLI for this task. Depending upon your Prime Network Services Controller backup
location, restore using FTP, SCP, or SFTP.

Example:
nsc# connect local-mgmt

nsc(local-mgmt)# restore scp://username@server/path

Step 6 In the Prime Network Services Controller GUI, choose Resource Management > Resources > VSMs, and
do the following:
a) Wait until each registered VSM displays the operational status of lost-visibility.
b) Choose each VSM, and click Delete.

Step 7 In the Prime Network Services Controller GUI, choose Resource Management > Resources > VSMs, and
verify that the deleted VSMs are not displayed.

Step 8 Reregister the VSMs associated with PrimeNetwork Services Controller by entering the following commands
for each VSM:

Example:
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VMware

vsm# conf t

vsm(config)# vnmc-policy-agent

vsm(config-vnmc-policy-agent)# registration-ip PrimeNSC-ip-address

vsm(config-vnmc-policy-agent)# shared-secret password

Hyper-V Hypervisor

vsm# conf t

vsm(config)# nsc-policy-agent

vms(config-nsc-policy-agent)# registration-ip PrimeNSC-ip-address

vsm(config-nsc-policy-agent)# shared-secret password

Step 9 Reinstall the VSM policy agents.
If the VSM policy agents must be upgraded, install the new software
now.

Note

Example:

VMware

vsm# conf t

vsm(config)# vnmc-policy-agent

vsm(config-vnmc-policy-agent)# policy-agent-image bootflash:nsc-vsmpa.n.n.n.bin

Hyper-V Hypervisor

vsm# conf t

vms(config)# nsc-policy-agent

vsm(config-nsc-policy-agent)# policy-agent-image bootflash:nsc-vsmpa.n.n.n.bin

Step 10 Wait until all the VSMs have registered with Prime Network Services Controller and are displayed under
Resource Management > Resources > VSMs.

Step 11 Reregister the VSGs associated with Prime Network Services Controller by entering the following commands
for each VSG:

Example:

VMware
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vsg# conf t

vsg(config)# vnmc-policy-agent

vsg(config-vnmc-policy-agent)# registration-ip PrimeNSC-ip-address

vsg(config-vnmc-policy-agent)# shared-secret password

Hyper-V Hypervisor

vsg# conf t

vsg(config)# nsc-policy-agent

vsg(config-nsc-policy-agent)# registration-ip PrimeNSC-ip-address

vsg(config-nsc-policy-agent)# shared-secret password

Step 12 Reinstall the VSG policy agents.
If the VSG policy agents must be upgraded, install the new software
now.

Note

Example:

VMware

vsg# conf t

vsg(config)# vnmc-policy-agent

vsg(config-vnmc-policy-agent)# policy-agent-image bootflash:nsc-vsgpa.n.n.n.bin

Hyper-V Hypervisor

vsg# conf t

vsg(config)# nsc-policy-agent

vsg(config-nsc-policy-agent)# policy-agent-image bootflash:nsc-vsgpa.n.n.n.bin

Step 13 Re-enable the ASA 1000V policy agent.

Example:

VMware

asa# conf t

asa(config)# vnmc policy-agent

asa(config-vnmc-policy-agent)# shared-secret password

asa(config-vnmc-policy-agent)# registration host PrimeNSC-ip-address

Hyper-V Hypervisor
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Not available.

Step 14 Verify the following states after the restore process is complete:
The restore process could take a fewminutes depending upon your setup environment.Note

a) Using the VSG CLI, verify that your configurations are restored to their earlier state.
b) Using the Prime Network Services Controller GUI, verify that your objects and policies are restored to

their earlier state.
c) Using the ASA 1000V CLI, verify that your configurations are restored to their earlier state.

Managing Export Operations
Use export and import operations to migrate data from one Prime Network Services Controller server to
another. To back up and restore Prime Network Services Controller data (for example, as a disaster recovery
mechanism), use backup and restore operations.

Creating an Export Operation
The associations of compute and edge firewalls with VSGs and ASA 1000Vs, respectively, are not included
in export or import data. Only firewall definitions are included, such as device profiles and policies. If an
imported firewall did not exist in the system, it will not be associated to a VSG or ASA 1000V after the import
operation. If an imported firewall already existed in the system, the association state remains the same.

InterCloud data is not included in export or import operations. The affected InterCloud data includes:

• Provider account information

• InterCloud links and components

• Cloud VMs

Before You Begin

Obtain the remote file server IP address or hostname and authentication credentials before performing an
export.

Procedure

Step 1 Choose Administration > Operations.
Step 2 Click Create Export Operation.
Step 3 In the Create Export Operation dialog box, provide the required information as described in the following

table, then click OK:
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DescriptionField

One of the following administrative states:

• enabled—Export is enabled. The system runs
the export operation when you click OK.

• disabled—Export is disabled. The system does
not run the export operation when you click
OK. If you choose this option, all fields in the
dialog box remain visible.

Admin State

One of the following export types:

• config-all

• config-logical

• config-system

Type

Protocol used when communicating with the remote
server:

• FTP

• SCP

• SFTP

Protocol

Hostname or IP address of the device where the export
file is stored.

This entry cannot be changed when editing the
operation.

If you use a hostname instead of an IP
address, you must configure a DNS server.

Note

Hostname/IP Address

Username the system uses to log into the remote
server.

User

The password the system uses to log into the remote
server.

This field is displayed if you choose enabled in the
Admin State field.

Prime Network Services Controller does not
store this password. You do not need to enter
this password unless you intend to enable
and run the export operation immediately.

Note

Password

Full path of the .tgz filename.

This entry must start with a slash (/) and must not
contain a relative path.

Absolute Path Remote File (.tgz)
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Editing an Export Operation

The associations of compute and edge firewalls with VSGs and ASA 1000Vs, respectively, are not included
in export or import data. Only firewall definitions are included, such as device profiles and policies. If an
imported firewall did not exist in the system, it will not be associated to a VSG or ASA 1000V after the
import operation. If an imported firewall already existed in the system, the association state remains the
same.

Note

Before You Begin

Obtain the remote file server IP address or hostname and authentication credentials before performing an
export.

Procedure

Step 1 Choose Administration > Operations.
Step 2 In the Operations table, select the export operation you want to edit, then click Edit.
Step 3 In the Edit Export dialog box, modify the fields as appropriate, then click OK.

DescriptionField

One of the following administrative states:

• enabled—Export is enabled. The system runs
the export operation when you click OK.

• disabled—Export is disabled. The system does
not run the export operation when you click
OK. If you choose this option, all fields in the
dialog box remain visible.

Admin State

One of the following export types:

• config-all

• config-logical

• config-system

Type
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DescriptionField

Protocol used when communicating with the remote
server:

• FTP

• SCP

• SFTP

Protocol

Hostname or IP address of the device where the export
file is stored.

This entry cannot be changed when editing the
operation.

If you use a hostname instead of an IP
address, you must configure a DNS server.

Note

Hostname/IP Address

Username the system uses to log into the remote
server.

User

The password the system uses to log into the remote
server.

This field is displayed if you choose enabled in the
Admin State field.

Prime Network Services Controller does not
store this password. You do not need to enter
this password unless you intend to enable
and run the export operation immediately.

Note

Password

Full path of the .tgz filename.

This entry must start with a slash (/) and must not
contain a relative path.

Absolute Path Remote File (.tgz)

Deleting an Export Operation

Procedure

Step 1 In the Navigation pane, choose Administration > Operations.
Step 2 In the Operations table, select the export operation you want to delete.
Step 3 When prompted, confirm the deletion.
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Configuring Import Operations

Creating an Import Operation

Before You Begin

Obtain the remote file server IP address or hostname and authentication credentials.

The association of compute and edge firewalls with VSGs and ASA 1000Vs, respectively, are not included
in the export or import data. Only the compute and edge firewall definitions are included, such as device
profiles and policies. Therefore, if an imported firewall did not exist in the system, it will not be associated
to a VSG or ASA 1000V after the import operation. If an imported firewall already existed in the system,
the association state remains the same.

Note

When the configuration data is imported into the Prime Network Services Controller server, you might
see an error message and get logged out, followed by the display of a new Prime Network Services
Controller certificate. This error occurs because the PrimeNetwork Services Controller hostname, domain
name, or both have changed. The VM Manager Extension needs to be exported again and installed on
vCenter. To continue with the import, accept the Prime Network Services Controller certificate and log
into Prime Network Services Controller again.

Caution

Procedure

Step 1 Choose Administration > Operations.
Step 2 Click Create Import Operation.
Step 3 In the Create Import Operation dialog box, provide the following information as required, then click OK:

DescriptionField

One of the following administrative states:

• enabled—Import is enabled. The system runs
the import operation as soon as you click OK.

• disabled—Import is disabled. The system does
not run the import operation when you click
OK. If you choose this option, all fields in the
dialog box remain visible.

Admin State

Action to be taken on a file: merge.Action
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DescriptionField

Protocol used when communicating with the remote
server:

• FTP

• SCP

• SFTP

Protocol

Hostname or IP address of the device where the
import file is stored.

This entry cannot be changed when editing the
operation.

If you use a hostname instead of an IP
address, you must configure a DNS server.

Note

Hostname/IP Address

Username the system uses to log into the remote
server.

This field is displayed if you choose enabled in the
Admin State field.

User

Password the system uses to log into the remote
server.

Prime Network Services Controller does not
store this password. You do not need to enter
this password unless you intend to enable
and run the import operation immediately.

Note

Password

Full path of the .tgz filename.

This entry must start with a slash (/) and must not
contain a relative path.

Absolute Path Remote File (.tgz)

Editing an Import Operation

Before You Begin

Obtain the remote file server IP address or hostname and authentication credentials.
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Procedure

Step 1 Choose Administration > Operations.
Step 2 Select the import operation that you want to edit, then click Edit.
Step 3 In the Edit dialog box, modify the fields as required, then click OK.

DescriptionField

One of the following administrative states:

• enabled—Import is enabled. The system runs
the import operation as soon as you click OK.

• disabled—Import is disabled. The system does
not run the import operation when you click
OK. If you choose this option, all fields in the
dialog box remain visible.

Admin State

Action to be taken on a file: merge.Action

Protocol used when communicating with the remote
server:

• FTP

• SCP

• SFTP

Protocol

Hostname or IP address of the device where the
import file is stored.

This entry cannot be changed when editing the
operation.

If you use a hostname instead of an IP
address, you must configure a DNS server.

Note

Hostname/IP Address

Username the system uses to log into the remote
server.

This field is displayed if you choose enabled in the
Admin State field.

User

Password the system uses to log into the remote
server.

Prime Network Services Controller does not
store this password. You do not need to enter
this password unless you intend to enable
and run the import operation immediately.

Note

Password
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DescriptionField

Full path of the .tgz filename.

This entry must start with a slash (/) and must not
contain a relative path.

Absolute Path Remote File (.tgz)

Deleting an Import Operation

Procedure

Step 1 Choose Administration > Operations.
Step 2 Select the import operation that you want to delete, then click Delete.
Step 3 When prompted, confirm the deletion.
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